Squeezelite not recognized as player

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezelite not recognized as player

This topic contains 6 replies, has 3 voices, and was last updated by  MarkMutt premium 1 week, 4 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 9. November 2016 at 1:26 #23780

    I can’t get squeeze server to find squeezelite player. It used to work but after buying a new router and restarting my pi it’s not working anymore. I tried rebooting my pi. Also tried restarting service (sudo service squeezelite stop/start) but it’s not shown in the squeezebox server web interface.

    Any advice on how to solve this?

    Best
    Ole

    9. November 2016 at 17:08 #23841

    Hi Ole,
    Please try renaming the device. This also changes the name under which the Squeezelite player is recognised in your Squeezebox Server. Also, which version of the Server have you installed? We recommend 7.9 nightly.

    22. November 2016 at 16:26 #24090

    Heiner,
    Not sure if this is a similar problem to the one Ole has outlined above (apologies for hijacking if you think this is not the case).
    I have recently rebuilt my multi-room speaker systems.
    I used to play my music from a Synology NAS but was concerned about disk thrash so I built a Raspberry Pi with a big USB stick to act as repository (all solid state only read required noatime) ;-).
    I then decided that I only used the Pi-NAS with the speakers so why not build the NAS in ???
    I did this and it worked and used another Pi as another synchronised speaker system – ALL OK
    I recently built 3 more boxes to house Pi’s, PSU’s, Amps and Speakers (and a front button to allow gracefully startup/shutdown)
    I upgraded my images and used them to build the microSD cards on all the M2P Pi devices.
    The server/player works as a server and player sitting on the network (player identified with ‘-s 127.0.0.1’ to speed loading of local player) and also using a WiFi dongle to create an access point for the satellites/me_(with my phone/tablet controller) to connect to if out of the house (also used in Garden or at other people’s parties). The satellites have been configured to connect to multiple WiFi networks (should be allowed under your m2p interface, but had to manually edit ‘/opt/max2play/wpa_supplicant.conf’ to allow this). – Again works okay.
    I don’t like signing in as root (to the samba server to upload more music), so modified your standard fsab offerings to ‘defaults,noatime,rw,uid=0,gid=100,nofail’ so that root ‘pi’ and any other user added to the ‘users’ group can write and all remaining ‘valid’ users just read. – Again all okay.
    I can use the web interface of the LMS server to control / synchronise players, so most everything works fine.
    The issue I have is that I prefer to use ‘Squeezer’ as my phone / tablet interface but though it will identify the server IP address and correct port … it will not identify ANY players. It just reports ‘squeezer’ and sits there doing nothing. ;-(((
    I think I used to have this issue before but it eventually found the local player after a while (which is why I use the ‘-s 127.0.0.1’ on the local player as that reduced the time). I have left these systems for most of a day and still not seen the players show up.
    I have tried (as you suggest above) to rename the players but you do not specify how.
    1. I have renamed them via the LMS web interface (only lasts to the next reboot and doesn’t work anyway)
    2. I have renamed the Library via the LMS web interface (does not seem to affect anything and will not let you reset this to blank afterwards)
    3. I have used the m2p web interface to rename the Pi’s (does not work before the reboot or after it either)
    Is there anything that has changed in the m2p builds (fully updated in all cases) that would affect this ? Or have I been stupid and missed something vital ? Or should I be looking to talk to the ‘Squeezer’ developers to see what they have changed ?
    Thanks
    Mark

    • This reply was modified 1 week, 5 days ago by  MarkMutt. Reason: allowed for the fact that I may have done something wrong ;-(((
    23. November 2016 at 16:33 #24129

    Hi Mark,
    The renaming I was referring to meant the name of the player and subsequently the name of the Pi. Since the preinstalled instance of Squeezelite takes its name from the Pi’s name, you should just change the name “max2play” that is displayed in the menu “Settings/Reboot” of the M2P web interface. After saving and a reboot, the name of the device and of its Squeezelite player should have changed in the LMS interface.
    As mentioned in your 3., this should work. I just confirmed on a test device to make sure. Please try following the steps mentioned above.

    23. November 2016 at 17:33 #24137

    Heiner,
    I have already tried as you suggest, given option number 3. in my response (It didn’t work)
    I have since downloaded “Squeeze Controller” from the Google Play Store. It seems to find the names of the players straight away.
    So between this and the default LMS server web interface at x.x.x.x:9000 (Both work at recognising player names, though I don’t like the “Squeeze Controller” interface much and the LMS Web Interface is a nightmare to use from a phone) It seems to point towards an issue with an upgrade to “Squeezer”. Upgrades seems to get pushed through to me regularly and they just install without permission (not that you ever know which ones are good for you or those that will drive you to distraction).
    I’ve flagged the issue to “https://groups.google.com/forum/#!forum/android-squeezer” as it seems to be their issue (not yours or mine at least 😉 )
    Sorry to have caused any inconvenience, will post back if I get an update.
    Thanks and Regards
    Mark

    23. November 2016 at 19:17 #24145

    Heiner,
    Found this thread on github :-

    Here’s a copy of the text (sometimes links have destinations moved/deleted) :-

    austins68 commented 3 days ago • edited
    I have had to upgrade to LMS 7.9 because of a ReadyNAS firmware upgrade. My Squeezer app stopped working at that point: it was unable to enumerate my players (actually only one). It works with LMS 7.7.

    By experimenting, I was able to determine that the problem was that the reply to the initial CLI query “players 0 20 full_list:1” has changed between 7.7 and 7.9.

    LMS 7.7 replies “players 0 20 full_list:1 count:1 playerindex:0 playerid:xx:xx:xx:xx:xx:xx uuid: ip:192.168.x.x:xxxx name:xxxxxxx model:squeezelite isplayer:1 displaytype:none canpoweroff:1 connected:1”
    LMS 7.9 replies “players 0 20 full_list:1 count:1 playerid:xx:xx:xx:xx:xx:xx uuid: ip:192.168.x.x:xxxxx name:xxxxxxx seq_no:0 model:squeezelite modelname:SqueezeLite power:1 isplaying:0 displaytype:none isplayer:1 canpoweroff:1 connected:1 firmware:v1.8”
    Looking at the Squeezer code, I had a hunch that the “playerindex” parameter was important. I patched the function _addPlayersLoop in /usr/share/perl5/Slim/Control/Queries.pm on my LMS 7.9 to include the parameter, and this did indeed enable Squeezer to work.

    I’m leaving this workaround in place, but the correct fix is probably to allow Squeezer to cope without the “playerindex” parameter.

    I think this is a problem with interop with LMS 7.8 as well.

    UPDATE: Here is a diff for the patch to the above-mentioned file, /usr/share/perl5/Slim/Control/Queries.pm. My version is 7.9.0 – 1479378558. This worked for me, but I offer no warranty. Apply this at your own risk and then restart your LMS service.

    *** a/Queries.pm 2016-11-20 21:23:43.549509849 +0000
    — b/Queries.pm 2016-11-20 21:24:56.434742441 +0000
    ***************
    *** 2346,2351 ****
    — 2346,2353 —-
    if (scalar(@players) > 0) {

    for my $eachclient (@players[$start..$end]) {
    + $request->addResultLoop(‘players_loop’, $cnt,
    + ‘playerindex’, $cnt);
    $request->addResultLoop(‘players_loop’, $cnt,
    ‘playerid’, $eachclient->id());
    $request->addResultLoop(‘players_loop’, $cnt,

    As M2P requires 7.9 nightly and as the current version of Squeezer is 1.4.1 then you are going to get more people with this issue
    It ‘may’ be worthwhile you preparing a patch to apply in a M2P release as otherwise a few people will be getting as frustrated as me.
    The Google group does not seem to be active and Nik Clayton seems to be permanently “away from keyboard”
    Cheers
    Mark

    23. November 2016 at 20:23 #24148

    Heiner,
    Just found another on the logitech forums :-
    http://forums.slimdevices.com/showthread.php?106475-Problem-with-Latest-Nightly-and-Android-Squeezer
    So it seems a small clash appeared between the two code sets and there is a fix available !
    Trying it now … nope will not allow me to uninstall and replace LMS … Or select a new package over the top
    Have to edit the file manually :-
    sudo nano /usr/share/perl5/Slim/Control/Queries.pm
    Look for line with text “for my $eachclient (@players[$start..$end]) {” (without quotes)
    The above line should be line 2348 – check using ‘f11’
    Then insert the text following this line:-

    $request->addResultLoop(‘players_loop’, $cnt,
    ‘playerindex’, $idx);

    Then save and reboot your Pi ;-))))
    It works !!! Squeezer is displaying again !
    This is pretty much as the other post I found above but is specific to an M2P build
    Hope this helps
    Cheers
    Mark

    • This reply was modified 1 week, 4 days ago by  MarkMutt. Reason: missed some info out
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here