Squeezelite not autostarting when Kodi is closed

Max2Play Home 2016 (en) Forums Max2Play Add-ons Squeezelite not autostarting when Kodi is closed

This topic contains 3 replies, has 2 voices, and was last updated by  MarioM Moderator 9 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 19. Februar 2022 at 22:21 #52067

    Hello, I’m using Max2play v.255 with Raspberry Pi 4 B and HifiBerry Amp2. I ticked the setting ‚Disable Built-In Audio‘ in the Raspberry settings tab in order to get Kodi audio working with the HifiBerry. Kodi audio doesn’t work without it.
    However, I ticked the box ‚Autostart Squeezelite‘ in the Audioplayer tab but Squeezelite doesn’t start after I have stopped Kodi. I tried to manually click on the start Squeezelite button but only got an error message:

    Trying to launch … NOT successful Click here to show detailed information
    [10:09:58.258155] test_open:310 playback open error: No such file or directory
    [10:09:58.258357] output_init_common:382 unable to open output device

    I found out that the way to make Squeezelite start again, whether automatically or manually, was to UNTICK the ‚Disable Built-In Audio‘ setting.
    However, audio in Kodi doesn’t work without it.
    What should I do?
    Thanks

    23. Februar 2022 at 14:21 #52083

    Hi Quebrantahuesos,

    Normally Squeezelite should autostart anyway. This can sometimes take up to two minutes. Does the autostart work if you wait a little longer after Kodi has stopped?
    What have you set in Squeezelite’s advanced options for audio output and command line options?

    23. Februar 2022 at 20:09 #52089

    Hello Mario,
    I have the default sound card set for the HifiBerry Amp2 (sysdefault-snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0 – Default Audio Device, CARD=sndrpihifiberry) and I haven’t changed the command line options (they are -o hw:1 -V Digital).
    I have just tested by waiting, as you say, a couple of minutes, and Squeezelite has indeed started up.
    I am sorry to have wasted your time but I hope this topic might help someone else in the same situation!

    My other problem with using Kodi is controlling the volume. I assume this is not something to do with Max2Play but if you know how to get the TV remote on HDMI CEC to control the volume on Kodi on Max2Play, please let me know; it’s driving me mad! The remote works well otherwise; it’s just the volume.

    24. Februar 2022 at 13:48 #52095

    This sounds more like a Kodi problem. Have you edited the CEC mapping in the Kodi settings?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here