[SOLVED] Squeezelite always needs to be restarted after non-use

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Squeezelite always needs to be restarted after non-use

This topic contains 5 replies, has 3 voices, and was last updated by  Heiner Moderator 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 28. June 2017 at 17:07 #29756

    I’m running LMS and Squeezelite on a Raspberry Pi 3 with a wired ethernet connection. I use it mostly for internet radio.

    I’m connecting the USB output to a T+A DAC 8 DSD. This sounds fine at first. However, if I switch off the music (via the SqueezeCtrl app on my tablet) and then return to play more music after a longish, as yet undetermined, period, then I get intermittent and distorted sound. As far as I can tell it’s not a DAC issue as its diagnostic lights indicate the connection is properly maintained.

    This issue can always be resolved by restarting Squeezelite (though it sometimes needs to be killed first, rather than just stopped). But it’s a pain to have to keep doing that.

    Previously, before I experimented with USB, I used a HiFiBerry Digi+ and connected with a phono lead. There were no problems whatever with this (except that it’s limited to 24/192). The basic hardware seems to be OK, there seems to be a software issue of some sort.

    28. June 2017 at 18:09 #29757

    Actually, after some hours of playing, I’ve just experienced the problem while the music was playing. It just stopped and then produced a regular pulsing version of the sound. Killing Squeezelite and restarting it solved it.

    2. July 2017 at 14:26 #29784

    OK. I think I’ve solved it by adding

    -o hw:CARD=HDAudio,DEV=0

    to Squeezelite’s command line. I’ve not had a problem since doing that.

    5. July 2017 at 15:01 #29824

    Hi Richard,

    Sorry about the late response and thanks for sharing your solution as well as your progress!

    16. July 2017 at 10:21 #29923

    Richard, Heiner,

    I have exactly the same issue. In my case with an Arcam irDAC-II.

    I’ve tried many things already (increase buffer size, max USB power, tick USB DAC box).

    It sounds the same as a studio DAC missing it’s Wordclock sync. Which is a bit weird because my DAC (and I also expect Richards’) are asynchronous and should be independent from any clocking issues between the RPi and the DAC…

    When I add the commandline parameters as suggested by Richard I get the following error:

    Trying to launch … NOT successful Click here to show detailed information
    [10:12:41.475874] test_open:384 playback open error: No such device
    [10:12:41.476429] output_init_common:382 unable to open output device

    Any suggestions?

    19. July 2017 at 16:18 #29972

    Hi Albert,

    Unfortunately, we have had no experience with this USB DAC, yet. However, the slimdevices forums seems to have discussed it in the past: http://forums.slimdevices.com/showthread.php?107034-PCP3-11-Pi-Model-B-USB-DAC-Arcam-IRDAC-II-issues

    Generally, you can also contact the manufacturer of the DAC and ask for the details on its output device and driver.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here