Squeezeboxserver läßt sich nicht starten

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezeboxserver läßt sich nicht starten

This topic contains 8 replies, has 4 voices, and was last updated by  Heiner Moderator 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 2. Mai 2018 at 11:45 #35418

    Hi,
    nach mittlerweile 11 Stunden Versuch, diesen Player zum laufen zu kriegen, kommt jetzt die Fehlermeldung:

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    sudo: no tty present and no askpass program specified
    Damit kann ich nichts anfangen.
    Das Übersetzungsprogramm kennt das Wort „sudo“ auch nicht?
    Was ist tty ?
    Was ist ein askpass programm?

    Kurz vorm Abwinken

    Achim

    2. Mai 2018 at 17:36 #35441

    Hallo Achim,

    Entschuldige die Unannehmlichkeit.

    Bitte lade unser neuestes Image “Max2Play Raspberry Pi ALL incl. 3B+ (SD-Card Image based on Raspbian Stretch)” runter, um sicherzugehen, dass du die aktuellste Version hast. Bitte mache zudem auch ein Update auf der Einstellungen/Reboot-Seite.

    Danach sollte sich der Squeezebox Server ohne Probleme installieren lassen.

    2. Mai 2018 at 21:38 #35461

    Hallo Heiner,
    danke für deinen Tipp.
    Habe ich gemacht.
    Trotzdem weiß ich nicht, wie ich den USB Speicher des Raspberry einbinden soll.
    Was nützt es, wenn ich da die IP Adresse eingebe?
    Wenn alles eingerichtet ist, war´s das mit dem Heimnetzwerk.
    Mit anderen Worten, dann ist kein W-Lan, Lan mehr dran.
    Nur in kuscheliger Einheit mit Display, Festplatte, Rasp und HDMI zum Yamaha.
    Das mit dem NAS usw habe ich längst hinter mir. W-Lan geht bei uns nicht. Ich habe immer den neuesten Fritz Homeserver. Der Vorgänger steht dann als Repeater bereit. Das Wohnzimmer ist oben. Die Wände sind das Dach. Isoliert mit Alukaschierung. Die Zwischendecke ist voller Eisen. Der Homeserver hängt im Kelleraufgang und schafft kaum die 4 Meter zum Repeater.
    Selbst auf die Terrasse dringt nur in Fensternähe ein bisschen Netz.
    Also, ich will dass nach dem Start die Liste der Festplatte automatisch aufmacht. Dann brauche ich nur einen Ordner/Album anklicken und läuft.
    Keine Playlist speichern, sondern nur das hören, was ich gerade aussuche.
    Im Hobbyraum habe ich einen XP Rechner nur mit Winamp. Wenn er hochgelaufen ist, ist automatisch der Winamp Katalog offen und der Player. Zack, ist die Musik an.
    Also nicht wie bei Rune oder Volumio oder Yamaha App, wo man sich erst bis zur Festplatte hinklicken muß.
    Ich möchte es Bedienerfreundlich.
    Was soll ich denn nun für Pfad,Mountpoint Typ,Optionen für die angeschlossene Festplatte eintragen?
    Er findet sie nicht selbst!?
    Das können alle anderen Player!
    In Deinem Video beschreibst Du zwar einiges, Aber woher soll ich wissen wie der Stick im Raspy heißt, und welchen Pfad er hat?
    Danke für Deine Hilfe
    Achim

    4. Mai 2018 at 21:17 #35521

    Mein lieber Heiner,
    danke für Deine Mail.

    Sehr geehrter Achim,
    
    Vielen Dank für Ihre Anfrage.
    
    Über HDMI können Sie entweder Jivelite (mit Server und Audioplayer Komponenten auf anderen Plugins) oder Kodi (alles in einem) nutzen. Bei letzterem müssten Sie noch in den Raspberry Einstellungen das build in audio deaktivieren.
    
    Unsere technische Hilfe (Support) wird komplett über unser Max2Play-Forum abgewickelt, damit die ganze Community davon profitiert, sobald technische Fragen und Probleme gelöst worden sind. Posten Sie Ihre Nachricht bitte entweder in eine bestehende Forendiskussion, die zu Ihrem Anliegen passt, oder eröffnen Sie eine neue. Wir werden so schnell wie möglich darauf eingehen.
    Beachten Sie bitte, dass die Nutzerkonten von Max2Play.com und dem Max2Play-Shop aus technischen Gründen getrennt sind. Ein Shopkonto kann also nicht auf Max2Play.com genutzt werden und umgekehrt. Natürlich ist es möglich, sich auf beiden Websiten mit derselben E-Mail-Adresse anzumelden.
    
    Vielen Dank für Ihr Verständnis.
    
    --
    Viele Grüße
    Heiner Uebbing
    Max2Play
    
    

    nur leider beantwortet das meine Frage:
    Wie bringt man das Programm dazu den USB-Stick zu erkennen.
    Eigentlich ist es in der heutigen Zeit schon heftig, einen Player zu verkaufen, welcher nicht mal an ihn selbst angeschlossene Audiospeicher findet.
    Überhaupt ist die Software ein Rückschritt!
    Erinnere Dich!
    Vor geraumer Zeit hast Du eine Taste geschnippt, und das Radio war am Spielen.
    Zwei weitere Tasten, und die CD , Schallplatte, Cassette, Bandgerät usw spielte los.
    Gut, für den Vorteil einen schnellen Zugriff auf Alles zu haben, nimmt man schon die Bootzeit in Kauf.
    Aber dann reicht es auch.
    Ärgerlich ist dann schon, wenn man, wie bei Rune/Volumio usw erst noch bis zur Audiosammlung durchklicken muß, obwohl man nur diese Eine hat und nichts anderes nutzen will.
    Bei Max2Play bin ich nichtmal so weit gekommen.
    Ihr solltet bewerben, dass man mittlere Kenntnisse in Linux Nutzung braucht.
    Das wäre fair!
    Mir selbst genügen schon einfache Spielereien mit ATtiny und Arduino. Aber eben Einfache.
    Nun habe ich wieder Runeaudio. Da kann man das Display einfach drehen, wenn man alles in einen Editor läd und unter config.txt LCD rotate die 3 gegen die 2 tauscht.

    Peinlich für Euch, nicht für den User!
    Schönen Gruß und kauf dir ne Wurst und nen Kaffee für die 10 Tacken
    Tschüß

    7. Mai 2018 at 15:10 #35555

    Sehr geehrter Achim,

    Meine Antwort bezog sich auf Ihre Frage bezüglich der grafischen Ausgabe über Max2Play. Dies sind die beiden Optionen für solch ein Setup.

    Max2Play wird jedoch grundsätzlich komplett über das Webinterface konfiguriert. Es handelt sich „headless system“, also eines ohne zentrale Ausgabeoberfläche. Man kann diese nach Bedarf mit Programmen wie den obig genannten besetzen, nötig ist dies mit Max2Play jedoch nicht. Das Webinterface ermöglicht jede Einstellung und Steueroption über ein Gerät der Wahl, das sich ebenso im lokalen Netzwerk befindet.

    Dieses Webinterface lässt sich von jedem anderen Gerät über „max2play/“ in dessen Browser erreichen, sobald das Gerät am Netzwerk angeschlossen ist.

    Falls Sie den Eindruck erhalten haben, dass Sie Max2Play über die HDMI-Schnittstelle konfigurieren sollen, lassen Sie mich bitte wissen, wo diese Fehlinformation steht, damit wir dies umgehend anpassen können.

    USB-Speicher werden automatisch erkannt und direkt gemountet. Dessen Pfad und weitere Details lassen sich im Webinterface unter dem Menü Dateisystem/Mount einsehen. Diesen Pfad kann man dann auch direkt einbinden im Programm der Wahl.

    1. Juli 2018 at 12:36 #36425

    Hallo,
    habe das gleiche Problem mit dem LMS. Ein jahr lang lies sich mit der Version der LMS problemlos installieren. Nun auf einmal diese ominöse Meldung auf einem neu installierten System. Weder 7.9.1 noch 7.9.2 lassen sich installieren.

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    sudo: no tty present and no askpass program specified.
    Überhaupt hat vonwegeneinfach mit seiner Kritik an m2p völlig recht. Das Ganze ist weder, wie beworben, einfoch noch über das Webinterface wirklich gut zu bedienen. Über dies tauchen sehr häufig Fehler auf, die sich nicht erklären oder gar irgendwie beheben lassen, ohne dass man über ssh zugreift.

    Ich versuche jetz seit einigen Wochen ein System so aufzubauen, dass es lediglich als LMS für meine Player im Hintergrund läuft. Es ist ein Drama. Gestern hatte ich plötzlich in der W-Lan Einstellung 2 IP Adressen für das Gerät stehen, obwohl Accespoint ausgeschaltet ist. Mir ist das nur aufgefallen, weil ich lediglich sporadischen Zugriff auf den Server hatte. Natürlich hatte der Server damit auch keinen Internetzugriff, also auch kein Netradio.

    (192.168.1.48 und 192.168.189.1). Das Ganze lies sich nur durch die Einstellung einer festen IP beheben.

    Mit RPI 3B+ und stretch gibt es die gleichen Probleme. Ebenfalls 2 IP-Adressen in der W-Lan Einstellung. Kann mir kaum vorstellen, dass meine Fritzbox 2 IP-Adressen zuteilt. Das witzige dabei ist, dass trotz der angezeigrten IP-Adressen kein Accesspoint zur Verfügung steht (Egal ob ein oder ausgeschaltet).

    Ich habe jetzt so viel Zeit und auch Geld in diese Geschichte gesteckt und bin immer noch unzufrieden. Es ist, lieber Heiner, zwar richtig, dass Ihr Euer Programm als Reines Webinterface anbietet, aber wer will denn wirklich auf eine Bedienung am Gerät oder gar eine Infrarotfernbedienung verzichten? Und übrigens, Ihr bietet doch auch solche Dinge an (Display, JustBoom-Fernbedienung).

    Wenn ich mich hier im Forum umsehe, dann lese ich von so vielen Dingen, die nicht, schlecht oder fehlerbehaftet funktionieren. Die Nutzer können doch nicht alle doof sein? Ich zum Beispiel habe bereits mehrere Datenbanken programmiert, die Heute noch fehlerfrei laufen und von hunderten von Usern genutzt werden. Aber mit den Fehlern in M2P komme ich nicht zurecht. Wenn ich auf eine Schaltfläche klicke, die eine LMS Installation anbietet und aufruft, dann erwarte ich, dass das funktioniert und nicht dass ich mich stundenlang in irgendwelchen Foren schlau machen muss. Wenn Du also den Rat gibst, dass man eine neue Version von M2P (stretch) nutzen soll „damit wirds schon funktionieren“, dann erwarte ich, dass Du Deine älter Version, mit der es nicht mehr funktioniert, so anpasst, dass man diese Installation nicht mehr ausführen kann (weg mit der Schaltfläche).

    Nun gut, damit mag es genug sein. Ich werden für mein Projekt noch einen Versuch mit stretch starten, dann ist endgültig schluss und ich kaufe mir ein Fertiggerät.

    9. Juli 2018 at 9:11 #36491

    So, ich hatte ein ähnliches Problem – ist aber schon ein paar Wochen her. Der Link ist falsch. Die 7.9.2 glaub ich gibt es gar nicht und der andere ist falsch eingestellt. Den Pfad am Besten so eintragen ( glaub ich) http://downloads.slimdevices.com/LogitechMediaServer_v7.9.1/

    7. Oktober 2018 at 9:19 #38411

    So, hab mich nun wieder mal stundenlang mit dem Quatsch beschäftigt – läuft aber nix mehr. Hab das neue Image installiert. Hier zeigt sich dann im Display oben und unten ein Rand, welchen ich beim alten Image nicht hatte. Desweiteren funktioniert meine Lirc Fernbedienung nicht mehr, vermutlich wurden hier die Befehle geändert. Werd nun ein letztes mal die alte Schei….e aufspielen und mich dann mit dem Picoreplayer auseinandersetzen. Ich hatte euch echt lieb hier, aber das was nun passiert geht gar nicht mehr. Früher sollte das Programm eine Erleichterung bei der Installation darstellen. Das ist definitiv nicht mehr der Fall. Wenn es wieder Plug and Play wird komme ich wieder. Basteln kann ich auch mit der Freeware – da brauch ich das nicht……. Meine Meinung.
    Die Installation von der USB Soundkarte geht auch nicht mehr bei der neuen Software – die lief früher auch und ich bin hier nicht der komplette Anfänger. Hab Zuhause alles vernetzt, meine Vu+ usw eingebunden usw. Warum macht ihr immer neues anstelle sich wie früher um ein funktionierendes Programm zu kümmern……. Wie gesagt meine Meinung

    8. Oktober 2018 at 12:30 #38429

    Hallo jono,

    Danke für das Feedback. Wir haben Umstellung auf Stretch genutzt (der Pi3B+ funktioniert nicht mehr mit jessie) um einige Dinge zu optimieren und anzupassen. Falls du dahingehend konkrete Fehlermeldungen erhältst, kopiere sie bitte direkt hierher und werden es nachstellen und ggf. die Problemlösung direkt online stellen.

    Das System für Raspberry Pi ist ständig im Wandel und so müssen auch wir ständig mitziehen und diese Neuerungen umsetzen. Damit als Nutzer dann keine Probleme auftreten, sind wir auch auf euch und euer Feedback angewiesen, damit wir jegliche Konfiguration optimal, auch in der Zukunft, anbieten können.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here