Squeezebox server with google play, kodi and Samba

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Squeezebox server with google play, kodi and Samba

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 2 weeks, 3 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 27. September 2018 at 15:38 #38162

    Hello, I am very disappointed, I already tried at least 5 times from scratch to create my squeezebox server with max2play…
    My goal was to use Google Play music (reported as working only on unix), and use my large samba mp3 share, and with the kodi option enabled.

    Well … I cannot do any of these things !

    -Google Play Music just never wanted to launch… just as on the window<s version, and I tried the included option / the direct link and even a new version that came between the days when I tested, with always the same result: cannot load.

    -I use the famous french provider freebox that comes with a powerful NAS and … obviously a very classic Samba share of any USB hard drive, well strangely I just never could connect to it, and I tried a lots of thing, and… I read several french reports claiming the same thing : Linux got very hard time to mount it this way, i mean no one could. I tried the UPNP thing but I never saw this thing working correctly.

    -Kodi never started, it just ruined the whole thing each time by turning the 8GB sdcard to 100%, meaning it’s the end of the whole max2play server, and the option to expand partition never worked ? is 8Gb too small ?

    27. September 2018 at 16:39 #38178

    Hi ninja,

    In Max2Play first boot under our new images, it should automatically recognize if it is on an unexpanded partition and expanded it with a reboot. You can follow this process when first booting the Pi via hdmi output.

    Our Google Play Music plugin is for the Squeezebox Server only. You cannot simultaneously run Kodi on it, only switch between the two.

    Also, we intentionally added the hint that this installation takes some time to the button because it does. You need to be connected to the internet and wait a few minutes for the google music plugin install to be fully done.

    27. September 2018 at 17:04 #38187

    I just tested the plugin and made sure it was okay. Please wait ca 5 five minutes after the yellow text ends to absolutely make sure you do not impede the installation.

    29. September 2018 at 5:48 #38239

    I’ll try a sixth time right now, but it’s not very clear :

    -Why are you mentionning partition ? is there something more I could do except „burning“ your sd file ? I mean this does erase any old partitions right ?
    -What ? you cannot run both Kodi and squeezebox ? well right now i cannot even install kodi after squeezebox so … switch is not even an option !
    -Should I install google before or after inital upgrades ?
    -I would eventually be interested by other plugins like bluetooth or dlna or spotify, but I guess I won’t be able to cast from android to a real classic squeezebox through max2play as a simple squezebox server ?
    -Last question as I use a nespicase+ for raspberry right now, just to use his secured reset+power button, would this official script be working with max2play too ? https://github.com/RetroFlag/retroflag-picase

    29. September 2018 at 7:25 #38240

    OK I succesfully installed the google plugin, looks like you have to do that first and wait and reboot ? now of course I cannot log in, already tried several things about 2steps on and off, app password, device id and ssl… still trying

    1. Oktober 2018 at 10:38 #38261

    Hi ninjaw,

    You should only need to enter the device ID and the premium login of your Gmusic account.

    1. Oktober 2018 at 11:26 #38274

    Yep, unfortunally nothing worked, even changing password, I keep having that ridiculous message wrong password
    yeah, well…

    1. Oktober 2018 at 12:54 #38280

    I’ll test it out today or tomorrow and let you know the results.

    2. Oktober 2018 at 14:17 #38329

    Hi ninjaw,

    I just successfully tested it. Please try reinstalling the plugin to make sure it got all packages and try using the find my phone service of Google to double-check your device id. (Got my correct one only through this process)

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here