squeezebox server have sound using radio but no sound when Air Play

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) squeezebox server have sound using radio but no sound when Air Play

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Mbydeen 6 months, 4 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 23. January 2017 at 1:19 #26205

    Hello

    I’m running RPi3 with a Hifiberry Digi+ I don’t know what I’m doing wrong but I cant seems to get the sound using shairport (phillip) since I can’t install disaster123 version failed to load in the plug-in. I got the sound when I’m using the radio function in the LMS but when it come to stream airplay from my ipad I got no sound. I know for sure I configured the hifiberry correct because I got sound coming from one way.

    Any one running into this problem?

    Thanks and hope to hear from you all

    here is the log

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_digi, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_digi, – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: RW_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####

    26. January 2017 at 15:25 #26331

    When using an external soundcard and direct sound output (higher sound quality) just one player must have exclusive access to the soundcard. For this setting there are two possible options:

    1.Install Shairtunes for Squeezebox Server (easy installation on Squeezebox Server tab in Max2Play). With this setting all Squeezebox Clients will have Airplay support, but can’t run synchronized. That means you may just play sound via Airplay at one device at a time.

    2. Setup Shairport on each Max2Play device and use advanced Settings in Shairport to automatically disable the Squeezelite player on the device once a stream is played via Airplay. This setting has the advantage of a dedicated Airplay Player on each device, that can be sychronized with iTunes to a multiroom setup.

    And please make sure that the Airplay service is running, and the Hifiberry Digi+ sound card is selected as default sound card, we recommend yout to have a look at Max2Play Raspberry Pi 2 Image for HiFiBerry Sound Cards DAC+ Amp+ Digi+

    https://www.max2play.com/en/videos/

    • This reply was modified 6 months, 4 weeks ago by  Mbydeen.
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here