Squeezebox server doesn't see mountpoint

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezebox server doesn't see mountpoint

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 10 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 12. November 2017 at 21:29 #32436

    In summary, I have an external harddisk on another RPI, mounted via the „filesystem mount“ which does work in Kodi and via the GUI, but doesn’t work in Squeezebox. I think it is a permission issue…

    I use one RPI as media server, called „media_server“ with an external 3TB USB harddisk connected. It is formated with NTFS, so I can attach it to a Windows system if I have many bytes to transfer. It is password protected. A second RPI, actually a HifiBerry, is connected to my TV and it is called LivingRoom with M2P installed on it.

    After figuring out how to mount Samba network paths, I got it working. At least in Kodi and if I open the mount via the desktop using the TV and keyboard attached to the HifiBerry. I can play music and video files, rename them, etc. The mount isn’t however visible in the Squeezebox Server settings however via http://LivingRoom:9000 > Settings > Basic Settings / Media folders > Browse. If I type the mount „/mnt/media“ and scan it, it returns an error.

    After serveral searches on fora, etc. I got it working if I remove the password protection on the external drive and allow everyone to access it (by adding „allow_other“ in /etc/fstab on media_server). This isn’t really an option however, because I also run a Nextcloud server on the same RPI which goes into a protective maintenance mode if the drive is accessible to everyone. On other topics I read that Squeezebox Server approaches the mounts with a user called „squeezeboxserver“ or „lms“. I have added both on the media_server with permission to access the drive, but still the Squeezbox Server doesn’t see the mountpoint.

    What shoud I do to get this working?

    14. November 2017 at 12:07 #32474

    Hi kriddy,

    Did you create the SambaShare with Create Mode 777?

    19. November 2017 at 18:07 #32539

    Thanks for your reply Heiner. If I use mode 777, everyone has access. Squezebox will work, but Nextcloud will not. I would like to use mode 770, but then I need to know the username Squeezebox uses…

    21. November 2017 at 17:59 #32572

    Hi kriddy,

    You can try using user:root password: max2play

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here