squeezbox / server / Kodi-Music Remote "Player is stopped"

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI squeezbox / server / Kodi-Music Remote "Player is stopped"

This topic contains 11 replies, has 2 voices, and was last updated by  Max Müller premium 2 hours, 44 minutes ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 9. Oktober 2018 at 12:09 #38493

    benutze max2play zuerst für Radio ab Internet, bis heute keine Probleme
    natürlich wollte ich meine „digitalisierte“ Plattensammlung integrieren
    die Sammlung habe ich mittels iTune auf eine USB-micro SC 32GB (Fat32) Karte übertragen
    auf einen Mac mit iTune funktioniert die Wiedergabe einwandfrei

    auf max2play/Kodi wird die Sammlung einwandfrei aufgelistet inkl Platten-Cover Spielzeit usw.

    einmal ist es mir nach zahlreichen Versuchen (direkt auf dem System, nicht Remote!) sogar gelungen einen Titel ab zu spielen
    aber eben, nicht nachvollziehbar wie.
    Es gelingt einfach nicht

    auffällig ist,
    – Dateisystem Mount, der Pfad, Mountpoint und Typ wird entsprechend angezeigt
    – jedoch weiter unten, „Externe Laufwerke…“ JUKEBOX in nicht verbunden (Device /dev/sda1 with UUID 74B9-0226)
    selber Name/Kennung wie oben angezeigt

    9. Oktober 2018 at 13:38 #38497

    Hallo Max,

    Check einmal ob die Ordner und Dateien in deiner Musikbibliothek besondere Rechte oder Formate besitzen? Eigentlich sollte Kodi mit den meisten klarkommen, aber basierend auf deinen Einstellungen bei der Migration von iTunes, könnte das das Problem sein.

    Du kannst noch den Squeezebox Server installieren und sehen ob dieser die Dateien korrekt indiziert und abspielt.

    9. Oktober 2018 at 14:42 #38499

    hallo Heiner,
    danke für die Meldung

    es ist wie verhext,
    es ist Mediaplayer Squeezelite und Squeezebox Server installiert und auch konfiguriert
    im Squeezbox Server Webadminisrtation kann ich die Titel korrekt abspielen lassen

    auf Kodi (max2play/raspi) kann ich unter Optionen/Dateimanager/ /media/usb0/ alle Titel sehen und mit Doppelklick abspielen
    am Smartphone KODI Music Remonte wird auch der Titel mit allen Infos angezeigt allerdings es ist keine Playliste vorhanden
    ich vermute, dass ich in der normalen Musik Auflistung lediglich die Covers oder Tonträger-Infos erreiche und nicht den eigentlichen Tonträger/File

    es erscheint die Meldung „Wiedergabe nicht möglich“
    wo kann ich die Logdatei einsehen?

    10. Oktober 2018 at 12:26 #38510

    Hallo Max,

    Hast du bereits in Kodi’s Einstellungen gecheckt ob deine Soundkarte als Ausgabegerät gewählt ist?

    Du kannst in unserem Debug Info Fenster den Log sehen.

    10. Oktober 2018 at 13:08 #38519

    Hallo Heiner

    danke für Meldung, die Soundkarte ist als Ausgabegerät, es war nie anders

    (ich erhielt den kompletten Raspi ink Soundkarte und Gehäuse mit fertig installierter Software)

    bis heute habe ich diesen als „Radio“ benutzt, aber eben ich wollte auch meine „Plattensammlung“ auf diesem abspielen können.
    anfänglich hatte es mal, aber nur bei einigen funktioniert, warum, konnte ich niemals heraus finden
    jetzt wo ich etwas mehr Zeit habe, möchte ich eben das Ganze richtig zum laufen bringen (dies als Nebenbemerkung)

    ich vermute, dass in der internen Datenbank eine sogenannter Index besteht, der Titel und Coverbild wohl in die Anzeige bringt aber die dazu gehörende mp3/4 Datei nicht findet (deshalb im Remote nur die Anzeige aber bei „Player is off“

    wie schon erwähnt, unter Optionen/Dateimanager/ A /media/usb0/ ( B ebenfalls /media/usb0 und gleiche Liste) alle Titel sehen und mit Doppelklick abspielen
    irgendwie erfolgt das „hinzufügen“ nicht

    müsste man alle bestehenden Musikdaten erst löschen und dann wieder hinzufügen? dann aber wie???

    DEBUG KODI/XBMC lässt sich die Vermutung bestätigen, gesucht wird unter /media/usb/music … ???

    13:42:23 T:1783624720 WARNING: Process directory ‚/media/usb/Music/unforgettable -3/slowly nostalj?/‘ does not exist – skipping scan.

    beim Versuch den Titel zu spielen:

    13:58:32 T:1961353216 ERROR: Init: Error opening file musicdb://albums/473/3960.m4a?albumid=473
    13:58:32 T:1961353216 ERROR: CAudioDecoder: Unable to Init Codec while loading file musicdb://albums/473/3960.m4a?albumid=473
    13:58:32 T:1961353216 WARNING: PAPlayer::QueueNextFileEx – Failed to create the decoder
    13:58:32 T:1961353216 ERROR: Playlist Player: skipping unplayable item: 0, path [musicdb://albums/473/3960.m4a?albumid=473]

    beim boot ist mir aufgefallen, dass die Meldung mount /dev/sda1/Jukebox FAIL gebracht hat, trotzdem ist diese ge“mounted“ /media/usb0
    anlässlich boot:
    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 7459532 3457600 3647464 49% /
    devtmpfs 437208 0 437208 0% /dev
    tmpfs 88308 496 87812 1% /run
    tmpfs 5120 0 5120 0% /run/lock
    /dev/sda1 30363648 16163264 14200384 54% /media/usb0
    tmpfs 176600 0 176600 0% /run/shm
    /dev/mmcblk0p1 57288 20368 36920 36% /boot

    #### LOAD AVERAGE ####
    0.66 0.44 0.18 1/252 4389

    #### KERNEL ####
    Linux max2play 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.11 (wheezy)
    Release: 7.11
    Codename: wheezy

    Audioplayer:

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8, Copyright 2012-2015 Adrian Smith.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT DSD

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SHAIRPORT_PARAMETER=-d plug:plugequal
    USE_USB_DAC=1
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    GMEDIARENDER_ALSA_DEVICE=sysdefault
    YMPD_PARAMETER=–webport 8081
    GMEDIARENDERER_ALSA_DEVICE=plug:plugequal

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    plugequalUSB – Equalizer for USB
    dmixerUSB – DMixer for USB
    plugequal – Equalizer for plughw:0,0
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device

    #### SHAIRPORT (SYNC) VERSION ####
    2.2.4-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: RW_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    Squeezbox-server:

    2018-10-09 08:17:05 squeezeboxserver_safe stopped.
    2018-10-09 08:18:33 squeezeboxserver_safe started.
    [18-10-09 08:19:10.1522] main::init (387) Starting Logitech Media Server (v7.9.1, 1512734075, Fri Dec 8 15:42:06 UTC 2017) perl 5.014002 – arm-linux-gnueabihf-thread-multi-64int
    [18-10-09 08:19:11.7833] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-10-09 08:19:11.8667] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-10-09 08:19:13.3766] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-10-09 08:19:13.4619] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-10-09 08:19:15.9579] Slim::Plugin::CLI::Plugin::cli_socket_open (163) Can’t setup the listening port 9090: Address already in use
    [18-10-09 08:19:15.9614] Slim::Utils::PluginManager::load (393) Warning: Couldn’t call Slim::Plugin::CLI::Plugin->initPlugin: Can’t setup the listening port 9090: Address already in use at /usr/share/squeezeboxserver/lib/Log/Log4perl/Logger.pm line 900
    [18-10-09 08:19:16.2777] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-10-09 08:19:16.3446] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [18-10-09 08:19:17.2355] main::checkDataSource (1110) Warning: Schema updated or no media found in the database, initiating scan.
    [18-10-09 08:19:25.4428] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-10-09 08:19:25.5320] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    2018-10-09 11:17:16 squeezeboxserver_safe started.

    [18-10-10 07:42:19.9177] main::init (387) Starting Logitech Media Server (v7.9.1, 1512734075, Fri Dec 8 15:42:06 UTC 2017) perl 5.014002 – arm-linux-gnueabihf-thread-multi-64int
    [18-10-10 07:42:25.4921] Slim::Plugin::CLI::Plugin::cli_socket_open (163) Can’t setup the listening port 9090: Address already in use
    [18-10-10 07:42:25.4946] Slim::Utils::PluginManager::load (393) Warning: Couldn’t call Slim::Plugin::CLI::Plugin->initPlugin: Can’t setup the listening port 9090: Address already in use at /usr/share/squeezeboxserver/lib/Log/Log4perl/Logger.pm line 900

    10. Oktober 2018 at 15:43 #38531

    Hallo Max,

    Dein System ist noch basierend auf Raspbian Wheezy. Dabei ist auch ein etwas ältere Version von Kodi enthalten. Unser aktuelles basiert auf Stretch (dazwischen gab es noch Jessie) und kommt mit Version 17.6-3~stretch.

    Falls es für dich nicht zu viel Aufwand ist, würden wir empfehlen die neue Version zu laden, um alle Neuerungen von Max2Play nutzen zu können und eine mögliche Dependenz zur alten Version von Kodi auszuschließen.

    Mach am besten zuvor ein Backup deines aktuellen Images mit Softwarelösungen wie Etcher oder WinDiskImager, damit du zur Not auf die vorige Version zurückgehen kannst.

    10. Oktober 2018 at 19:26 #38539

    Hallo Heiner

    ja an diesem Vorgehen studiere ich schon lange (Backup ist fraglich, kein grosser Nutzen)

    gerne möchte ich wissen, wo es eine Anleitung gibt, für das implementieren meiner Plattensammlung
    damit sich dies nicht wieder wiederholen kann

    wünsche einen schönen Abend
    Max

    14. Oktober 2018 at 20:00 #38602

    hallo Heiner

    das System ist neu aufgesetzt (Version 17.6-3~stretch)

    Kodi/XBMC erkennt jedoch die Soundkarte nicht
    diese ist unter „Hifi Berry“ sowie unter „Raspberry Einstellungen“ definiert, „HifiBerry DAC+ (PI 2 / 3)“

    Kodi/XBMC benötige ich für die Bedienung mit Kodi Music Remote (Pro) 4.6.0
    dort im Debug sehe ich, dass dieser Device 1 HDMI; Device 2 Analogue und Device 3 Both / Analogue + HDMI

    Kodi/XBMC, weiter kommen fortlaufend Fehlermeldungen:
    18:00:06.566 T:1911025664 ERROR: JSONRPC Server: Failed to connect to sdpd
    18:00:06.974 T:1748984576 ERROR: CecLogMessage – RegisterLogicalAddress – CEC is being used by another application. Run „tvservice –off“ and try again.

    ich will kein Video! aber hier scheint ein nicht notwendiges Add-on geladen zu sein!?

    was ist hier falsch?

    ist der MPD installiert, mit YMPD geht die Wiedergabe über die Soundkarte (ganz normal)

    weitere Frage, neues Image, wie erfolgt die Aktivierung der Lizenz?

    besten Dank
    Gruss Max

    15. Oktober 2018 at 12:53 #38617

    Hallo Max,

    Die Aktivierung der Lizenz funktionier über Einstellungen/Reboot, einfach eintragen und speichern.

    Danach kannst du in den Raspberry Einstellungen noch die eingebaute Soundkarte deaktivieren und neustarten.

    15. Oktober 2018 at 14:23 #38619

    Hallo Heiner

    danke für die Meldung, doch dies verstehe ich jetzt nicht ganz
    eine allfällige neue Aktivierung der Lizenz ist erst dann gedacht, fall ich das System neu aufsetzen müsste!

    15. Oktober 2018 at 16:16 #38623

    Sie erwähnten, dass das system neu aufgesetzt sei. Dabei muss auch die Lizenz neu eingetragen werden. In Einstellungen/Reboot geben Sie einfach Ihre Lizenz (Email-Adresse oder Code) ein und klicken speichern, danach wird diese grün angezeigt und man sieht bis wann sie noch aktiv ist.

    Nach Aktivierung können sie auf das Menü Raspberry Einstellungen zugreifen. Dort gibt es eine Option zur Deaktivierung der eingebauten Soundkarte. Nach einem Neustart nach dieser Deaktivierung schmeißt Kodi automatische dieses Ausgabegerät aus der Auswahl und Sie können die Soundkarte als Ausgabegerät wählen.

    • This reply was modified 3 hours, 41 minutes ago by  Heiner.
    15. Oktober 2018 at 17:15 #38625

    nein noch nicht, eventuell lässt sich das Problem auch anderweitig lösen
    im Moment beim jetzt laufenden bzw neu aufgesetztem System ist die Lizenz normal aktiviert!

    • This reply was modified 2 hours, 42 minutes ago by  Max Müller.
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here