Spotty is not working; helper app is reported as not available, although availab

Max2Play Home 2016 (en) Forums Max2Play Add-ons Spotty is not working; helper app is reported as not available, although availab

This topic contains 1 reply, has 2 voices, and was last updated by  MarioM Moderator 2 weeks, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 28. September 2021 at 7:14 #51679

    Hi,
    when selecting spotty from the main menu, I get the following.

    
    Spotify Anmeldedaten fehlen
    Bitte überprüfen Sie Einstellungen/Erweitert/Spotty Spotify für Squeezebox im Web Interface 
    

    When going to the settings, I get

    
    Beim Ausführen der Spotty Helfer-Anwendung ist ein Fehler aufgetreten. Vermutlich wird diese auf ihrem System nicht unterstützt. Bitte wenden Sie sich an mich, unter Angabe der folgenden Plattform-Informationen:
    
    Betriebssystem: Debian / armv7l-linux
    
    Ordner für Hilfsprogramme:
    /usr/share/squeezeboxserver/Bin/armhf-linux
    /usr/share/squeezeboxserver/Bin
    /usr/share/squeezeboxserver/Bin/arm-linux
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /bin
    /usr/sbin
    /usr/bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    ldd (Debian GLIBC 2.24-11+deb9u4) 2.24
     
    Konto: 	Importieren:
    

    The helper app is available:

    
    ll /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux/spotty-hf
    -rwxr-xr-x 1 squeezeboxserver nogroup 4132392 Jul 12 07:51 /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux/spotty-hf
    

    log file:

    
    tail -f /var/log/squeezeboxserver/server.log
    [21-09-28 07:06:29.0875] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-09-28 07:06:29.0903] Plugins::Spotty::Helper::get (52) Last error:
    Illegal instruction
    [21-09-28 07:06:29.0932] Plugins::Spotty::Connect::canSpotifyConnect (84) Cannot support Spotty Connect, need at least helper version 0.12.0
    

    After spotty was not working, I did an update from max2play and also apt-getupdate && apt-get upgrade.

    28. September 2021 at 12:54 #51681

    Hi rtbuw,

    The error message says to please contact the developer of the Spotty Helper plugin, and including the platform information. You can contact the developer in the Slimdevices forum: https://forums.slimdevices.com/
    It looks like the Helper plugin is not compatible with your system, or you need a newer version of the plugin.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here