Spotify required option name missing

Max2Play Home 2016 (en) Forums Max2Play Add-ons Spotify required option name missing

This topic contains 8 replies, has 4 voices, and was last updated by  MarioM Moderator 2 weeks, 6 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 6. Juni 2019 at 5:38 #45624

    I just installed the spotify plugin and when it starts, I get this error:

    #### Librespot Output ####
     
    
    #### Librespot Command Line Options ####
    error: Required option 'name' missing
    Usage: /opt/spotifyconnect/librespot [options]
    

    I tried adding „–name PoolPi“ to the command line parameters, but it still gives me the same error.

    Has anyone else had this issue?

    6. Juni 2019 at 9:35 #45626

    Hi djvj,

    Were you able to authenticate you premium account yet?

    Please try reinstalling Spotify Connect and try logging in again.

    7. Juni 2019 at 5:11 #45633

    Hi, yes I’m premium. No problems there.

    I tried reinstalling it and still get the same issue. When I start the service, it says it starts with a process ID, but when I go to stop it, it says „Unable to stop process – it seems that it is not running“

    7. Juni 2019 at 6:28 #45634

    So I ended up using the Spotty plugin here on LMS server itself which worked great. This supports multiroom too. Not sure if it forces all rooms all the time or not, cause then I might have to figure out what’s wrong with the max2play plugin then.

    https://forums.slimdevices.com/showthread.php?110455-Announce-Spotty-2-8-x-Spotify-Connect-for-your-Squeezebox

    • This reply was modified 3 years, 1 month ago by  djvj.
    11. Juni 2019 at 11:55 #45648

    Hi djvj,

    We generally recommend Spotty for all multiroom purposes due to its modular structure in the Squeezebox system.

    In our Spotify Connect player, the error you name is not really an error and should not cause the issue of being unable to stop. This is most probably due to multiple players trying to occupy the same sound card and running into occupied ports. You can check this by stopping all players in the Audioplayer menu and restarting the Spotify Connect player. However, your best bet with multiroom is Spotty, as I mentioned.

    24. Mai 2022 at 21:07 #52236

    Hello please fix this issue, I’m having the same if I try to use the plugin
    Everything works fine if I ssh and run the command /opt/spotifyconnect/librespot –name CONNECT –device <device name>

    If I don’t specify the –name I get the same error in the the shell (ssh)
    This is a hint your wrapper is not passing the arguments correctly

    If I pass no arguments at all then it works and the name is max2play but I hear no music because I need to specify a specific –device

    Long story short I believe it’s not possible to pass any command line options because the wrapper is kind of broken

    Can you have a look? Shall we pass options in a specific format?

    8. Juni 2022 at 12:02 #52252

    Hi Steve,

    please excuse the late reply. The error is only displayed because the debug of Librespot is called through a command without passing parameters here. This is because there is unfortunately no command for (this version of) Librespot that only displays the help. However, this does not affect the correct functioning of Spotify Connect. The name parameter is always automatically set with the name of the player (default „max2play“) – depending on what is set in Settings/Reboot.

    Spotify Connect should run without any additional parameters in the command line options. Please make sure that you have installed your sound card correctly and that the audio output is set accordingly in the plugin.

    9. Juni 2022 at 9:27 #52254

    Thanks for the reply, Unfortunately I need to use the options to have it working with my USB sound card. I see the card from max2play menu but it does not work not sure why (it works with any other feature of max2play but this ) . I have now created a service to start the librespot process independently from this interface menu and all works fine

    16. Juni 2022 at 12:14 #52266

    Hi Steve,

    I have now tested Spotify Connect again with an Allo Revolution USB DAC and could not reproduce your problem. In the plugin, the USB DAC appears in the Output Devices as „hw: Revolution“. Spotify Connect can be started normally without specifying additional parameters.
    Strange that this doesn’t work for you. But I’m glad you were able to find a workaround.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here