[SOLVED] Spotify Connect

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify Connect

This topic contains 12 replies, has 2 voices, and was last updated by  Heiner Moderator 5 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 3. März 2018 at 20:36 #34194

    Hi,

    I am having problems running Spotify Connect on Rasp Pi 3 and Max2Play V2.45 using Audiophonics card
    When trying to connect I receive this error message:
    INFO:librespot: librespot (). Built on 2017-08-17. Build ID: fMyATDNy
    INFO:librespot_core::session: Connecting to AP „gew1-accesspoint-b-2853.ap.spotify.com:4070“
    INFO:librespot_core::session: Authenticated as „*********“ !
    INFO:librespot::audio_backend::alsa: Using alsa sink
    INFO:librespot_core::session: Country: „SE“
    thread ‚main‘ panicked at ‚called Result::unwrap() on an Err value: WireError(InvalidEnumValue(13))‘, /checkout/src/libcore/result.rs:860
    note: Run with RUST_BACKTRACE=1 for a backtrace.

    Any advice on how to proceed would be much appreciated

    5. März 2018 at 14:54 #34211

    Hi Paul,

    Thanks for pointing this out. I was able to recreate the issue. We are looking into it right now.

    5. März 2018 at 16:24 #34219

    In the meantime, you can use the Spotty Plugin on the Squeezebox Server (install version 7.9).

    Here’s the How-To on setting it up.

    5. März 2018 at 18:03 #34228

    And now we found a fix!

    We now updated the build of librespot for our Spotify Connect to account for some new changes.

    Just click „reinstall“ and it should work again.

    12. März 2018 at 14:02 #34340

    Hi Heiner,

    Thanks. I can run spotify connect through LMS, everything works fine.
    However if I try to install spotify connect plugin I get the error:
    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing
    Usage: /opt/spotifyconnect/librespot [options].

    Can you help with the missing name and how I enter it?
    Regards
    Paul

    13. März 2018 at 12:08 #34387

    Hi Paul,

    That’s the error message when you username was not recognized. Please check again in the field „Username“ of the Plugin if your premium account’s username is correctly entered.

    13. März 2018 at 19:21 #34406

    Thanks,
    tried to re-enter spotify user name but still same message. Nothing I place in the config window seems to be entered into the spotify app.
    I have re-installed spotify connect but still same error message.

    Thank you for all the assistance and time you have invested but I think I will need to look for another approach.

    15. März 2018 at 11:04 #34440

    Hi Paul,

    What status does the player put out when you start it and what output device did you select?

    15. März 2018 at 16:32 #34457

    Hi Paul,

    You did not receive the same error message as the other users whose problem we fixed, but please also try making a beta and then reinstalling the Spotify Connect Player.

    16. März 2018 at 20:44 #34485

    Hi,
    Tried beta version and reload of spotify connect.
    I still get the same debug info:
    Librespot command line options
    error:Required option ’name‘ missing.
    According to the debug info
    I am authenticated with spotify.

    The outpit device is hw:sndrpihifiberry-sn
    I have a audiophonics sound card attached.

    Kind Regards
    Paul

    19. März 2018 at 13:44 #34530

    Hi Paul,

    That all sounds good. The „error“ is fine and should not hinder playback. It’s not part of the log, bust just of the command line options. The name is listed as the name of your Max2Play device. You should still be able to play to it, I have the same output. After starting playback on your phone you should get the following output:

    #### Librespot Output ####
    INFO:librespot: librespot 8f8eb8c (2018-02-28). Built on 2018-03-05. Build ID: 1ErnJKzS
    INFO:librespot_core::session: Connecting to AP „gew1-accesspoint-b-kgs7.ap.spotify.com:4070“
    INFO:librespot_core::session: Authenticated as „xxxxxxxxxxxxxxxxx“ !
    INFO:librespot_playback::audio_backend::alsa: Using alsa sink
    INFO:librespot_core::session: Country: „DE“

    20. März 2018 at 19:33 #34584

    Thanks very much for the support. Spotify on my tablet can now see and use the max2play device.

    Issue solved!

    22. März 2018 at 13:11 #34648

    Thanks for the heads-up! 🙂

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here