Spotify Connect plugin on RPI Zero

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Spotify Connect plugin on RPI Zero

This topic contains 9 replies, has 2 voices, and was last updated by  gtj premium 3 months, 2 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 14. Mai 2020 at 14:55 #48779

    Hi guys,

    I’ve just set up a RPI Zero with Max2play and a Justboom Digi pHAT.
    I have two problems though so any help will be greatly appreciated.

    First, the Spotify Connect plugin does not autostart on boot despite I have checked the related tick box. I have to manually start it through the Max2play server page. Strangely, when I move the sd card to a RPI 3B+ the plugin will autostart normally. Why is this happening? Any ideas?

    Secondly, despite I have set the Justboom pHAT as my primary interface and have also set a -C 10 parameter to utilise both services (Spotify Connext & Squeezlite) with the same audio interfac, I haven’t figured how to set Spotify Connect’s initial volume to full. It starts around the middle and have to manually higher it from the Spotify app on my mobile phone. At the same time the Squeezlite initial volume is set to full.
    What command line values should I set for the Spotify Connect to start at full volume? I tried PCM 96% or PCM 100% but don’t seem to have any luck.

    Many thanks!

    19. Mai 2020 at 16:12 #48814

    Hi gtj,

    sorry for the late reply. I will be back in the office tomorrow and if I find the time, I will test the setup myself and then contact you again.

    17. Juni 2020 at 17:07 #49047

    Hi gtj,

    Please excuse the late reply, somehow I missed your request. I tested the autostart problem myself and it didn’t work for me either. I passed that on to our chief developer. As soon as there is a fix, I will contact you again. For the volume problem you can try the following: Enter „–initial-volume 100“ in the command line options of Spotify Connect to get the volume at 100% after starting.

    5. Juli 2020 at 3:32 #49186

    Hello Mario.

    Thank you for getting back to me.
    Is there any update on this?

    Thank you

    7. Juli 2020 at 12:37 #49190

    Hi gtj,

    Unfortunately, our developer has not yet been able to fix this bug. I will remind him again, but he is currently very busy, so that the processing of some topics in the forum may be delayed.

    8. Juli 2020 at 2:43 #49231

    Thank you for updating me.
    I’ll keep my eyes peeled if any resolution comes up.

    8. Juli 2020 at 15:51 #49267

    Hi gtj,

    Our developer has found the time today to work on your request. He has now added a fix to the Max2Play Beta. This fix will delay the autostart of Spotify Connect for the Pi Zero. Please do a beta update and tell us if it works. If it does, the fix will be integrated into the next Max2Play version.

    10. Juli 2020 at 1:31 #49276

    Hi Mario,

    Thank you for your work with this.
    I have updated to the beta version and now both Squeezlite and Spotify Connect clients will autostart and switch one another upon request.

    I have another problem though. There’s no sound on either interface. However I might be doing something wrong or missing as it’s been a while since I last set this one up and I can’t remember. I have to re-learn everything from scratch.

    Is there anything in particular I should check?

    Thank you

    UPADATE:
    I found where the problem was. The header is not secure enough and it was losing connection between the Pi and the Hat. I can confirm you can proceed with implementing this bug fix to the next official update!

    The initial volume of Spotify Connect however is still low. I did put the argument into the settings, tried also an alctl store but at all times after reboot the volume will be at 50%.
    Could you please let me know where the conf file of the client is located? I’m thinking to try to set the value to 100 there instead.

    • This reply was modified 3 months, 3 weeks ago by  gtj.
    14. Juli 2020 at 13:13 #49297

    Hi gtj,

    Please check whether there are other players running parallel to Spotify Connect, which may overwrite the volume. As far as we know, there is no file that you could edit to change the start volume of Spotify Connect.

    14. Juli 2020 at 13:17 #49298

    The regular „audioplayer“ is running alongside Spotify Connect. Should I make any volume settings there instead that will apply for Spotify too?

    BTW the beta fix works like a charm for a few days now. Thanks for the excellent work!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here