Spotify connect needs to be restarted after a few hours

Max2Play Home 2016 (en) Forums Max2Play Add-ons Spotify connect needs to be restarted after a few hours

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 11 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 2. November 2017 at 23:24 #32265

    Hi max2play team,
    I am running max2play Beta-170823 on a Raspberry PI 2 with a Hifi Berry DAC+ Pro.
    Squeezelite is very stable (with a roon server). Spotify also works fine. But after some time of not using (Raspi is always on) the Spotify Client (iOS or MAC) can not find the Spotifiy Connect on my raspberry. The service on the raspi is still running. After stopping and starting the Spotify connect on the raspi is fond immediately and is working fine.
    After some hours of not using I have reproducible the same effect.

    Regards
    Thorsten

    3. November 2017 at 12:20 #32270

    Hi Thorsten,

    I assume you are using the Max2Play Spotify Connect and not the Spotty plugin’s new feature for Spotify Connect?

    In that case, please try clicking „reinstall“ to get the latest version of librespot on which this plugin is based.

    Also, you can add the hw volume control, similarly to Squeezelite.

    edit: Du kannst außerdem versuchen, bei den Command Line Options “–device hw:0” oder “–device hw:1” einzutragen. Je nachdem, welchen Slot deine Soundkarte hat (wenn Build-In Audio deaktivier ist, ist es 0, wenn nicht, ist es 1).

    5. November 2017 at 23:42 #32299

    Hi Heiner,
    you are right. I am using the Max2Play Spotify Connect.
    I have followed your instructions but unfortunately there is still the same behavior. B. t. w., I have the same effect with an other Raspi (Raspi3, same max2play software, but Hifi Berry Digi+)

    Regards
    Thorsten

    7. November 2017 at 17:16 #32329

    Hi Thorsten,

    Do you have the Spotify/Squeezelite automatic Audio-Switch activated? Also, is your shairport autostart deactivated.

    Furthermore, have you tried running Spotty on the LMS to see whether the same problem occurs in this setup?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here