[SOLVED] Spotify connect fail to start

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify connect fail to start

This topic contains 12 replies, has 2 voices, and was last updated by  Heiner Moderator 10 months, 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 5. November 2017 at 15:35 #32287

    Hi.

    Just register and install spotify connect with tar url:
    http://shop.max2play.com/media/downloadable/currentversion/spotifyconnect.tar

    All is fine, but it’s fail to start at reboot and fail manual too.
    Here the debug:

    #### Librespot Output ####
    /bin/bash: suo: command not found
     
    
    #### Librespot Command Line Options ####
    error: Required option 'name' missing.
    Usage: /opt/spotifyconnect/librespot [options]

    A typo bug suo at place of sudo.

    Can you help please ?
    Thx

    PS: Does all premium plugins need to install with the url link ?

    6. November 2017 at 17:01 #32312

    Hi Tetsuo,

    Please try installing the beta version of Spotify Connect (replace „currentversion“ with „beta“ in the URL).

    Yes, all new plugins are available as .tar files under URL links. However, you can also install the .tar file locally and download it on any other device from our website.

    9. November 2017 at 9:06 #32372

    Thanks for your help Heiner, I’ll retry with beta url 😉

    10. November 2017 at 14:19 #32406

    Great, let me know if this fixes problem so I can close the topic 🙂

    10. November 2017 at 22:17 #32413

    Hi.
    Badly it’s not resolve.
    Try many installation.

    – go top startup tab, switch the plugin to the left, enter the beta url.
    – Try to launch, same message.
    – Go to the plugin tab, hit reinstall button, same message …

    I observe that the configuration form is always completed with my informations even after new installation
    Maybe I need to full delete all older files from the current version, but I didn’t find a way to do this.

    12. November 2017 at 11:51 #32422

    Hello Heiner.

    Just find wath’s the problem, in my login name I have a pipe character ‚|‘ so when you use the login in the script the system interpret it as a pipe.

    Just make the test with an other spotify account and it’s work well.

    Can you fix this by protect the login during command line ?

    Thnx

    13. November 2017 at 16:29 #32459

    Hi Tetsuo,

    Unfortunately, our plugin is an implementation of the librespot protocol which we do not alter. But you can add this issue as a to-do: https://github.com/plietar/librespot/issues

    17. November 2017 at 20:49 #32509

    Hi Heiner.

    No problem just post an issue on github.
    You can close here.
    Thanks for your help 😉

    21. November 2017 at 16:36 #32562

    Hi Tetsuo,

    Thanks for the follow-up! 🙂

    25. November 2017 at 12:25 #32628

    Hi Heiner, I follow the github report: https://github.com/plietar/librespot/issues/265

    As I presume, the answer is we need to quote the user variable in the command.

    Suggestion, can you quote username in spotifyconnect/controller/Setup.php at line 104:

    $parameter[] = '--username '.$_REQUEST['username'];

    to :

    $parameter[] = '--username '."\"".$_REQUEST['username']."\"";

    Thanks 😉

    28. November 2017 at 14:02 #32667

    Hi Tetsuo,

    Thanks for the detailed response. We amended the plugin for the next version, you can already get the edited version in our current beta 🙂

    9. Dezember 2017 at 20:09 #32845

    Thank you for the fix Heiner 🙂

    12. Dezember 2017 at 11:11 #32886

    Thank you for helping us find and solve the issue.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here