Wolfson dac not staying selected following a reboot

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Wolfson dac not staying selected following a reboot

This topic contains 15 replies, has 5 voices, and was last updated by  MarioM Moderator 4 months, 1 week ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • 21. Januar 2018 at 19:10 #33568

    I’m trying to set up squeezelite on an old Pi B with a Wolfson dac card. I have a licence for the full version of max2play. I select the wolfson dac in raspberry setting and reboot. when the Pi reboots and i select raspberry setting the dac is not longer selected. I’ve tried this several times and cannot get the system to reboot and keep the dac selected to enable an audio output to be selected.

    I’ve also found after rebooting max2play can default to unactivated when moving to a different menu item?

    • This topic was modified 2 years, 10 months ago by  simon e. Reason: Move forum page
    • This topic was modified 2 years, 10 months ago by  simon e.
    23. Januar 2018 at 11:51 #33607

    Hi simon,

    Please try updating to our newest beta, select none as sound card, reboot, select the cirrus logic again and reboot again.

    14. April 2020 at 17:21 #48482

    Hi!

    I have a similar problem.
    After setting up the Wolfdon card and the soundoutput, the dac stays after a reboot, but not the soundoutput.

    I use latest stable, setup without soundcard.

    I have issues with players going offline after inactivity. Is there a sleepmode somewhere to deactivate?

    Do you have suggestions about debugging?

    15. April 2020 at 14:55 #48492

    Hi Kajan,

    If I understand you correctly, the correct sound card is still selected in the Squeezelite menu after the reboot, but you can no longer output sound? Do you connect your Pi to the Internet via WiFi or via LAN?

    17. April 2020 at 10:34 #48534

    Hi MarioM!

    Yes, the correct sound card is still selected but there is no output sound. If I select output and save the sound output starts again.
    I have four Pies where three have wolfson board. Two are connected via LAN and one via WIFI, they all have the same problem. I also have one with HiFi-Berry, and this one doesn’t have the same flaw.

    21. April 2020 at 16:54 #48576

    Hi Kajan,

    We will do some testing with a Wolfson Cirrus Logic on site and hope that we can reproduce your problem.

    21. April 2020 at 17:25 #48578

    Please let me know if there are any logs or sim that you want.

    25. April 2020 at 11:51 #48614

    I have a similar problem with a different DAC.

    I have the a Raspberry Pi 3A+ with fully licensed v2.52 max2Play. My DAC is connected via USB, and is the Woo Audio WA7 (v1) which has a C-Media CM6631A reciever.

    I can set everything up and install the USB soundcard, and it works fine. The next day after a reboot it no longer can ’see‘ the soundcard and hence Squeezelite refuses to start. I can reboot as many times as I like, but this situation doesn’t change. Only when I go back to ‚Raspberry settings‘ in the Max2Play interface, choose ‚None‘ for soundcard, reboot, then again in ‚Raspberry settings‘ choose ‚USB…‘ for the soundcard and go through the 5minute install process again, then reboot twice more…. then it all works again… until the next day when its broken again!

    I also have a Pi with a HiFiBerry Digi, and that worked fine.

    I’m not an expert, but it seems like this is a software bug with the soundcard drivers and init….

    28. April 2020 at 14:51 #48640

    Hi everyone,

    sorry for the late reply.

    @kajan: Unfortunately we have not yet been able to test. But I will update you soon. In the meantime, you could test our update 2.52 and see if that might solve your problem.

    @zubrze: We will test with an external DAC as soon as we get to it. Does the Health Checker show anything strange about the power supply when using the external DAC? It may draw too much power via the USB port.

    28. April 2020 at 17:57 #48648

    Thank you for the update.
    The upgrade seems to work on the hardwired pies, but I still have the same issue with the ones on wifi.

    11. Mai 2020 at 12:45 #48752

    Hi Mario, The health checker is all green, says „OK“ for power. I bought a new cable to the DAC, but that didn’t make any difference. It seems really flaky if the DAC is ’seen‘ by the Pi on boot… So far it seems Max2Play doesn’t really at all reliably with my external DAC. I might have to try a different ditribution for the Pi.

    12. Mai 2020 at 15:08 #48762

    Hi everyone,

    I will finally be back in the office tomorrow and from then on I will be there at least once a week. I will then have the opportunity to test a few cases from the forum and will hopefully be able to recreate and test your setup too.

    8. Juni 2020 at 22:45 #48961

    Hi!
    How is the testing working out for you?

    9. Juni 2020 at 15:26 #48971

    Hi Kajan,

    Unfortunately I have not yet been able to do extensive testing. This problem is very specific and has therefore been less of a priority than others. But I will get back to you as soon as possible. Have you found a workaround for your setup so far? Do other settings work with WiFi and is only saving the sound output affected by the problem?

    20. Juli 2020 at 20:08 #49344

    No News regarding this?
    I still have the same problem. The only other issue I have is that the pieas goes to sleep.

    24. Juli 2020 at 12:51 #49416

    Hi Kajan,

    We tried to address the problem, but unfortunately had to find out that we no longer have a working Wolfson card to test with. Apart from that, our support mainly focuses on cards that we sell in our shop, which is why we are not likely to get a new test card. Therefore I’m sorry to say that I cannot offer you a solution for this very case. If the problem only occurs with a WLAN connection, I can only recommend connecting the devices via LAN. In general, this is always the better solution, since streaming is more stable this way.

    The pis do not normally have a sleep mode, only connected hard drives can automatically switch to sleep mode. For this problem, please open a new topic here in the forum.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

Register here