Sound Output Diagnosis Tools

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 11. September 2017 at 18:18 #31273

    I am about to install an RP3 & DAC+.

    Please add a “Test Output Device” button to indentify which output is selected and to test if this one works.
    I have to use cmd line tools to check the output path.

    At the moment a can “aplay” a wave file to the DAC+, but have no idea why the DLNA device brings error messages and refuses to work with the audio output..

    Thaks – Udo

    14. September 2017 at 11:24 #31317

    Hi Udo,

    Our images are very easy to set up and the default playback is your Pi’s native audio jack. The moment you select your sound card, settings are automatically made to select the right output device for it in your audio player of choice.

    You can find the output device selection in each audio player’s advanced options. Just click the “Edit Advanced Options” button in our web interface.

    You can select what setup you might want on our start menu of the web interface. After rebooting the system, your audio player, e.g. Squeezelite if you select the advanced setup, will already the right output device, e.g. with HiFiBerry DAC+ it’s “sysdefault – snd_rpi_hifiberry….”.

    That way, you just test by setting up the system you like and playing the music you like. For a quick playback check you can either select a radio station in the Squeezebox Server or do the same with any other audio player, e.g. play a file from your iPhone when using AirPlay.

    15. September 2017 at 16:57 #31347

    Hi Heiner,

    i would appreciate if thing would work like they are intended to…

    In fact the outputs are scrambled. The is only gmrenderer active, DAC+ selected, but the standard output is still selected.
    DLNA can be used, but only with the RP audio jack.

    A complete fresh installation (2.44) has the same problem.

    Using the command line “speaker-test -Ddefault:sndrpihifiberry -twav” activates RCA plugs of DAC+ as expected.
    -> HW ok.

    So the front seems to show what should be but not what really is.
    -> Test button makes sense.

    Now i am going to configure the system via text editor, even if thats what i tried to ommit and why i was willing to pay for a simple functioning solution.

    Any helpful hints?

    Thanks – Udo

    18. September 2017 at 13:32 #31366

    Hi Udo,

    With a fresh installation of Max2Play, you should immediately get the option to select HiFiBerry, HB DAC+ and your player setup in our web interface. The dropdown menu for output device selection should definitely give you options that include “hifiberry” in the name, these output devices all work with the sound card. Our default and recommended one is “sysdefault…”.
    This is literally what is selected, when you saved your DAC+ as the sound card in use and rebooted.

    We will consider adding a test button for a quick audio check, thanks for the input.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here