Sound dropouts while synced

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Sound dropouts while synced

This topic contains 10 replies, has 3 voices, and was last updated by  fvzeppelin premium 9 months, 3 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 1. September 2015 at 22:58 #15568

    For a while I have been using a LMS system (Daphile on a rather low-end Via system) with 2 players that I usually have in sync. This works well.
    But if I do the same with Max2Play on an rPi 2, I get dropouts about every 10-20 seconds. Until I stop syncing, or turn one player off. Then it plays smoothly! I have the latest updates installed.
    Any ideas?

    7. September 2015 at 15:55 #15639

    Hi hanszorn,
    This problem can have many different sources. It can be because of your WiFi signal, your power supply, your music files. Please try to eliminate the sources of error first, by changing location of the Pi’s, trying a different power supply and using different, lower quality music.
    Also, if you do not already, please try and run LMS on one of the Max2Play devices.

    7. September 2015 at 16:06 #15640

    Hi Heiner,
    Thank you for your response. I experimented a lot with moving the devices around, connecting both wired and wireless but nothing made any difference. However I am not sure if I tried local files, I usually use it for radio and Spotify.
    Regarding your last remark, it is the LMS on Max2Play that causes the trouble, independent of what kind of players I use (Squeezebox Classic, PiCorePlayer, Max2Play…). Now that I am using the LMS of my Daphile again, all problems have vanished.
    And remember: the trouble starts when I use more than one player at the same time. It seems this is too much load for the LMS on Max2Play, although the web interface is very responsive!

    7. September 2015 at 16:38 #15641

    Usually, the Pi can manage multiple players in our setups with any problems. Did you maybe forget to expand the filesystem before installing LMS? Than you would have over 80 percent of your memory used which is displayed in the debug info on Settings/Reboot. This could also be a problem factor.

    7. September 2015 at 16:50 #15642

    Will look into that when I am at home.

    7. September 2015 at 19:33 #15643

    This is what I see:

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    rootfs 7629512 3322120 3963480 46% /
    /dev/root 7629512 3322120 3963480 46% /
    devtmpfs 470368 0 470368 0% /dev
    tmpfs 94936 480 94456 1% /run
    tmpfs 5120 0 5120 0% /run/lock
    tmpfs 189860 0 189860 0% /run/shm
    /dev/mmcblk0p1 57288 14736 42552 26% /boot

    #### LOAD AVERAGE ####
    0.07 0.05 0.05 1/105 4612

    #### KERNEL ####
    Linux max2play 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.8 (wheezy)
    Release: 7.8
    Codename: wheezy

    10. September 2015 at 16:57 #15655

    The log does not indicate anything going wrong. Your system seems to be running perfectly. We can only recommend using the newest edition of Raspberry Pi, Model 2B, if you do not already. Otherwise there is nothing else to fix.

    10. September 2015 at 22:34 #15657

    It is a model 2B I am running it on. Before that I ran M2P on a model (1)B, but because of _sound dropouts_ I decided to buy a 2B. To no avail, unfortunately.

    3. February 2016 at 22:36 #18377

    I’m having a very similar problem:
    – Raspberry Pi 2 Model B
    – Fresh M2P install with JiveLite
    – Sound output via HDMI
    – LMS running on a different machine, no problems with any of the other clients
    – I’m NOT using synced playback.

    With this setup, I have sound dropouts as described by hanszorn. The M2P machine has a filesystem expanded to 8GB and CPU load is typically below 5%. HW codecs are activated (which should not make a difference 😉 ). When I take the headphone jack, the dropouts do NOT occur. Well, waiting for my HifiBerry DAC+ and hoping, that there will neither be any dropouts.

    Nevertheless, it would be nice if you could assist in solving this issue.

    Thanks!

    18. February 2016 at 14:37 #18573

    Hi fvzeppelin,
    There are a few things you can try to fix the issue. The DAC+ will work great anyways. In your current setup, however, with the HDMI output, the Pi should be the issue. Please check if you have Kodi on or on autostart, test it with just Jivelite and Squeezelite running. Also, please try connecting the Pi to another device like a TV via HDMI to rule out the port as the origin of error.
    If you have another Raspberry, please try it with the image you are using on the one with drop-outs.

    18. February 2016 at 16:14 #18584

    Hi Heiner,

    thanks a lot for your reply!
    I already tried around a little, and with the same hardware, running a Volumio image, I have no trouble at all. So I would say, the problem should neither be the hardware, nor the connection between the Pi and the TV. Additionally, Kodi is turned off in my setup.
    So I would really guess that it is a configuration problem of the Max2Play image.
    If you have any further suggestions or an opinion different from mine, please let me know 😉
    Nevertheless you’re quite right: The Pi-DAC+-combo works great!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here