Significant delay when using AirPlay/Shairport

Max2Play Home 2016 (en) Forums Max2Play Add-ons Significant delay when using AirPlay/Shairport

This topic contains 5 replies, has 2 voices, and was last updated by  JoshHeng premium 3 days, 7 hours ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 3. Dezember 2018 at 21:58 #42509

    Hi,
    I have a Max2Play Squeezebox/Squeezelite setup on a Raspberry Pi 3 Model B+.
    When I use AirPlay from any of my Apple devices, there is always a significant delay of around 1-4 seconds. This means that it is impractical for tasks such as videos, games and phone calls.

    Is there a way to reduce this delay?

    Thanks,
    Josh

    3. Dezember 2018 at 22:06 #42510

    Sorry, I am actually using the ShairTunes2 plugin for Squeezebox instead of Shairport

    4. Dezember 2018 at 17:09 #42556

    Hi Josh,

    Yes, if you have not yet try connecting via ethernet cable. Also make sure your Pi is running smooth in the Settings/Reboot’s Health Checker during playback. You can also check your power supply, we recommend using 5V 3A with the 3B+ and if you have USB periphery connected try removing that too.

    4. Dezember 2018 at 23:13 #42567

    Hi,
    I am unable to wire an ethernet cable to my Raspberry Pi as it is a long way away from any router/switch and all Powerline adapters don’t seem to work well.

    I do have a 5V 3A power supply, and the only USB peripherals I have is one USB sound card.

    The health checker’s results:
    Internet: Connected
    CPU Load: 0.23
    SD Card Usage: 14%
    Temp CPU: 51.5
    Power Supply: OK

    Thanks, Josh

    7. Dezember 2018 at 12:27 #42594

    Then it should be an issue with your WiFi. With AirPlay you stream from your phone to your router to your Pi. So the distance and WiFi modules‘ signal strength matter the most.

    You can try a WiFi adapter if you have one available.

    9. Dezember 2018 at 14:59 #42620

    Ok, thank you for your help.

    Josh

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here