Shareport (Airplay) no sound/no longer working streaming Music from my iPhone

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Shareport (Airplay) no sound/no longer working streaming Music from my iPhone

This topic contains 7 replies, has 2 voices, and was last updated by  Fredly 1 month, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 15. Juni 2020 at 20:43 #49015

    I have several Max2play setups and have use Shareport (Airplay) many time to stream music from my iPhone to Max2play.

    I see „Max2play“ as an option under Airplay, I can select it, its ticked off and it shows the connection iPhone -> Max2play, but no sound comes out

    I do not have any Shairtunes plugins installed.

    If anyone that can explain why this is happening, I would greatly appreciate it.

    Cheers, Fred in Canada

    16. Juni 2020 at 14:13 #49026

    Hi Fred,

    Has Airplay ever worked for you? If so, did you change anything in your system before it stopped working? Which Max2Play version do you use? Which pi?

    16. Juni 2020 at 19:45 #49032

    Yes, I have used Airplay several times successfully and never had a problem.

    But I just tried it recently and again…no sound. (Has the Airplay protocol change as I understand Airplay 2 is the latest version)

    I have three configurations, none work with Airplay.

    I have a Raspberry Pi 4 with external DAC, and Pi 3 with an Allo DAC hat and the Allo miniBoss.

    All run the latest Max2play V2.52

    (In Max2play, under Audioplayer I have simply checked „Autostart Sharport(Airplay) button)

    Again any assistance here would be greatly appreciated.

    Fred in Canada

    17. Juni 2020 at 12:16 #49040

    Hi Fred,

    As long as your system hasn’t changed since the last time Airplay worked, it should still work the same. If the problem occurred after you updated to version 2.52, the problem can of course be due to the image. We will try Airplay again with a test device to rule this out. Has anything else changed on your iPhone? Do other services like Squeezelite work? And can you possibly test whether one of the Airplay plugins for the Squeezebox server works with your devices?

    Edit: I have just successfully tested Airplay with v2.52. Can you make sure that no other services are running in parallel and that the sound card is not blocked? Which audio output did you choose for Shairport?

    • This reply was modified 1 month, 4 weeks ago by  MarioM.
    17. Juni 2020 at 18:56 #49048

    MarioM, thanx in advance for you assistance here.

    OK, I have verified that the correct audio output for my Pi systems is selected.

    System 1 – hw – Khadas Sound Card

    System 2 – hw – Boss Dac

    I don’t use Airplay regularly, so I cannot confirm if a iPhone update has caused Airplay to stop working

    (My iPhone Ver is 13.5.1)

    Squeezelite is used by both my Pi Configs, so that is working correctly/how I currently play music.

    Sorry, how do I identify if I have other services running in parallel or if the sound card is blocked?

    …and what Airplay plugins for Squeezebox are available/that I may test.

    Thanx for your support thus far, Fred in Canada

    17. Juni 2020 at 21:12 #49050

    Mario, its not great or anything, but I have created a quick video, showing you what I see at my end, Fred

    Hope this helps, Fred

    19. Juni 2020 at 13:49 #49054

    Hi Fred,

    Unfortunately I cannot play the video („video is not available“). Squeezelite, for example, would be a service that runs parallel to Shairport and may block the sound card. Can you test if Shairport works if you disable Squeezelite? Does the sound output match in the advanced settings of the two services?
    There are two Airplay plugins for the Squeezebox Server that you could try. Here is a quick guide: https://www.max2play.com/en/how-tos/howto-airplay-with-max2play/

    20. Juni 2020 at 16:33 #49056

    MarioM, I did get the Airplay feature working.

    Shareport/Airplay DID work when I disable Squeezelite services, but did NOT work when Squeezlite was enabled.

    So, as you suggestion, I disable Shareport/Airplay within Max2play and installed the Shairtunes2 plugin and all worked as usual.

    (Again I have only ever used the Shareport/Airplay simultaneously with Squeezelite and have never had a problem like this in the past)

    Thank you once again for your assistance and hopefully someone can learn by my mistake.

    Take care, Fred in Canada

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here