ShairTunes2 (v0.19) Plugin failed to load

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) ShairTunes2 (v0.19) Plugin failed to load

This topic contains 6 replies, has 4 voices, and was last updated by  Heiner Moderator 1 year, 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 14. August 2017 at 21:09 #30623

    RPi B
    Fresh install of Max2Play 2.44, with iQAudIO support
    ShairTunes2 (disaster123) won’t load – also put the repo in „Additional Repositories“ in LMS plugin settings, but doesn’t help

    Any thoughts??

    15. August 2017 at 16:14 #30644

    Hi bob,
    Please check the inactive plugins of the LMS and activate shairtunes2 (fork).

    15. August 2017 at 23:12 #30653

    Hi Heiner,
    I’ve encountered the similar problem with 2.44.
    I’ve tried to install shairtunes plugin for Squeezebox Server via the Max2Play Plugin Page.
    After that I got the same error. Shairtunes plugin v0.19 won’t load.

    After your post I’ve recognized that Shairtunes2 (fork) v0.70.4 should be activated.
    But I’ve got the same error, because Net:Sdp couln’t be found.

    Module [Plugins::ShairTunes2::Plugin] failed to load:
    Can’t locate Net/SDP.pm in @INC

    After manual installation of Net:Sdp the plugin starts, but Airplay still isn’t working 🙁
    The Plugin claims „WARNING: Either LMS or the enabled/disabled players must be restarted for modifications to be taken into account“
    All players and the server were restarted but still no Airplay devices is visible either at iphone nor ipad!?
    Any ideas?
    Best regards,
    Ralf

    15. August 2017 at 23:56 #30654

    Thank you Heiner,

    I found the (fork) version last night and all works properly – squeezelite power script and all. now trying to get rid of dmix.

    Perhaps the instructions (actually the plugin itself) for installing shairtunes2 could be changed to the phillipe version? („Install special Plugins for Squeezebox Server“ on Squeezebox Server Tab).

    2 quick issues – sorry for putting them here… (i) notice you have a Daemonize startup option for squeezelite startup – is this ever necessary? assume m2p does that… (2) I didn’t use the iQaudIO option, but see that m2p has defaulted audio to iQaudIO card – guess that’s because squeezelite does that automatically.

    Thanks again!

    17. August 2017 at 14:13 #30682

    Hi guys,

    @ralf: We do not recommend installing packages manually with Max2Play. Shairtunes2 works out-of-the-box, now. First try disabling the faulty version and running only the 0.79 (fork). If that does not work, please burn a fresh image and immediately after installing the SBS, head to the settings of it and activate shairtunes2 (fork). We will remove the faulty version of shairtunes2 in our next release.

    @Bob: Thanks for the feedback, this will be fixed in the next release of Max2Play and will already be fixed in newly downloaded versions and in the beta in the next days. Regarding your other questions: I am not sure I follow on what information/feedback you require?

    17. August 2017 at 16:57 #30683

    Hello

    I encountered the same difficulties as Ralph to install the Shairtunes2 plugin. I had first installed the one you recommend in your interface (disaster123 version). It does not work (can’t be loaded). I tried to install the version of Philippe (fork). After activating it and restarting the server, it does not appear in the functional plugin and remains in the third-party plugin list not activated. In your answer to Ralph, you say there must be a conflict between the old version of disaster123 and the version of Philippe.
    So I would like to uninstall my current server to go back on a clean installation and redo the manipulation without having previously installed Shairtunes2 version disaster123. How can i uninstall the squeezebox server from Max2Play?

    Thank you

    21. August 2017 at 13:16 #30717

    Hi Fabien,

    You just install the new version you want and it replaces the current installation.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here