Shairtunes2 Plugin not loading on Max2Play 2.37

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Shairtunes2 Plugin not loading on Max2Play 2.37

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner premium 3 weeks, 2 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 1. November 2016 at 20:27 #23630

    Dear all,
    I just installed the Squeezeboxserver on my new Raspberry pi with max2play image 2.36. I also wanted to install the sharetunes2 plugin but it doesn’t install. I also upgraded to max2play 2.37 (premium license) – same problem. The squeezebox server itselfs works without any problem.
    I performed the following steps:
    Downloaded image from max2play and wrote image to SD card. Raspi pi 3 B correctly boots. Upgrading to max2play 2.37, expanding file system, set mount point to Windows share – everything is fine. Installation of SqueezeBoxServer 7.9 (nightly) worked. Squeezeboxserver up and running, scanning music library, connected 6 Squeezebox Touch, all playing fine.
    On the max2play Squeezebox tab, I installed the shairtunes2 plugin but it doesn’t install. The plugin is shown unmarked on the Squeezeboxserver plugin tab with the note “Plugin could not be loaded”.
    Log shows the following kines:

    BEGIN failed–compilation aborted at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/ShairTunes2/Plugin.pm line 27.
    Compilation failed in require at (eval 879) line 1.
    BEGIN failed–compilation aborted at (eval 879) line 1.
    [16-10-31 17:53:19.7198] Slim::Utils::PluginManager::load (323) Error: Couldn’t load Plugins::ShairTunes2::Plugin

    I Wrote a fresh image to the SD card again, did the same steps as above again – no success.

    How can I get shairtunes2 to load?
    I also use a Logitech Media Server (Nightly 7.9) on a Windows 2012 R2 for years and the shairtunes plugun loads without a problem.

    • This topic was modified 1 month ago by  Webkemmi.
    • This topic was modified 1 month ago by  Webkemmi.
    2. November 2016 at 11:21 #23634

    I just startet the installation of shairtunes2 again and had a look at the installation log. Obviously one of the installation sources can’t be found!

    Reading package lists…
    Building dependency tree…
    Reading state information…
    The following extra packages will be installed:
    libauthen-sasl-perl libcrypt-openssl-bignum-perl libencode-locale-perl
    libfile-listing-perl libfont-afm-perl libhtml-form-perl libhtml-format-perl
    libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
    libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
    libhttp-message-perl libhttp-negotiate-perl libio-html-perl
    liblwp-mediatypes-perl liblwp-protocol-https-perl libmailtools-perl
    libnet-http-perl libnet-smtp-ssl-perl libnet-ssleay-perl libsocket6-perl
    liburi-perl libwww-robotrules-perl
    Suggested packages:
    libdigest-hmac-perl libgssapi-perl libdata-dump-perl libcrypt-ssleay-perl
    libauthen-ntlm-perl
    The following NEW packages will be installed:
    avahi-utils libauthen-sasl-perl libcrypt-openssl-bignum-perl
    libcrypt-openssl-rsa-perl libencode-locale-perl libfile-listing-perl
    libfont-afm-perl libhtml-form-perl libhtml-format-perl libhtml-parser-perl
    libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
    libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
    libhttp-negotiate-perl libio-html-perl libio-socket-inet6-perl
    libio-socket-ssl-perl liblwp-mediatypes-perl liblwp-protocol-https-perl
    libmailtools-perl libnet-http-perl libnet-smtp-ssl-perl libnet-ssleay-perl
    libsocket6-perl liburi-perl libwww-perl libwww-robotrules-perl
    0 upgraded, 30 newly installed, 0 to remove and 23 not upgraded.
    Need to get 259 kB/1672 kB of archives.
    After this operation, 5068 kB of additional disk space will be used.
    Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libnet-ssleay-perl armhf 1.65-1+b1
    404 Not Found [IP: 5.153.225.207 80]

    (Reading database … 70226 files and directories currently installed.)
    Preparing to unpack …/cache/libnet-sdp-perl.deb …
    Unpacking libnet-sdp-perl (0.07-1) over (0.07-1) …
    Setting up libnet-sdp-perl (0.07-1) …
    Processing triggers for man-db (2.7.0.2-5) …
    Shairtunes2 installed
    Restarting logitechmediaserver (via systemctl): logitechmediaserver.service.
    Finished

    • This reply was modified 1 month ago by  Webkemmi.
    2. November 2016 at 15:55 #23639

    anybody out there from max2play?

    2. November 2016 at 16:38 #23640

    Hi Webkemmi,
    Thanks for posting here and thanks for buying our premium license. I just made a fresh install and retraced your steps. We were then able to find the issue and fixed it in a beta update which you can already activate. It will then be included in our next official update. When you do the beta update, just install the shairtunes2 plugin again afterwards, reboot and the plugin should show up active in your LMS settings.

    3. November 2016 at 11:39 #23642

    Heiner,
    thanks – it works well now 🙂
    Another question:
    When the Raspberry is turned on and connected to my TV, it always switches the source back to the Raspberry after some seconds, even if Kody is stopped.
    How can I prevent it to send the CEC signal to the TV? I would like to keep Kodi up and running but I don’t want it to switch the AV automatically.
    Thanks
    Stefan

    • This reply was modified 4 weeks, 1 day ago by  Webkemmi.
    9. November 2016 at 17:23 #23845

    This is unfortunately an issue with your TV that we cannot diagnose for you. It might be due to the mode of your TV or its configurations. Maybe contact your TV’s support channel?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here