Shairtunes2 – no audio

This topic contains 3 replies, has 2 voices, and was last updated by  MarioM Moderator 7 months, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 1. April 2020 at 10:47 #48371

    Hi

    I’ve setup my Sqeezelite client+server and to prove everything worked fine I was also able to play music from my iphone using the spotify connect plugin

    I then tried to install Shairtunes2 and initially I could not even get into the settings section because of a problem already reported in this forum:

    404 Not Found: plugins/Extensions/settings/plugins/ShairTunes2W/settings/basic.html

    Shairtunes

    To solve this issue I have then updated as suggested here:

    https://github.com/disaster123/shairport2_plugin/blob/master/README.md

    > apt-get upgrade libcrypt-openssl-rsa-perl libio-socket-inet6-perl libwww-perl avahi-utils libio-socket-ssl-perl

    Now Shairtunes2 install ok and I am able to access the settings section but if I stream from my phone no audio comes out of my PI

    Audio card is cirrus logic and all set correctly (spotify connect plugin keeps working fine) so issue is only with Shairtunes2

    Even if no audio I can see from LMS page tracks are played correctly so I’m confused…

    Any idea? Can you help?

    Thanks

    1. April 2020 at 13:28 #48383

    Hi Steve,

    I was just trying to recreate your problem and applied the fix as described here: https://www.max2play.com/en/forums/topic/shairtunes-3/
    After the update, Shairtunes could be started and after selecting the correct file format in the Shairtunes settings, I was able to stream music from my mobile phone (Android with AllConnect via Airplay). In my setup I simply used the jack output of the Raspberry Pi, i.e. without a sound card.
    Is Squeezelite running on your setup? You could try the fix again as in the other thread and first output the sound only via the Raspberry Pi to completely rule out that the problem lies with the sound card.

    1. April 2020 at 14:19 #48384

    Hi Mario

    I’ve found what the problem is. Based on your reply I’ve played with the encoding parameter for the Shairtune2 abd found out I had WAVE selected. I’ve changed it now to MP3 or FLAC and now both work. Can you confirm WAVE does not work for you as well? My audio card is fine and it’s selected as direct hw mode Thanks

    2. April 2020 at 14:32 #48393

    Hi Steve,

    I can confirm that Wave doesn’t work for me either. I will therefore take a closer look at this soon. But nice that it works for you now in this way.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here