Shairtunes streaming sounds jittery and horrible

Max2Play Home 2016 (en) Forums Max2Play Add-ons Shairtunes streaming sounds jittery and horrible

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 9. Januar 2019 at 11:47 #43319

    I’m having a problem with Shairtunes that I was hoping you might know of a resolution to. I’ve just recently moved to MAX2PLAY with a HiFiBerry AMP2 (From a poorly maintained Mopidy release) and I can stream direct to the Pi via Shairport (I also had no problems streaming when I was running Mopidy and I don’t think that was using Shairport) but as soon as I attempt to stream to it via Shairtunes it has a horrible stutter and delay through it all. Playing local media with sync between the Pi and PC works perfectly.
    -Streaming is from a HTC U11 via Airplay in HTC Connect
    -I have tried casting via Shairtunes to the latest MAX2PLAY Pi image as well as a Windows 7 machine running Squeezelite and both have the same result
    -Pi is running over WiFi and W7 is via Ethernet
    -Streaming and syncing local media works fine
    -I have tried LMS that is included in M2P as well as an install of 7.9.1 on my NAS and both have the same result

    Recording of the issue and logs are here: https://1drv.ms/f/s!AnJJzI94O7vbiFNdjWSoSV0trLby
    You can hear around the 10 second mark after the audio has been stopped that it is still playing very choppy. I hit stop around the 1 second mark in this example and there’s a very long delay before it stops.

    10. Januar 2019 at 10:37 #43376

    Hi justinj,

    Thank you for the detailed report.

    I saw you also already posted in the slimdevices forum on the matter, you should get some insight from them as well.

    I would recommend also trying out a different smartphone or streaming device output for AirPlay to rule out an issue with the HTC.

    10. Januar 2019 at 10:50 #43383

    Yes I did post there too as I couldn’t initially post here. I’m thinking the issue has to be outside of the HTC seeing as how I can use Airplay from HTC Connect (So connecting it exactly the same way from the phone’s perspective) to Shairport on M2P and my old Mopidy install without any issues. The only variable in this situation has been Shairport Vs Shairtunes. I did try from an older HTC device (Just to be thorough in by debugging before posting) and achieved the same bad result (and success via Shairport).

    10. Januar 2019 at 12:20 #43390

    We added a security measure to counter spambot registration. That’s why you couldn’t immediately post here.

    With both devices using the same protocol, it could still be connected to the HTC Connect software. Try using a genuine AirPlay device if possible.

    You can also check your Health Checker in Settings/Reboot during playback on the Squeezebox Server device to make sure the Pi is not somehow constrained.

    10. Januar 2019 at 15:15 #43424

    I can’t see what it could be in the HTC Connect software as there is NOTHING being changed on the phone at all. Even if both Shairtunes and Shairport use the same core, there has to be some kind of buffer setting or similar causing this. It’s not the Pi as I’ve tried the Pi, NAS and Windows machine as the LMS server and the Pi and Windows machine as receivers.
    I’ve played with the buffer settings in Shairport options but are there some other options somewhere? Perhaps hidden from normal view?

    11. Januar 2019 at 15:23 #43511

    I thought the issue was with shairtunes not shairport? You can find the shairport settings in the „advanced“ menu in the Squeezebox Server settings.

    12. Januar 2019 at 1:16 #43546

    Sorry it is to do with Shairtunes. So many similar names I listed the wrong one.
    It works fine with Shairport direct to the M2P device but I want to sync the audio between rooms so I need to use Shairtunes which is what I’ve played with the buffer and encoding settings of to no avail.

    12. Januar 2019 at 16:50 #43555

    So it appears to be an issue with variable packet sizes from the HTC Connect app. Issue has now been fixed in the 104.4 version of Shairtunes https://github.com/philippe44/ShairTunes2
    Not sure what’s needed for you to pop that into your repo/image but it’d be good to update M2P for others that might have the same issue and not know how to update manually.

    14. Januar 2019 at 15:09 #43591

    Hi justinj,

    Updates for shairtunes2 and all other plugins for LMS should pop up automatically in the Squeezebox Server settings menu (blue button in M2P -> settings in the bottom right corner -> „plugins“ menu)

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here