Shairport Buffer Delay

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Shairport Buffer Delay

This topic contains 2 replies, has 2 voices, and was last updated by  Mbydeen Moderator 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 28. January 2017 at 17:07 #26377

    Hi I would like to ask for some help as I have done multiroom audio in my home with m2p but one of my rooms has 3 computers in room, they will play audio of films using TuneBlade at all the times but shairport has very huge delay for bufferization. So what i mean if you are watching film your audio of film will be behined 2-3 seconds how could i bring it to 0 ? Thanks

    29. January 2017 at 21:04 #26394

    After few hours of searching I have found the Archive of Shairtunes 1 and 2 that is used for squezebox server and few files with settings in compiled files. However quezebox is instant and has no delay. Shairtunes.zip has a folder src with a file “hairtunes.c” and there is line “#define START_FILL 100” How could I get same config file for plugin installed in /opt/shairport I take it that is airplay not the plugin for squezebox ?

    Please help me out if you can guys I hope I am clear enough am kinda newbie in this whole thing [=

    • This reply was modified 6 months, 2 weeks ago by  splitek.
    14. February 2017 at 16:52 #26925

    Dear splitek,

    Sorry for the late response, we have tested TuneBlade and you can configure the settings for the latency, by clicking on settings > AirPlay Streaming > and choose Real-time Streaming or Custom buffer size to 0.

    I think that solution would be the most convenient for you, instead of recoding the plugin, if you are a developer, you can check the whole project on:

    https://github.com/max2play/webinterface

    Best Regards,
    Mohammad Mbydeen

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here