Setting a mount point

This topic contains 6 replies, has 5 voices, and was last updated by  Heiner Moderator 8 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 29. September 2015 at 22:23 #15889

    I am having great difficulty setting the mount point for my music files. From other posts on the slimdevices forum I’m not the only one who has had this problem. The „help“ is confusing and ambiguous and so I would suggest that an example would be very helpful. So why not use my set up as the example:

    I have a Synology DS 214. I have created a folder called „music“ and my albums are in a sub- folder called FLAC. I know the IP address of the 214.

    I have no idea whether the 214 is nfs or cifs and no idea how to find out.

    So what is “ PATH“ ? Is it music ?? What do I put in the second box? – /mnt/music/ ?

    How do I find out whether to use nfs or cifs?

    30. September 2015 at 15:03 #15907

    Hi iansr,
    Path is the path the folder with your files is in. So you type the „IP address or name of your server“/music/FLAC
    Mountpoint is the path where your squeezebox server or other extensions can reach your folder, you can just use the example /mnt/share
    cifs is the typical network share for Windows systems and nfs typical for Linux. So use the former, usually.
    Then in the options you can also copy and paste the example and then change the name and password to the name and password of your network share.

    1. Oktober 2015 at 11:54 #15911

    Got a USB Flash drive on mine. I log in and did this:

    mkdir /media/64G_USB_Flash
    apt-get install exfat-fuse exfat-utils
    mount /dev/sda1 /media/64G_USB_Flash/

    Added this to /ect/samba/samba.conf can add it by typing:

    nano /etc/samba/smb.conf

    [64G_USB_Flash]
    comment = 64G_USB_Flash
    read only = no
    path = /media/64G_USB_Flash
    guest ok = yes
    public = yes
    writable = yes
    available = yes
    create mask = 0664
    force directory mode = 2775

    At the end of it.

    I all so under the ####### Authentication ####### I change the security = to share so like this:

    security = share

    Then don’t need a password to go to it’s folder and save files to it.

    All so added my workgroup = rday Use what ever workgroup name on your LAN you have. I just do my 1ST initial and last name.

    Can save it by CTRL O and quit out of the edit with CTRL X. It shows it at the bottom the ^ means Press CTRL.

    Then restarted samba with:

    /etc/init.d/samba restart

    Then can easy save it by going to the Max2Play „FILESYSTEM MOUNT“ It will show up there.

    Mine looks like this:

    UUID=4E4F-2C00 then /media/64G_USB_Flash then exfat then defaults

    Said save it and now on reboots it mounts it.

    Sort of hard to know that info just to put it in the web page of it.

    blkid

    will show it’s UUID and Type. So can type it in the web page of Max2play. I guess after you make a folder can then use the webpage to mount it. I don’t think you can do it all from the Max2play web page.

    Can’t type all the same as I used. Use your own. Common sense. Like were I mounted mine and the UUID will not be the same.

    • This reply was modified 3 years, 1 month ago by  Raymond Day.
    • This reply was modified 3 years, 1 month ago by  Raymond Day.
    • This reply was modified 3 years, 1 month ago by  Raymond Day.
    • This reply was modified 3 years, 1 month ago by  Raymond Day.
    9. Februar 2018 at 18:07 #33933

    I’m having this problem also. No matter what I try, I can’t get the shared folder to mount. I try with IP, with network share name, I’ve tried various versions of the path, with CIFS with NFS, with the connect string (user=, pw= and so on…) and nothing seems to work.

    Internal on my NAS, the path is:
    /share/CACHEDEV1_DATA/Multimedia/Music

    On my network via a browser or any other streaming device, it is:
    GMGNAS/Multimedia/Music

    M2P sees the server and will enter the information, but I keep getting a path error. Other streaming devices on my network (Volumio, moOde) see the server just fine. But for some reason, M2P just won’t connect.

    Can someone help?
    Ok, so here’s the problem.

    M2P was seeing my network name for the NAS, but required its IP. I have the files loading now.

    • This reply was modified 9 months, 2 weeks ago by  Hammerhead.
    12. Februar 2018 at 11:55 #33951

    Hi Hammerhead,

    Thanks for following up on your issue, happy to hear you got it fixed over the weekend 🙂

    23. Februar 2018 at 21:41 #34070

    Allo Digione Player.
    Set up Squeezebox Server with SqueezeLite. Music stored on external Western Digital USB HDD connected to the Pi. Music player works great, but having trouble with setting up a Samba share to the drive. I want to use the HDD for other storage, and I want to be able to add additional music if I can. I followed the Samba share directions, used the suggested fill ins, but all I got was error messages.

    Here’s where I get lost in the instructions:
    „The second field requires the actual path of your share. You need select an existing path on your filesystem“

    I don’t know how to find the correct path. Help please.

    27. Februar 2018 at 16:51 #34110

    Hi fahzz,

    This is the folder in the Pi that is used for the SambaShare. You can just use the example, or something like „media/usb2“ which is then created instead 😉

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here