Set max bitrate for SMSL AD18 on USB

Max2Play Home Forums Max2Play on Raspberry PI Set max bitrate for SMSL AD18 on USB

Viewing 4 posts - 1 through 4 (of 4 total)
  • 22. Juni 2019 at 11:53 #45893


    I am very new to max2play and I am currently testing it on an Audiophonics Rasptouch. I use an SMSL AD18 plugged on USB to use the digital output.
    Which is working well ! But the output is stuck to 48kHz when I would like to set it to 24bits/96KHz (or more, but I am not sure if this amp can input more …)

    I had a look in the wiki and here in the forum, most of the answers are routing to the squeezelite parameters but I do not exactly what to enter, and where.
    Do you have anywhere in the wiki/forum/… examples of settings to enter so that I can try to configure it ? Thanks !

    Other than that, I managed to install and run everything on my own, it works great 🙂

    24. Juni 2019 at 13:32 #45905

    Hi GuiPoM,

    Here’s the wiki you’re looking for.

    The parameter is:
    -a <b>:<p>:<f>:<m> Specify ALSA params to open output device, b = buffer time in ms or size in bytes, p = period count or size in bytes, f sample format (16|24|24_3|32), m = use mmap (0|1)

    27. Juni 2019 at 23:41 #45976

    Hello !

    I sorry for answering so late, I haven’t been notified for your answer 🙁

    Yes, I have seen this wikipage, but I do not manage to make my amp switch to more that 48KHz. Is there any place here on the forum or anywhere else where people share some settings so that I can compare ?

    I do not know what to enter. I tried lot of values, from the simple -a 32 to more complex but I can’t make the smsl amp display anything else than „48KHz“ when plugged on windows I can get 96Khz or 192KHz 🙁

    I was hoping someone here would have tried max2play with an usb amp but I can’t find any hint.

    27. Juni 2019 at 23:54 #45977

    I got something working with :
    Soundcard: hw (Direct hardware device without conversion) <here this is my SMSL AD18 but should be the same for other USB DAC or AMP)
    Param ALSA: default 80:4::
    Command line options: -a 40:4:24_3:1 -b 50000:50000 -p 90 -r 96000 -u hMX

    And tada, 96KHz is now displayed. But I do not manage to make to work higher than 24/96, which is already great !

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here