Sample rate problems with USB M2Tech HiFace DAC and maybe others

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Sample rate problems with USB M2Tech HiFace DAC and maybe others

Tagged: 

This topic contains 0 replies, has 1 voice, and was last updated by  Ajax 2 years, 3 months ago.

Viewing 1 post (of 1 total)
  • 3. Juni 2018 at 12:54 #36032

    Hello,

    Disclaimer: This post is not intended as a question but as a hint for others. I haven’t found a better place to post then here.

    today I stumbled over the sampling rates of my USB-DAC M2Tech HiFace DAC: It was limited to 44,1 or either 48 kHz as shown by „cat /proc/asound/card1/pcm0p/sub0/hw_params“ even while playing hires audio files. The DAC is capable of 384 kHz…

    After fiddling with several options it turned to be the selection of the output for squeezelite. The HiFace DAC has as relvant options: Default, sysdefault and front. Using the former two leaves the effective sampling at max 48 kHz. Only with front I get:

    [email protected]:/opt/max2play# cat /proc/asound/card1/pcm0p/sub0/hw_params
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 192000 (192000/1)
    period_size: 3840
    buffer_size: 15360

    I suppose other USB DACs may be harmed in this way also.

    Ciao,

    Martin

    • This topic was modified 2 years, 3 months ago by  Ajax. Reason: Bold for sample rate
    • This topic was modified 2 years, 3 months ago by  Ajax. Reason: Deleted double output of cat
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Register here