Samba Share Examples?

This topic contains 16 replies, has 4 voices, and was last updated by  Heiner Moderator 5 months, 1 week ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • 4. Januar 2019 at 12:19 #43110

    Hi, I need some help please. I am trying to mount a samba drive to which is connected via USB to my router. My router’s address is: 192.168.1.254. My Pi is connected to this same router.
    Below is what I have been writing in the various sections and 50 variations. But what ever I try dosn’t work.
    //192.168.1.254/share
    /mnt/share
    cifs
    user=samba,password=12345678,sec=ntlm,iocharset=utf8,vers=1.0

    Any suggestions please

    • This topic was modified 5 months, 3 weeks ago by  Weka_1.
    4. Januar 2019 at 14:11 #43151

    Hi. Have you tried putting in the address of your Samba drive (your NAS or whatever), rather than your router? It looks like you’ve not done this! That’s the only difference I can see from my (working) Samba share…
    Good luck!
    Malc

    5. Januar 2019 at 1:11 #43163

    Hi thanks for the reply. On this router the samba share has the same address as the router. My macbook can see it on the network as: smb:192.168.1.254 maybe i can try that? I have tried this many times several times over and cant get it to work. Must be doing something silly somewhere….

    6. Januar 2019 at 9:21 #43168

    Hi Weka_1

    Edit version

    //192.168.1.254/share means that you inside your routers samba settings have called your device: share!! (or on some routers) you have called your harddrive share when you formatted it)

    /mnt/share means that on your Raspberry Pi you have created a folder called share

    (sudo mkdir /mnt/share)

    given it permissions like
    (sudo chmod 775 -R /mnt/share)

    changed the owner to the name of your pi (stand name = pi)
    (sudo chown -R pi:pi /mnt/share)

    user=samba,password=12345678 (this is just an example not the real password for your router right???)

    please check all of this and let us know!!

    • This reply was modified 5 months, 3 weeks ago by  Cassio299.
    • This reply was modified 5 months, 3 weeks ago by  Cassio299.
    • This reply was modified 5 months, 3 weeks ago by  Cassio299.
    6. Januar 2019 at 9:27 #43171

    Hi ,
    the router address / samba share is 192.168.1.254 i am sure of that. But you are right about the share name
    I got rid of the share. and i can see it loading up when i reboot and read the text. So I am making some progress. Now it it gives me this error:
    mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Mountpoint NOT added! Please refer to the description below!

    The 12345678 is my password for the samba share.

    Ok boom I havent made those directories or made those permissions. Let me try that. Thanks for your help

    • This reply was modified 5 months, 3 weeks ago by  Weka_1.
    • This reply was modified 5 months, 3 weeks ago by  Weka_1.
    • This reply was modified 5 months, 3 weeks ago by  Weka_1.
    6. Januar 2019 at 9:52 #43176

    Sorry I just look up some standard internal ip addresses and yours were among it.

    If you still gets trouble after that the remove the password settings in your samba settings and just use your routers login and password

    6. Januar 2019 at 9:54 #43177

    hey no its fine i appreciate the help. ok. i will try that.

    9. Januar 2019 at 2:20 #43281

    https://youtu.be/C8Vd2pNgK9M

    Hi, click the link above, when my pi reboots I could see that on the text. The share was found but it was unable to accept my password. Am I correct in this? I got the remote control going and am easily able to follow any commands. I put all those ones through and made new directories mnt/share.

    Now I wonder what to do.

    • This reply was modified 5 months, 2 weeks ago by  Weka_1.
    10. Januar 2019 at 4:37 #43350

    If the Pi can’t login to your shared disk, it will not mount it!!

    It is quit easy to see if your disk is mounted:

    option 1: connect you pi to a monitor/TV

    – click the raspberry icon in the menu bar on the desktop
    – click settings
    – click Appearance Settings
    – mark Mounted Disks at the bottom of the page
    – click ok

    option 2

    ssh to pi from another Mac or PC

    cd /mnt/share
    ls

    You should now see folders and/or files from your disk connected to your router

    If your shared disk is not mounted…… you will have to dobb or tribble check your settings especially:

    sodu nano /etc/fstab

    remember: there is no space between your code every space is a tab.

    (to close fstab after you have edited: Control+X type:yes hit:enter)

    10. Januar 2019 at 4:41 #43351

    ok thanks. ssh is working great. catching up on linux commands at the moment. will check fstab. Please how to start max2play from the linux gui? Where is it installed?

    Ok its definitely definitely definitely not mounted

    yes problem is in that fstab file. No password is there. I am trying to copy paste it. But cant yet.

    • This reply was modified 5 months, 2 weeks ago by  Weka_1.
    • This reply was modified 5 months, 2 weeks ago by  Weka_1.
    10. Januar 2019 at 4:44 #43352

    You can only see the gui if you connect a tv/monitor

    ohh…. Im forgetting that Max2play dos’nt have the full raspbian version you might not be able to mount disks on the disk top!!
    Better stick to the ssh method!!

    10. Januar 2019 at 4:53 #43355

    //192.168.1.254 /mnt/share cifs user=name,password=pass,sec=ntlm,iocharset=utf8,vers=1.0 cifs user=samba,password=12345678,sec=ntlm,iocharset=utf8,vers=1.0

    The debug info is the same as the critical lines in my fstab file. The info is doubled up?

    • This reply was modified 5 months, 2 weeks ago by  Weka_1.
    10. Januar 2019 at 6:18 #43357

    Exact !! we have to do some cleaning Heres what it should look like:

    //192.168.1.254/share <tab x1> mnt/share <tab x1> cifs <tab x1> user=samba,password=12345678,sec=ntlm,iocharset=utf8,vers=1.0 <tab x1> 0 <tab x> 0

    Check that the above filenames share + user and password are correct !!

    <tab x1> = the tab button

    You navigate the cursor inside fstab with the arrow keys!!

    Its one long line. Don’t mind when some of the text disappear while you are tapping. The spaces with tab and the non space between the commas are very important.

    Hit control + x
    write:yes
    Hit enter

    Reboot !!

    check if your share is mounted with:

    cd /mnt/share
    ls

    edit: I allmost forgot: I do not recommend that you copy/paste the above code …

    • This reply was modified 5 months, 2 weeks ago by  Cassio299.
    10. Januar 2019 at 6:21 #43358

    Ok brilliant. Just adjusting my path to my music files now. This Nano editor is killing me…:( first time I seen it.

    10. Januar 2019 at 7:12 #43360

    [SOLVED] thanks for your help and comments. Now its working. The fstab file was messed up and also I didnt have the file path correct for my samba share.
    //192.168.1.254/samba/Western_Digital-10583032_usb1_1/Music

    • This reply was modified 5 months, 2 weeks ago by  Weka_1.
    10. Januar 2019 at 7:24 #43362

    Great….. you have already learnt a lot…

    Setting a share
    check if it is mounted
    and a fix if it isn’t

    have fun with you media player and server

    15. Januar 2019 at 13:24 #43650

    Great thread! Thanks again so much to Cassio for the expert help 🙂

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.

Register here