RPI3+Hifiberry Amp+ and M2P

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI RPI3+Hifiberry Amp+ and M2P

This topic contains 5 replies, has 2 voices, and was last updated by  vincentpearleyes 1 month, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 18. October 2016 at 21:50 #23442

    Hi folks,

    I am trying to setup an squeezebox multiroom audio and am unable to make
    the client working.
    The Squeezebox server is a simple rpi3, connected to Ethernet with
    internet access and mounting my NAS.
    The clients are squeezelite on Rpi3, hifiberry amp+. It is wifi connected
    (WPA, fix IP address, configured from CLI). I have also subscribed to the premium license, and
    it appears green !

    All installation is OK, and correct parameter selected in the different
    tabs : amp+ in hifiberry tab, raspberry settings tab, and in the advanced setting for the audio
    player. Only one audio player is selected.

    According to different blogs and forum, it should be proposed as possible
    audio output: Hifiberry amp+ in the list with Force HDMI and Force headphones jack (Set Audio Output on Raspberry PI). This
    is not the case. And it is worth saying that no sound is going out of the
    client (wiring is ok).

    From a squeezebox point of view, it is OK, I can see the client from the
    SQB web interface and send music.

    After browsing the internet, I put this parameter in /boot/config.txt :
    dtoverlay = rpi3-disable-bt, without more success.

    The M2P version is 2.37.
    Any help or suggestion is welcome. Thank you in advance.
    –V

    19. October 2016 at 13:25 #23450

    Hi vincent,
    In your Squeezelite under “edit Advanced Options”, what parameter is selected at the “Soundcard” dropdown menu?

    19. October 2016 at 19:50 #23459

    Hi Heiner,

    Thank you for answering.
    I selected the “sysdefault- snd_rpi_hifiberry_amp …”

    Cheers.
    –V

    20. October 2016 at 15:55 #23482

    That should be correct and you should have a sound output. The sound output option in the Raspberry Settings (Force HDMI, etc.) is only for those options, HDMI and audio jack, it does not interfere with the Amp+.
    What power supply are you using and have you tested different passive speakers?

    20. October 2016 at 16:09 #23483

    I am using 2 speekers from a mini stereo, and did not try others, at least one of them would work.
    The PS is a 2a 12V PS, originally used for a disk drive, I also have a more powerfull one to test.

    I will make some more tests this evening (not at home right now) :

    • Test other speakers”
    • test the other outputs (HDMI and Jack)
    • Test another couple of RPI3-Hifiberry amp+
    • Test with CLI command aplay

    Are there further checks I can do or log or config information I can provide ?

    Thanks.
    –V

    28. October 2016 at 13:28 #23601

    Hello,

    I finally managed to have everything working.
    Several tests were made without success.

    I installed again everything from scratch, and changed the speakers.

    I guess there was something wrong with the previous installation, and definetely those speakers are not suitable for the Amp+ (goog guess Heiner).

    Cheers.
    –V

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here