Rpi3 + Hifiberry Digi+ = No Sound from Toslink

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Rpi3 + Hifiberry Digi+ = No Sound from Toslink

This topic contains 9 replies, has 5 voices, and was last updated by  gand 1 month, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 24. September 2016 at 7:43 #23177

    What’s the correct way to get M2P working with Hifiberry Digi+’s Toslink audio output?

    I just did a clean install of the Hifiberry M2P image.
    I’m using the Rpi as a Squeezebox replacement.
    I have my LMS on another machine on my network.
    I’m using iPeng as the remote control.
    I’m using Squeezelite on M2P as the player (not sure if I should be?)

    Here’s the problem: I can access all of my files just fine, but I only get sound from the Pi’s 3.5mm headphone jack–no sound output at all from the Toslink output from the Hifiberry Digi+. I also can’t tell if the Hifiberry is receiving any audio–I only see one green light on the Digi’s board.

    My guess is I have not installed the Hifiberry Digi+ correctly or that I do not have the output configured properly in M2P. For example, Squeezelite does not work on its default setting (equal – equal), so I’m randomly choosing one of the other soundcard settings to get it to start. It does start if I choose plugequal, but that’s probably wrong. I’m referring to this menu:

    https://i.gyazo.com/2a07e928610ded505b556899faed1e4d.png

    Thanks very much for any help!

    24. September 2016 at 18:23 #23180

    Also, if I try to activate Squeezelite with the default soundcard setting (equal – equal), I get this error:

    https://i.gyazo.com/26fa0616d4d2801c2731032395038900.png

    or sometimes this error (device not found)

    https://i.gyazo.com/9f068cc1735a49c3ea6a4519ba50a7f2.png

    Thanks for any help!

    • This reply was modified 2 months, 1 week ago by  Justink.
    28. September 2016 at 2:34 #23229

    I have a similar problem with a digi+ headphone socket output.
    New Pi3 + HifiBerry Digi+ (jack socket version)
    Clean install of latest Max2Play
    No sound at all from Digi+ output – only from Pi’s own headphone socket.

    I’ve tried all the suggestions – disabled the Pi’s own output, disabled bluetooth, activated the USB soundcard in audioplayer advanced settings, rebooted several times – nothing.

    And now even worse Squeezelight won’t start – error message:
    “Trying to launch … NOT successful Click here to show detailed information
    squeezelite: pcm_params.c:170: snd1_pcm_hw_param_get_min: Assertion `!snd_interval_empty(i)’ failed.”

    Any help out there please would be appreciated.

    Thanks

    PS
    I’ve mounted the HifiBerry using nylon spacers rather than metal ones. I hope all the conncections between Pi and HifiBerry are via the header pins and metal spacers are not required for a ground connection!
    Also the HifiBerry worked OK when it was in a Pi2, just not in my shiny new Pi3 🙁

    • This reply was modified 2 months ago by  TJH.
    • This reply was modified 2 months ago by  TJH.
    • This reply was modified 2 months ago by  TJH.
    28. September 2016 at 2:58 #23233

    I’ve just set “Soundcard = sysdefault-snd_hifiberry_dacplus…” in Squeezelight advanced settings (it was equal-equal)
    SUCCESS
    Not only does Squeezelight start, but there is great sound coming from the HifiBerry digi+

    I have no idea why or how or what it all means.

    Justink – Why not try this too and see if it works for you? Good luck.

    (I can go to sleep late but happy)

    28. September 2016 at 14:36 #23237

    Thanks for the update TGH, I will give this a try too!

    29. September 2016 at 17:00 #23259

    I’ve found there is a bug in latest max2play with squeezelite output device settings.

    1) I’ve installed max2play image with 7″ for 7″ display
    2) default device was set to alsa
    3) I’ve set Hifiberry Digi/Digi+ as soundcard output from Raspberry Settings
    4) max2play only adds dtoverlay=hifiberry-digi to /boot/config.txt but /opt/max2play/audioplayer.conf was not changed. Once I disabled Disable Build-In-Audio on RPI3 from max2play setting menu (which actually adds dtparam=audio=off to /boot/config.txt) squeezelite didn’t start at all as it was trying to use nonexistant sound device.

    This is bug and should be fixed. Is there any common bugzilla where to search and file new bugs ? I have plenty of problems with max2play and using forum to report these problems seems pretty crazy to me.

    Thank you
    Tomas

    12. October 2016 at 11:16 #23381

    Hello shamot,

    Thanks for your advice! You are right with this bug which you have found.
    We are working to solve this and in the next version it will be fixed.

    Thank you very much.

    Additionally thank you TJH for solve Justinks problem.

    Best Regards.

    21. October 2016 at 9:02 #23492

    Hi

    I have the same problem. Is there a work around in the meantime?

    Thanks

    Rgds
    Gert

    21. October 2016 at 16:11 #23517

    @gand, have you tried this (TJH’s workaround above)?

    “I’ve just set “Soundcard = sysdefault-snd_hifiberry_dacplus…” in Squeezelight advanced settings (it was equal-equal)
    SUCCESS”

    My workaround was to give up on the Digi+ and get the Hifiberry Dac Pro instead. RCA outs worked from that right away and everything has been working great ever since. I realize that’s not really a workaround but a capitulation strategy.

    Good luck!

    21. October 2016 at 23:39 #23520

    Hi
    @Justink, thanks for your prompt answer/help.

    For now I downgraded to Version 2.35 and that solved my problem. I can now choose the Raspbery Digi+ card. I already have a DAC and just want a coax connection into the DAC.

    Hopefully this will be solved in the next version.

    Rgds
    Gert

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here