RPi 3B+, Hifiberry AMP2 , Adafruit 3.5" – Display doesn't work

Max2Play Home 2016 (en) Forums Max2Play Add-ons RPi 3B+, Hifiberry AMP2 , Adafruit 3.5" – Display doesn't work

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 19. Januar 2019 at 23:19 #43886

    Hello,

    i found this post, but nevertheless, it didn’t help me:

    Plugin installation order

    As written, I have a Raspberry PI 3B+ as m2p-Client, next connected to the PI is the
    Hifiberry AMP2 and then next to the AMP i have attached a 3,5″ Adafruit PiTFT Touchscreen for Raspberry Pi with 2×20 Pin Connector „Entwicklerboard“–> This means, i have 3 boards connected to the 2×20 Pin Connector.
    https://www.reichelt.de/entwicklerboards-display-lcd-touch-3-5-480×320-pixel-rasp-pi-3-5td-2-p235535.html?&trstct=pos_8

    The necessary Plug-ins „JiveLite“ and „RPI Display“ are installed.
    The AMP2 ist working fine and so does m2p as a client. The multiroom-equipment works fine, but i don’t get the display running.
    The power supply is sufficient and the whole system is powered via the power input of the AMP2.
    When the player is switched off, the Adafruit display is white. As soon as music as playing, the display gets dark.

    Well, I have no idea abot the problem.
    1. Is it the 2×20 pin connector of the Adafruit display? Maybe this „Entwicklerboard“ doesn’t work finde with this configuration.
    I learned, that als 2×13 pin displays are available.
    2. I have no possibiliy in JiveLite to choose a 3,5″ display, though it is installed in „RPI Display“.
    3. I have no advanced setup options in „RPI Display“, though I tried to installthe 3,5″ display several times. BUT, when installing the 7″ inch Display, which I don’t have physically, I have the option to modify „Grundeinstellungen“….

    Edit: I cannot de-install the 7“ display. I get the following Report:
    „Display-bezogene Einstellungen entfernt
    rm: cannot remove ‚/usr/share/X11/xorg.conf.d/99-fbturbo.conf‘: No such file or directory rm: cannot remove ‚/etc/X11/xorg.conf.d/99-ads7846-cal.conf‘: No such file or directory“
    Afterwards, the adcanced options for the 7″ display are still available.

    It’s a bit mysterious for me and I can’t find a solution on the web.

    Thank you for your support!

    Philip

    22. Januar 2019 at 14:40 #44008

    Hi Philip,

    Try using a new image and avoiding the 7 inch option.

    We recommend using only one add-on board per Raspberry Pi as the GPIO pins for these often overlap and can cause issues.
    You can check with the documentation of the manufacturer whether is the case with your setup.

    22. Januar 2019 at 15:41 #44019

    Hello Heiner,

    thank you for your answer.
    I have allready tried several new images, as it is the only way to remove a display setup –> no improvement.

    Is there experience at max2play, that 2 add-on boards won’t work fine, one of it the Adafruit 3,5″ display? Or is it maybe the 2×20 GPIO pin board, and the 2x13GPIO pin board might work?
    Is there any other known solution, to have 2 add-on-borards working, e. g. another display.?

    What is the safest way? Should I go to a display which uses the HDMI-connector of the Pi? –> honestly said ,there are also some nice displays available, especially 5″.
    I also have another topic running concerning support of max2play for a 5″ display. –> Do you have an alternative, that this might work?

    Thank you and regards,

    Philip

    23. Januar 2019 at 12:51 #44064

    Hi Philip,

    As mentioned, two different boards often have overlapping pin usage which makes them both inoperable. We therefore recommend using only one extension board per each Raspberry Pi.
    HDMI displays will work, there won’t be any touch control with them, though.

    There is currently no 5″ solution for Max2Play, however, you can try installing the drivers manually.

    23. Januar 2019 at 13:15 #44068

    Hallo Heiner,

    thank you, I understand.

    So the only ‚easy‘ way to have a touch display on a Pi with a Hifiberry Amo is the 7″ Raspberry Touch Display.
    This one has it’s own connector and doesn’t interfere with GPIO.

    Some guys obvioulsy got a 5″ Touch Display running witg max2play, which i think is a great compromise between sizes and usability. Nevertheless, all these workarounds sound quite complicated to me.

    Cheers,

    Philip

    23. Januar 2019 at 14:57 #44085

    Yes, unfortunately there are currently no other displays that can use the Pi-specific display connection as far as we know.

    There are workarounds but they usually have to compromise in other areas and can indeed become very complicated.

    If you don’t need touch functionality, an HDMI screen is a good alternative though.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here