Remote Control Addon Beta

Max2Play Home 2016 (en) Forums Max2Play Add-ons Remote Control Addon Beta

This topic contains 13 replies, has 7 voices, and was last updated by  Heiner Moderator 1 month, 1 week ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • 27. July 2016 at 12:28 #21880

    This topic is all about the new Addon Remote Control.

    6. August 2016 at 17:31 #22066

    For me it just won’t install. I’ve tried several times

    8. August 2016 at 12:17 #22076

    What does the Plugin page say after you installed? Does it show “ShellInABox is installed” and a window below saying “connection is not secure”, or does it only show the “install” button? You may also Update Max2Play to the latest beta on the settings page and try again.

    10. August 2016 at 20:52 #22169

    Hi Flysurfer,
    Wanted to give this a try but am having a problem. After clicking install I got an error message install not successful but then it told me Shell In A Box is installed. I see ‘open console full screen’ and a large rectangle. If I click in the rectangle nothing happens. If I click on ‘console full screen’ a 2nd window opens with a certificate error, click on continue to website then page can’t be displayed. I am running this on max2play 2.34
    Thanks

    11. August 2016 at 11:03 #22181

    Hi Cyn,

    could you try to update to latest Beta on Settings tab of Web interface or install the Beta of the Plugin with the Link http://shop.max2play.com/media/downloadable/beta/remotecontrol.tar

    This will offer some more details on the page. After updating you can check if ShellinaBox is running at the bottom – just click on DEBUG.

    It should look similar to this:
    Max2Play Remote Control SSH

    If it doesnt show any process running, please try to uninstall and reinstall ShellinaBox.

    Stefan

    11. August 2016 at 18:18 #22210

    Nice addon, will for sure be usefull.
    Just a few things:
    The installation (normal, not the beta) would not update the website, after the click on “Install ShellInABox”.
    It just ends up looking like this:

    After reloading the page manually, it’s installed. (Worked on one of my two raspberrys at the first try, for the second one, i had to click “Install ShellInABox” again)

    Once it’s installed, i had to open the console in fullscreen to get the button to add an exception. In the small box, the button won’t show up. After adding the exception, it also works in the small box.

    It’s working fine so far, i just noticed a small bug: Certain keys won’t work. For example the minus key left of r-shift.

    Just some info about my 2 systems:
    Testet in Firefox 48.0
    2 x Raspberry Pi 3, Max2Play 2.34 (non beta)
    Both with the latest kernel and packages: “Linux max2play 4.4.16-v7+ #899 SMP Thu Jul 28 12:40:33 BST 2016 armv7l GNU/Linux” (Updated both from the “Raspberry Settings” page.)

    • This reply was modified 1 year, 4 months ago by  Drakexz.
    • This reply was modified 1 year, 4 months ago by  Drakexz.
    11. August 2016 at 18:21 #22213

    Thanks for the quick reply. I installed the beta version of max2play and do see processes running in the debug window. However in the box window I don’t see the “max2play login:” that your example displays.

    Could you explain this statement a bit further “Make sure to open console in fullscreen mode after installation to create a SSL-security exception for your browser. This fixes the unsigned SSL-certificate error.”

    I am opening it in full screen and clicking on both close and continue. I am using IE11 & Windows 10. Is there something else I am suppose to do?
    Thanks

    11. August 2016 at 18:31 #22215

    Try a different browser, the IE won’t work for me either.
    Firefox (48.0 64-bit) and Chrome (52.0.2743.116 m 64-bit) do work.

    11. August 2016 at 18:37 #22216

    I was just gonna report back that I tried Chrome & it worked. Thanks for your comment.

    30. December 2016 at 17:17 #25324

    I tried this out and, although it worked as advertised, my firewall blocked all internet traffic from my Max2Play machine. I’m going back to Putty.

    2. November 2017 at 20:16 #32264

    Hi,
    I am new to the Max2Play experience, and I enjoy it so far.

    However, I would be curious to know if anybody has been able to install ShellInABox recently. The Remote Control plugin was added successfully to my M2P Web Interface, and when I push the “Install ShellInABox” button, the installation seems to run smoothly and report success; but when I hit the refresh page button, as suggested, it keeps showing the “Install SheelInABox” button (instead of the expected “ShellInABox is installed”) and the ssh-console window is not shown.
    I am running on Windows 10 Pro in Chrome (also tried Edge or IE Explorer); my board is RPi3, with a 7 inch touch screen, no extra audio card (yet). I have tried updating Max2Play (from the Settings/Reboot) page but it did not help. As suggested in one of the messages above, I also tried to “Force Update to latest Beta for Max2Play”, but that resulted in my system not being able to boot properly (I was suddenly asked for a password during booting, and Jive Lite would not start!); so, I ended up reinstalling MAx2Play from scratch. I also searched the forum, but could not find any hint on this topic (except this thread).
    Any suggestions?
    Thanks.

    3. November 2017 at 12:17 #32269

    Hi Jazzfood,

    I just tested it on a RPi3 and the install went through okay. You should get the blue text ShellInABox is installed.

    The normal issue one runs into with shellinabox is that it gets blocked by the browser. But still the “installed” indicator should be visible after the first installation attempt.

    Do you have the button “Open Console Fullscreen”?

    3. November 2017 at 13:06 #32272

    Hi Heiner,
    No I didn’t have the “Open Console Fullscreen” button. After the installation, I still had the “Install SheelInABox” button, as if nothing had been installed. I started Putty and ran dpkg –get-selections | grep “shellinabox” and it returned nothing. So I guess it did not install…

    EDIT 1:
    In the meantime, I ran Putty and installed libnet-ssleay-perl and libio-socket-ssl-perl (in order to be able to watch some https podcasts on the LMS) and after that, it seems I was able to get the Remote Control to work!! I am sure the installation of the 2 SSL packages is unrelated to my original issue, but I thought I should share it with you in case it helps understanding the original issue.

    EDIT 2:
    FYI, I had to install the Logitech Media Server (LMS) several times before I could get it to start. I am wondering if this could have messed up some packages in my system, which would then prevent the Remote-Control from installing properly. Installing the 2 SSL packages later cleaned up the system, which is why the Remote Control is now able to install… Just a theory (trying to help in case others are running into the same issue)…

    Anyways, it works now.

    • This reply was modified 1 month, 2 weeks ago by  Jazzfood. Reason: I just tried again after installing some SSL packages and it now seems to work
    • This reply was modified 1 month, 2 weeks ago by  Jazzfood. Reason: Edit 2: I just thought of an issue I had during the LMS installation and I am wondering if this could be the reason for the Remote-Control installation fail
    6. November 2017 at 12:08 #32303

    Hi Jazzfood,

    Thanks for the detailed follow-up. I am glad you got it to work, however as mentioned it should work after just one click on the installation button. We will try to investigate further based on your results, whether this issue is reproducable. Thanks for your help.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Register here