RasPi nach einiger Zeit nicht mehr erreichbar

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI RasPi nach einiger Zeit nicht mehr erreichbar

This topic contains 8 replies, has 3 voices, and was last updated by  Heiner Moderator 7 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 16. Januar 2018 at 19:06 #33485

    Hallo liebes Forum,

    mein RasPi ist gerade neu, ich bin selber auch neu in der Materie, darum recht hilflos bei meinem aktuellen Problem.

    Max2Play ist eingerichtet, Kodi ebenfalls, genau so wie die Hifiberry Digi. Nach dem Booten erreiche ich die Max2play-Oberfläche über die IP oder http://max2play, ebenso wie das Kodi-Webinterface. Wenn der RasPi aber einige Zeit läuft (einige Stunden) bekomme ich keinen Online-Zugang mehr.

    Der Router zeigt mir die IP noch an, pingbar ist die Maschine allerdings nicht mehr. Der RasPi läuft allerdings noch problemlos, über eine angeschlossene Tastatur kann ich ihn steuern, er spielt Videos (youtube) ab, ist offensichtlich online.

    Habt ihr eine Idee, woran das liegen kann? Ich habe keine Ahnung, was hier vorliegen könnte und wie ich das Thema abstellen kann.

    Besten Dank schon mal!
    CaiPi

    17. Januar 2018 at 22:56 #33508

    Moin Moin,

    direkt eine Lösung habe ich auch nicht – bin auch kein PI/Linux Profi – aber hast Du schonmal versucht das Problem einzugrenzen? Z.B.:
    Wie hängt der PI im Netz? Über WLAN oder über LAN? Falls über WLAN dann mal direkt mit einem Kabel an den Router hängen und beobachten (oder eben anders herum…bleibt der Fehler?)…

    Und – Sind alle Pakete auf dem neuesten Stand? Vielleicht auch mal über ne Konsole/Terminal entsprechende Updates fahren…

    Was für ein PI/Modell?

    Gruß,

    Matthias

    • This reply was modified 8 months ago by  lemuba.
    • This reply was modified 8 months ago by  lemuba.
    19. Januar 2018 at 17:55 #33555

    Hallo Namensvetter,

    der RasPi ist ein aktuelles Modell 3b, die Pakete habe ich beim einrichten, also vor ca 2 Wochen, per „apt-get update apt-get upgrade“ auf den aktuellen Stand gebracht. Online ist der Kleine per WLAN, ich probiere nochmal LAN aus, gute Idee, wobei es auch nicht die Endlösung sein kann, weil ich dann meinem IP-TV das Kabel klauen muss 🙂

    Ich tippe eh auf eine Software-Problematik, da Kodi ja z.B. immer noch Youtube-Videos abspielen kann, ich aber beide Web-Interfaces (kodi / max2play) weder über den Hostnamen, noch über die IP erreiche. Auch ein Ping kommt nicht durch, obwohl der offenbar RasPi online ist. Ich tippe auf etwas in Richtung Apache o.ä., ich hab nur keinen Schimmer, wie ich das administrieren kann!

    Nebenbei: Kann ich irgendwie mit einer angeschlossenen Tastatur / Maus aus Kodi heraus auf den Desktop wechseln bzw. eine Konsole öffnen? Im aktuellen Zustand kann ich den Kleinen nur neustarten, indem ich hart den Stecker ziehe.

    Beste Grüße aus dem Norden!

    20. Januar 2018 at 3:30 #33558

    Moin Moin,

    um Deinem IP-TV nicht das kabel klauen zu müssen hätte ich da noch eine andere Lösung – Klick 🙂

    Wenn Du beim Kleinen den Stecker regelmäßig hart ziehst, ist es nur ne Frage der Zeit bis Du Dateien schießt, bzw. er gar nicht mehr hoch kommt… Vielleicht hast Du Dir damit auch schon das Problem eingehandelt…? Dann mal ein von Grund auf ein neues Image auf die SD ziehen.

    Du kannst Ihn doch auch über jeden externen Webbrowser (M2P Webinterface) oder Terminal/ssh runterfahren, wie auch vom Tablet, etc…
    Kodi habe ich bei mir nicht drauf und kann Dir somit leider nicht sagen wie Du ihn in Deiner Konfig über ne angeschlossene Tastatur runterfahren kannst.

    • This reply was modified 8 months ago by  lemuba.
    20. Januar 2018 at 14:44 #33561

    Hey 🙂

    mir ist schon bewusst, dass Steckerziehen keine Lösung ist. Darum läuft er im Moment sowieso und später auch geplant durch. Ich kann halt nur aktuell keinen anderen Reset machen, weil ich ihn eben gerade nicht fernbedienen kann und auch keine Konsole bzw. keinen Desktop zum Laufen bekomme. Genau das ist ja mein Problem 😀

    Und ja, ein Switch wäre eine Idee, ich hab nur keinen da und schaffe mir jetzt keinen an, nur um raus zu bekommen, ob ich ein WLAN-Problem habe.

    Meine Hoffnung ist ja noch, dass mir jemand mit dem vermuteten Software-Problem weiterhelfen kann. Den LAN-Test mache ich aber demnächst und berichte dann!

    Gruß aus dem Norden!

    22. Januar 2018 at 15:06 #33592

    Hi CaiPi,

    Zu 99 Prozent handelt es sich um ein Router/WLAN-Problem. Falls noch nicht geschehen, betreibe den Pi bitte einmal direkt neben dem WLAN-Empfänger deines Routers um ein simples Empfangsproblem auschließen zu können.

    Bezüglich Desktop, wenn bei Kodi der autostart deaktiviert ist sollte automatisch ein Desktop kommen nach dem Hochfahren. Du kannst zudem Iceweasel (Firefox-Browser) in den Raspberry Settings installieren.

    25. Januar 2018 at 22:04 #33654

    Hallo Heiner,

    schon mal herzlichen Dank für dein Feedback. Der Pi steht in Sichtweite des Routers, im selben Raum, keine 3m Luftlinie entfernt.

    Ich hab jetzt übrigens bemerkt, dass das WLAN sofort wieder aktiv ist, wenn ich einen LAN-Stecker einstecke. In dem Moment erreiche ich den Pi auf beiden IPs (also WLAN und LAN) und WLAN bleibt erstmal stabil, auch wenn ich nach 10 sec den LAN-Stecker wieder abziehe. Immerhin muss ich ihn so nicht per Stromversorgung abschalten, muss aber hinter meine 5.1-Anlage kriechen 🙂

    Im Router sehe ich den Pi übrigens dauerhaft mit seiner IP, auch wenn ich ihn nicht erreichen kann (mit Notebook und Handy probiert, an denen kann’s auch nicht liegen). Falls das interessant sein sollte, ist das eine Vodafone Easybox 904 xDSL. Ich hab hier noch einen WLAN-Repeater rumfliegen, den ich jetzt mal anschmeiße, damit könnten wir den Router dann auch ausschließen. Melde mich, wenn ich weiß, ob’s damit besser klappt.

    Grüße aus Kiel!

    • This reply was modified 7 months, 4 weeks ago by  CaiPi.
    29. Januar 2018 at 22:28 #33743

    Hallo zusammen,

    es scheint wirklich am Router gelegen zu haben. Ich hab den RasPi jetzt am WLAN-Repeater hängen und erreiche ihn schon lockere 48h immer, wenn ich teste.

    Herzlichen Dank für den Tipp!

    Eine Frage noch, die allerdings eigentlich überhaupt nichts mit dem Thema des Threads zu tun hat:

    Kodi ist bei mir auf Autostart gestellt. Wenn ich es jetzt allerdings beende, geht der TV von allein aus (ok, CEC Auto-Standby, schon klar), es startet nur leider kein Desktop. Meine einzige Möglichkeit, besteht darin, den Autostart von Kodi abzuschalten und den RasPi zu rebooten. Ist das wirklich die einzige Option, auf dem Pi einen Desktop zu starten? Kann ich anders nicht zwischen Kodi und Desktop hin und her wechseln?

    Danke schon mal!

    Gruß aus Kiel!

    30. Januar 2018 at 16:46 #33759

    Hi CaiPi,

    Max2Play ist eigentlich komplett ohne Desktop-Ausgabe konzipiert als kopfloses System. Auf Anfrage haben wir einen rudimentären Desktop und eine Browser-Installation angefügt, diese ist jedoch nicht wirklich eine Kompetenz von uns. Die Ausgabe wird eigentlich nur von Jivelite und Kodi genutzt.
    Du kannst noch die Option „Disable Screen Sleep on Desktop“ aktivieren (Raspberry Settings), aber ich weiß jetzt nicht auf Anhieb ob dies auch beim Wechsel von Kodi hilft.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here