Raspberry Zero W [SUPPORTED]

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Raspberry Zero W [SUPPORTED]

This topic contains 19 replies, has 10 voices, and was last updated by  crahlfs 1 month, 2 weeks ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • 10. March 2017 at 1:29 #27541

    The new Raspberry Pi Zero W is currently not supported out of the box when installing the 2.41 autoexpand image of max2play.
    To use builtin Wifi and Bluetooth an update of the PIs Firmware is needed. Unfortunatly the Zero W has no ethernet port.
    I have done these to get the image including wifi working:

    1. Write Image 2.41 to SD Card
    2. Boot this Card in an Raspberry PI 3 (do not connect the Ethernet cable!)
    3. After some minutes connect the PIs Wifi using the WPS Feature of your Router
    4. Do a SSH Login and update the Firmware with “sudo rpi-update”
    5. Shutdown the PI 3 and take out the SD Card
    6. Boot the PI Zero W with the Card and the WIFI should connect automatically

    The internal Bluetooth is working too, but it seems that the pulseaudio Server does not recognize the Zero W as a genuine Raspberry so that squeezelite won’t start. After i do a “sudo apt-get update” and “sudo apt-get upgrade” pulseaudio is working too.

    • This topic was modified 5 months, 1 week ago by  anesthesia.
    • This topic was modified 1 month, 3 weeks ago by  Heiner.
    10. March 2017 at 22:02 #27569

    Thanks for the info. Unfortunately i dont have a PI 3, is there an other way?

    11. March 2017 at 15:36 #27578

    Hi,
    has anyone tried to run the Raspberry Pi Zero W with Max2Play AND the pHAT BEAT from pimoroni?
    This would be my favourite combination to put inside a wooden loudspeaker box (or two for stereo 🙂 )
    (I’ve got a Raspberry Pi Zero W working with the pHAT BEAT in a funny “Pirate Radio”…)
    Now I’ve installed Max2Play on another SD-card the Zero W and afterwards installed the pHAT BEAT script (with “all pre-requisites and get your pHAT BEAT up and running”).
    After that I cannot start Squeezeplay in Max2Play and I cannot change the audio-output to the pHAT BEAT 🙁

    pHAT BEAT
    https://github.com/pimoroni/phat-beat

    Florian

    12. March 2017 at 23:32 #27610

    @anesthesia: Thanks a lot for your description – followed your steps and it works great!

    @floppybox: I use a raspberry pi Zero w with a JustBoom Amp Zero pHAT together with a pair of magnat needle boxes – works great!
    …i also use a hifiberry amp+ which naturally has more power also the above is more than enough for a “Standard room”.

    13. March 2017 at 13:08 #27648

    @anesthesia

    Thank you for sharing these information, we are working on updating the raspberry pi firmware on our new image.

    @floppybox

    Sorry we could not help you with that, since we do not provide technical support for pHAT BEAT at the moment.

    Best Regards,
    Mohammad Mbydeen

    14. March 2017 at 13:30 #27711

    @Cadster:

    Maybe there is another way to get the internal wifi running for those who don’t have another raspi (but it doesn’t worked for me):
    Copy Startup Files

    • This reply was modified 5 months ago by  anesthesia.
    15. March 2017 at 15:40 #27759

    @anesthesia

    Thanks for the tip, it worked for me!
    wlan0 was recognized after the replacement of bootcode.bin/fixup.dat/start.elf
    I had to edit /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf.

    Thanks again!

    18. March 2017 at 16:09 #27789

    @anesthesia

    I did it with a usb lan device. After updating the firmware my wifi worked.

    20. March 2017 at 14:42 #27807

    Dear all,

    Please note that we are working on updating our Max2Play firmware to support the built-in wireless for the new Raspberry Pi zero.

    Regards,
    Mohammad Mbydeen

    14. April 2017 at 15:03 #28251

    Thanks Anesthesia
    One question tho, why the firmware update on the 3?

    14. April 2017 at 15:05 #28252

    @Mbydeen
    Is there a way of configuring the pi zero w wifi connection with the sudo nano /etc/wpa_supplicant/wpa_supplicant.conf??

    14. April 2017 at 15:54 #28253

    Hi, the pi zero does not have ethernet onboard. If you have a compatible wifi stick or usb ethernet adapter this could work too. You need internet connection to do the firmware upgrade.

    14. April 2017 at 16:19 #28255

    @anesthesia
    Thanks! I used your method and it worked like a charm.
    I’m was asking about modifying wpa_supplicat.conf to see if there is a method to connect the zero w to wifi without using WPS.

    14. April 2017 at 18:39 #28257

    After the kernel upgrade it might work but not before because then internal wifi isnt recognized. So it can’t connect to any wifi with or without wps. The other method is to replace the bootfiles and the edit the wifi config. Like Mohammad wrote eill this be obsolete when a new image of max2play is out that works with the new firmware out of the box.

    3. May 2017 at 19:09 #28678

    Is there a ETA for the update? I’m waiting since day 1 and really want to use the zero w.

    30. May 2017 at 12:50 #29118

    Hi guys,
    Sorry to keep you waiting so long. We finally have some Zero W’s in house and are testing and working hard to make them fully compatible. I’ll update this thread when there’s news but will also probably publish a blog article with more details when everything’s settled.

    For now, huge thanks to anesthesia for getting creative and sharing the workaround. 🙂

    7. June 2017 at 12:28 #29331

    Hi everyone,

    The new version of Max2Play is ready for download and can also be updated to on any existing system. It includes a fix for the Zero W to work flawlessly amongst other things.

    When connecting your Zero W via WPS with a freshly burnt image, make sure to boot the Pi first and start the WPS search second. The Zero W takes a little more time to boot, expand the filesystem and connect via WPS. If you are not connected by the first WPS search of your router, please start a new scan and the Zero W should be detected.

    25. June 2017 at 0:46 #29708

    Hi Heiner, Thank you for adding the wps function. It was no Problem to set up the new Zero W.
    But I do not get Bluetooth working:-( I already did an kernel Upgrade & Update. But nothing changed: hciconfig always tells me “default controller available”. Could you check it on one of your Zero W?
    I would like to use BLE tags to recognize if I´m at home or not.

    Regards Christoph

    28. June 2017 at 15:17 #29746

    Hi Christoph,

    Have you checked our Bluetooth plugin yet to see what the output is there (if search for BT devices)?

    2. July 2017 at 10:12 #29775

    @Heiner The Plugin works fine for Raspbery Zero W !!! Thank you

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

Register here