Raspberry PI won't boot after SD-Card Write Protection enabled

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Raspberry PI won't boot after SD-Card Write Protection enabled

This topic contains 6 replies, has 3 voices, and was last updated by  Heiner Moderator 7 months, 4 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 6. Dezember 2017 at 6:23 #32803

    Hello, here is my configuration:

    Raspberry pi 3
    Hifiberry DAC+ standard
    max2play 2.45
    16GB SD card
    static LAN address
    no WIFI (disabled completely)
    running headless (no display, no keyboard, no VNC, no X11, etc)

    active plugins:
    – audioplayer
    – hifiberry
    – settings/reboot
    – wifi/lan
    – raspberry settings
    – SD-Card Protection

    I’m using it as an audio player only. LMS (Logitech Media Server) is installed on another computer on my network. I have no need or intention to install LMS on my Raspberry PI.

    All works well, *until* I enable SD-Card Protection. After I click the REBOOT button on max2play, the PI goes offline, and won’t boot again. Or at least, I can’t access it over the network, so it’s functionally down.

    While running, nmap gives this result:

    PORT     STATE SERVICE
    22/tcp   open  ssh
    53/tcp   open  domain
    80/tcp   open  http
    139/tcp  open  netbios-ssn
    445/tcp  open  microsoft-ds
    3389/tcp open  ms-term-serv
    

    After the reboot, nmap gives this result:

    Note: Host seems down. If it is really up, but blocking our ping probes, try -PN
    Nmap done: 1 IP address (0 hosts up) scanned in 5.26 seconds
    

    I have a static IP address assigned to the PI, and am not using DHCP or wireless at all.

    I would like to enable write protection, as the planned usage for the device is in a location where power is not always reliable. However, at the moment, it appears that write protection does not work at all for me.

    6. Dezember 2017 at 17:09 #32808

    I have a similar problem here – wifi and bluetooth disabled and the RPi is not present in LAN after booting. Sometimes powering off and on several times helps…

    What i figured out and seems to be a solution for the moment in my situation:
    Disabling the fix ip adress within the RPi’s webinterface and forcing the router to assign always the same ip adress to the RPi while handling DHCP. I use a fritzbox router and changing this setting is very easy.

    Regards,
    Stefan

    6. Dezember 2017 at 17:20 #32810

    Additionally:

    I have 3 RPI’s with Max2Play running here – all of them have the sd card protection activated. Two of them don’t have any problem after rebooting and are still reachable in the network (both with jivelite running, TFT attached and with fixed ip adress in the network tab), but the one without jivelite and TFT has the problem with the ip adress as described. Curios.

    6. Dezember 2017 at 23:21 #32830

    Interesting.

    I set up a DHCP server on my local network, and disabled the fixed LAN address on my rasp pi.

    After installing and enabling SD-Card Write Protection, the rasp pi is able to reboot and functions normally.

    This is an acceptable solution for now.

    The original issue is still open / unsolved: fixed LAN address + Write Protection = unbootable rasp pi.

    10. Dezember 2017 at 15:16 #32855

    Hi melissa,

    Sorry about the late response.

    I will try to recreate this issue in our offices and see if we can find a fix.

    18. Dezember 2017 at 12:30 #33008

    Hi guys,

    Sorry about the late response here. Please running the setup again with version 2.45 to see if the problem persists.

    18. Dezember 2017 at 12:30 #33009

    Hi guys,

    Sorry about the late response here. Please running the setup again with version 2.45 to see if the problem persists.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here