Raspberry Pi 7" official display problem

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Raspberry Pi 7" official display problem

This topic contains 6 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 14. März 2018 at 11:20 #34416

    Dear experts,

    Recently I also started building a HifiBerry setup using the Raspberry Pi 3B, HifiBerry Amp 2 and the official 7″ display running Max2Play.
    After doing all the updates and tweaks Kodi now runs fine. Im still having trouble making Bluetooth audio imput working but my biggest hurdle at the moment is to make the touchscreen work.

    I cannot find any subject about the official 7″ screen, but lots of subjects about people using their own 5″ screen.

    My problem is that whatever skin i use on Max2Play, the lower 20% of the screen has no touch and the touch is also off, the more i go down the more off it is… Im bad at commandline and there were some video’s about people calibrating their 5″ unofficial screen.
    A friend of my tested the screen on his regular raspbian setup and it worked 100% out of the box!!!!

    So, what could be the problem? I suppose it is with Max2Play? Does anybody have the same problem? And how can I fix this?
    I’m a premium member, so i hope this includes this support?!

    Thanks in advance!

    Kind regards,

    Joeri

    14. März 2018 at 17:33 #34424

    Hi joeri,

    The Joggler Skin for Jivelite is our official skin for 7 inch RPi touchscreen. It allows for a direct switch to Kodi.

    15. März 2018 at 2:20 #34433

    Dear Heiner,

    Thank you for your fast response.

    But ofcource I tried that. I tried All the skins!

    The problem is the touch… It will not use the lower 20% and the touch is off calibration in the parts where it does work. The unit was tested in the store also and they showed me it wasnt broken. They also said it was the max2play problem, not the pi or the display… Now i can only resonably use it with a mouse.

    What could it be? Is there a hardware revision? Is there a mandatory calibration? Can it be done in GUI?

    • This reply was modified 1 year, 3 months ago by  Dutch87.
    • This reply was modified 1 year, 3 months ago by  Dutch87.
    16. März 2018 at 12:22 #34476

    What options do you have selected in the RPi-Display Plugin? In our 7 inch touchscreen tester without this issue it’s only LCD as Default Display and Remove Cursor (e.g. mouse pointer). Also, please share the debug info of your RPi-Display Plugin and Jivelite Plugin.

    17. März 2018 at 17:33 #34500

    Dear Heiner,

    When I install the official Rasbian all is okay (just screen upside down, but thats okay)…

    On the page RPi-Display Touchscreen Setup
    Max2Plauy It notifies me in the webpage of: RPi Display is installed: 7″ Touchdisplay
    -Rotate display of Touchscreen Enabled
    -LCD as Default Display Enabled
    -Kodi Mouse 1-Click Enabled
    -Remove Cursor (e.g. mouse pointer) Disabled, I have to use the mouse due to the messed up touch, so i have that now disabled to hide it, but does not change anything.

    When I click Debug-Info it is empty…

    Also I updated Max2Play to the newest version
    Version 2.45
    Raspberry PI 3
    License Activated
    Also Kodi has been updated to 2:17.4-2~jessie
    Kodi only worked after updating Max2Play to this version.

    I also tried updating the plugins, deleting settings of display gives error
    Display related settings removed
    rm: cannot remove ‘/usr/share/X11/xorg.conf.d/99-fbturbo.conf’: No such file or directory rm: cannot remove ‘/etc/X11/xorg.conf.d/99-ads7846-cal.conf’: No such file or directory

    It’s just that I’m a total noob when it comes to Linux (commandline)…

    18. März 2018 at 20:58 #34512

    Dear Heiner,

    I solved it by reinstalling it 2 times. The first time the soundvolume was stuck of the HiFi Berry AMP 2.
    Now all seem to work okay. Just problems with the Bluetooth. I have to disable manually the squeezelight. Still there is lots of lagg so using Bluetooth for movies or games is still a no go compared to normal bluetooth headphones. Maybe some day it will happen. Using the squeezeboxserver for bluetooth creates buffers and over 5 seconds of lagg.

    Anyhow. Not sure how it happened, let’s hope it will stay okay (after future updates). Thanks for the support effort!

    20. März 2018 at 18:17 #34578

    Hi Dutch,

    Thanks for the update. We have a new Bluetooth Update coming out very soon.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here