Raspberry Pi 4: firmware update to fix temperature problems

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Raspberry Pi 4: firmware update to fix temperature problems

This topic contains 1 reply, has 2 voices, and was last updated by  MarioM Moderator 5 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 7. Mai 2020 at 9:50 #48725

    Hi,
    in the thread „[Announce] New Max2Play Image for Raspberry Pi 4“ there are many comments about not being able to update the firmware in Raspberry Pi 4 to lower the temperature (Pi 4 won’t work after reboot and requires burning new max2play image to SD).
    I think the problem here is that users reporting this were upgrading the Kernel and other important packages, hence breaking max2play.

    I just updated firmware to my Pi 4 and lowered temperature from 74ºC to 64ºC… and still running!
    To do so I followed the instructions from http://www.geeks3d.com/20191101/raspberry-pi-4-new-firmware-reduces-power-consumption-and-boards-temperatures/:
    $ sudo apt update
    $ sudo apt upgrade
    $ sudo apt install rpi-eeprom
    Now, run the following command to check the status of the bootloader + VL805 code:
    $ sudo rpi-eeprom-update
    And finally reboot

    Don’t run „apt dist-upgrade“ or „apt full-upgrade“ since they will upgrade important components like the kernel. I did not test using these options but from all the comments in the forum I guess this is the reason the Raspi 4 won’t boot.

    Note1: the first time I ran „sudo rpi-eeprom-update“ didn’t work. Just rebooted and tried again succesfully.
    Note2: I was running max2play 2.52 (had burnt max2play 2.50 image to SD, then updated online to 2.52)
    Note3: during „sudo apt upgrade“, samba and another packaged requested user input. I used default options.
    Regards

    12. Mai 2020 at 14:26 #48757

    Hi Tinet,

    Thank you for your advice. We also offer to update the kernels and packages with a simple push of a button in our Raspberry Settings pluign. However, we only recommend this if explicit new functions that come with the updates are needed, e.g. the temperature fixes.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here