[SOLVED] Raspberry Pi 3 + Allo Boss DAC

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Raspberry Pi 3 + Allo Boss DAC

This topic contains 26 replies, has 5 voices, and was last updated by  Heiner Moderator 1 month, 4 weeks ago.

Viewing 27 posts - 1 through 27 (of 27 total)
  • 16. April 2017 at 17:07 #28279

    I do not see Allo Boss DAC in Raspberry Settings page DACs/AMPs pull down menu.
    Please Help.

    • This topic was modified 11 months, 1 week ago by  juzio.
    • This topic was modified 10 months, 3 weeks ago by  Mbydeen.
    18. April 2017 at 11:08 #28314

    Hi juzio

    Please try to burn new image and start fresh installation, and make sure that you setup the card properly on the raspberry pi, otherwise it could be a hardware malfunction.

    Mohammad Mbydeen

    22. April 2017 at 17:10 #28409

    hi Mbydeen
    Burned new image, started fresh but Allo Boss DAC still not showing in Raspberry Pi Settings page. In that pull down menu I can see Allo Piano 2.0 and Piano 2.1 DAC’s but not Allo Boss DAC. Updated kernel and Max2Play but still no trace of Allo Boss in RPi settings page.


    23. April 2017 at 23:38 #28424

    I have exactly the same issue, I installed the Allo plugin, and have Allo boss selected. but squeezelite fails to start, saying no hardware found ?

    please help

    many thanks..

    24. April 2017 at 14:33 #28444

    @ juzio

    Please note that the Allo Boss DAC in Raspberry Settings page DACs/AMPs pull down menu is not available at the moment, you can change the settings from Allo plugin page. We are working to add it into the menu, sorry for any inconvenience.

    @ mrfunk

    It could be a hardware malfunction, please make sure that card in a good condition, and try to set it up on the Raspberry pi correctly.

    Best Regards,
    Mohammad Mbydeen

    24. April 2017 at 19:05 #28446

    We both have an identical issue. The card is new, and tested OK with volumio, by just changing the micro sd card.. So not a hardware issue…

    The order it was installed.

    I was originally using Iqaudio dac, this was removed, Allo boss installed and booted. Installed plug in, then custom kernel. Card is selected in the Allo plug in page. In the audioplayer setting page, the hardware line, doesn’t look correct, no mention of Allo boss. Screen shot to follow when I’m home tonight. Squeeze player fails to open saying no hardware found. I really welcome your help as max2play is just so freaking awesome! Thanks in anticipation


    24. April 2017 at 19:20 #28447

    Just noticed in manual that I should add “dtoverlay=allo-boss-pcm512x-audio” to config.txt? Surely the install does this for me, or is the action of the raspberry pi settings page causing the /boot/config.txt to be edited, hence the reboot? And with no option in the drop down, is this line being added? Will check tonight

    24. April 2017 at 23:02 #28452

    CLICK THIS LINK – this is piano dac
    CLICK THIS LINK – the is the boss DAC, note lack of options

    which file is edited to get text in this box?

    hope this makes sense?

    • This reply was modified 11 months ago by  mrfunk.
    • This reply was modified 11 months ago by  mrfunk.
    • This reply was modified 11 months ago by  mrfunk.
    • This reply was modified 11 months ago by  mrfunk.
    • This reply was modified 11 months ago by  mrfunk.
    25. April 2017 at 2:20 #28459

    I checked config.txt and line “dtoverlay=allo-boss-pcm512x-audio” is ther at the bottom of the file.

    25. April 2017 at 11:11 #28461

    Dear David,

    Thank you for your feedback about Max2Play.

    The Allo Boss card is new, but Max2Play is fully support this card, you dont have to edit any file to add the Boss option in the list. please check the image below:


    Please try to burn new image as I recommend you, or check whether the card has hardware malfunction.

    Best Regards,
    Mohammad Mbydeen

    25. April 2017 at 12:49 #28471

    Thanks for your response, appreciated!

    I do not have a pi3.. I’m using a pi2…. Is this “your” image or is it the one from the Allo site?

    Really want this to work, as I’ve heard good things about the boss..

    25. April 2017 at 15:04 #28481

    Hi mrfunk,

    This is our setup in our lab, we used Raspberry Pi 3.

    Mohammad Mbydeen

    25. April 2017 at 15:20 #28485

    Thanks, would this image work on a pi2?

    If not, would it be possible to make an image? I really appreciate your help btw

    26. April 2017 at 10:03 #28499

    Hi mrfunk,

    Yes, it works for Raspberry Pi 2 as well.

    Mohammad Mbydeen

    27. April 2017 at 13:44 #28594

    I was using the precompiled image for the rpi 7 inch screen, this is based on 2.38. Although I updated this, and installed the Allo plug in, it just refused to work.

    I’m now running the new 2.41 image and installed the rpi display plug in separately.. All working now. And sounds so amazing compared to the Iq dac

    Thanks for your good work, can’t believe I’ve wasted so many months playing with volumio etc.


    2. May 2017 at 13:43 #28663

    Hi David,

    We are happy that your problem has been solved, and we hope you are enjoying Max2Play 🙂

    Best Regards,
    Mohammad Mbydeen

    6. January 2018 at 2:45 #33268

    I have the same problem. I am on Max2play 2.44. I only have sound over HDMI except with the Squeezebox interface on PC, where the analog output of the Boss works. Any idea?

    6. January 2018 at 20:50 #33275

    Could it be related to the fact that the Boss Dac is listed as card #1 and ALSA is listed as card #0? In Kodi, I only see ALSA as audio output.

    • This reply was modified 2 months, 1 week ago by  chicoinm.
    8. January 2018 at 16:58 #33305

    Hi chiccoinm,

    You can deactivate the build-in audio in Raspberry Settings and need to do that if you are using Kodi for output.

    9. January 2018 at 1:39 #33314

    That did not help. I still Kodi audio output only through HDMI.

    11. January 2018 at 11:29 #33356

    Hi chicoinm,

    Sorry about the vague help, you have to check the settings of Kodi afterwards under audio to make sure the right audio output is selected.

    12. January 2018 at 5:21 #33367

    The choices I have for audio output in Kodi are:

    PI: HDMI
    PI: Analogue
    ALSA: Playback/recording…
    ALSA: PulseAudio Sound Server

    Should the Boss Dac be there?

    15. January 2018 at 12:59 #33433

    Hi chicoinm,

    Yes it should. Please try selecting “none” in the Allo Plugin, saving, rebooting, re-selecting BOSS DAC, saving and rebooting. Afterwards, please check again. Please also check the dropdown menu in Audio Player for Squeezelite. There should be another option than the ones you listed above.

    16. January 2018 at 17:45 #33483

    I did that, but nothing changed. Audio output from the Boss Dac works when using the Squeezebox server. But I only get HDMI audio output for Kodi or streaming from my laptop.

    I will try to reinstall Max2play completely. Is there a guide on how to do this correctly for the Boss Dac?

    17. January 2018 at 11:18 #33495

    Hi chicoinm,

    First of all sorry about the hassle, this should be much more comfortable with Max2Play.

    You can just burn a fresh image, access the web interface and select your sound card.

    Here’s our getting started guide: https://www.max2play.com/en/getting-started/

    18. January 2018 at 3:05 #33516

    Ok I got it working by installing the gmediarender server. Thanks for your help.

    22. January 2018 at 11:13 #33582

    Thank you for the follow-up 🙂

Viewing 27 posts - 1 through 27 (of 27 total)

You must be logged in to reply to this topic.

Register here