Raspberry image contains "odroid" username afer upgrade

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Raspberry image contains "odroid" username afer upgrade

This topic contains 5 replies, has 2 voices, and was last updated by  flysurfer premium 1 year, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 3. August 2015 at 15:51 #15261

    Hi!

    First of all: thank you for you work. Even though I do have few Rpis, it was very quick with this image to have Squeezebox & Shairplay working.
    I am definitelly going to support your work ­čÖé

    So I had 2 issues:
    1) I downloaded latest Raspberry image, run Rpi, upgraded to latest version. And after upgrade shairplay and squeezelite stopped working.

    I logged in directly and grep "odroid" /etc/init.d/* shown 2 entries in: USER=odroid
    /etc/init.d/shairport
    /etc/init.d/squeezelite

    I’ve manually updated it to USER=pi and rebooted and all is fine now.

    I downloaded this version:
    SPMAX2PLAY_RPI_212.img

    I’m currently on this kernel:
    [email protected] /etc/init.d $ uname -a
    Linux max2play 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux

    Tomasz

    3. August 2015 at 16:01 #15262

    Hi Tomasz,

    first: thanks a lot for your positive feedback!! Really appreciated!

    The scripts that come with Max2Play have a default setting for the odroid (if no USER is set) as this was the first device we supported. This default setting gets overrun at runtime by variables in the /opt/max2play/*.conf. This changes the user from odroid to “pi” in the scripts you mentioned. This line does the “magic”:
    USER=$(grep -a "SYSTEM_USER" /opt/max2play/audioplayer.conf | sed -n -e 's/^[A-Z_]*\=//p')

    If this does not happen correctly, it is really strange… you may have a look at the file “/opt/max2play/audioplayer.conf” and see why the variable SYSTEM_USER is not set.

    • This reply was modified 1 year, 4 months ago by  flysurfer.
    3. August 2015 at 17:00 #15271
    [email protected] ~ $ cat /opt/max2play/audioplayer.conf
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o plug:plugequal -a 80:::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=ALSA
    USE_USB_DAC=0
    USE_EQUALIZER=0
    

    You know… I remember, that I have clicked once this button: “Reset configs to Max2Play delivery configuration”
    Maybe this cleared it? I thought on fresh system it won’t do any damage.

    4. August 2015 at 9:42 #15272

    OK – that “Reset” seems be the reason and this is quite likely a bug! Thanks for investigating on this. I will fix this with the next update of Max2Play.

    4. August 2015 at 11:21 #15274

    Was there anything else removed by resetting? If so, I will reinstall.

    For sure “expend filesystem” didn’t work too. I had to do it manually.

    5. August 2015 at 11:30 #15279

    As some features in the webinterface rely on the SYSTEM_USER setting, there might be some other problems too (audioplayer soundcard setting is set to a wrong value with the reset). A reinstall might be the best solution.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here