Raspberry 7" Touchdisplay schaltet sich nicht komplett ab?

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Raspberry 7" Touchdisplay schaltet sich nicht komplett ab?

This topic contains 22 replies, has 7 voices, and was last updated by  GeorgeHB 1 year, 8 months ago.

Viewing 23 posts - 1 through 23 (of 23 total)
  • 9. November 2015 at 9:45 #16815

    Habe mir ein 7″ Touchdisplay gekauft welches sich nicht abschaltet, die Hintergrundbeleuchtung bleibt immer an.
    Bitte um Hilfe was muß ich tun?

    9. November 2015 at 10:09 #16816

    Das Abschalten scheint nur mit einer neuen Firmware zu funktionieren, die vor ein paar Tagen veröffentlicht wurde.

    echo 0 > /sys/class/backlight/rpi_backlight/bl_power
    echo 1 > /sys/class/backlight/rpi_backlight/bl_power

    9. November 2015 at 16:39 #16823

    Hallo Manfredk2, erstmal vielen Dank für die schnelle Antwort.
    Ich bin was Raspberry´s betrifft noch nicht sehr fit, Du schreibst das Abschalten funktioniert nur mit einer neuen Firmware die vor
    ein paar Tagen veröffentlicht wurde. Woher bekomme ich die?
    Als nächstes was bedeutet:
    echo 0 > /sys/class/backlight/rpi_backlight/bl_power
    echo 1 > /sys/class/backlight/rpi_backlight/bl_power
    ?
    Bin sehr dankbar für jede Hilfestellung.

    9. November 2015 at 19:54 #16824

    Hallo,

    ich bin leider auch kein Raspberry-Profi bzw. Linux-Profi.

    Ich hoffe die Firmware für das Touch-Display wird in der kommenden Version 2.25 (mit Kernel 4.1.12) von m2p integriert sein. 2.25 soll aktuell im Beta-Status sein.

    Hier was zum Lesen aus dem englischen Raspberry-Forum: https://www.raspberrypi.org/forums/viewtopic.php?f=108&t=120968&start=50

    echo 0 > /sys/class/backlight/rpi_backlight/bl_power wäre dann ein Shell-Befehl um das Display bzw. das Backlight ein- und auszuschalten.

    Gruß
    Manfred

    18. November 2015 at 19:12 #16958

    Hallo Manfredk2,
    habe gerade mit PuTTY probiert die Befehle an den Raspberry zu senden, was leider nicht von Erfolg gekrönt war.
    PuTTY schreibt Datei oder Verzeichnis nicht gefunden???
    Was habe ich falsch gemacht?
    Habe mich mit PuTTY auf die IP des Raspberry geschaltet und mich mit “pi” als Nutzername und “raspberry” als Passwort angemeldet
    und anschließend den von dir erwähnten Befehl
    echo 0 > /sys/class/backlight/rpi_backlight/bl_power
    eingegeben.

    18. November 2015 at 20:46 #16959

    Hallo,

    mit der aktuellen m2p-Version geht das afaik noch nicht. Vielleicht kann das Entwicklungsteam mal was dazu schreiben ob das in V2.25 gehen wird…

    Mein 7″ leuchtet auch dauerhaft vor sich hin 🙁

    Gruß
    Manfred

    20. November 2015 at 12:47 #16971

    Hallo zusammen,

    danke für die Infos in diesem Thread. Da die aktuelle Max2Play-Kernelversion wie von Manfred geschrieben diese Funktion noch nicht unterstützt, bin ich gerade dabei einen neuen Kernel mit der Backlight-Unterstützung zu erstellen. Diesen werde ich dann noch testen und als Update im RPI-Display-Plugin Mitte nächster Woche zusammen mit einem Max2Play Update zur Verfügung stellen.
    Dabei wird es auch ein Update für Jivelite geben, damit hier automatisch die Hintergrundbeleuchtung deaktiviert wird, sobald der schwarze Bildschirmschoner (BlankScreensaver) aktiv ist.

    Viele Grüße
    Stefan

    • This reply was modified 1 year, 11 months ago by  flysurfer.
    20. November 2015 at 13:17 #16973

    SUPER, das ist echt nett. Eine Frage hätte ich auch noch warum gibt es in Jivelite nicht die CEC Funktion um das Menü mittels Fernbedienung zu steuern? Ich würde mich sehr freuen wenn das wie bei KODI funktionieren würde, dann bräuchte man keine Tastatur mehr im Schlafzimmer 😉

    20. November 2015 at 13:59 #16976

    CEC für Jivelite zu aktivieren ist sicher möglich. Allerdings geht das nicht mit dem 7″ Display sondern nur über HDMI an einem angeschlossenen TV. Ich werde das mal testen und ggf. in Jivelite als Option hinzufügen.

    20. November 2015 at 14:05 #16977

    Das meinte ich auch, sorry falls ich das nicht so gut beschrieben habe 🙂

    26. November 2015 at 11:21 #17035

    Hallo!

    Update 2.25 ist jetzt verfügbar, mit dem Max2Play die Hintergrundbeleuchtung automatisch ausschaltet. Nach Aktualisierung von Max2Play muss im Menü “Raspberry Pi Einstellungen” ein “Kernelupgrade” durchgeführt werden und nach einem Neustart unter “Jivelite” eine Neuinstallation von Jivelite durchgeführt werden, vorzugsweise der vorkompilierten Version.

    Maximilian von Max2Play

    26. November 2015 at 18:50 #17041

    Hallo Maximilian!
    Danke für das Update, die Installation hat wunderbar funktioniert.
    Das Problem bei mir ist, dass sich der Raspi rebootet sobald ich auf aus drücke.
    Backlight schaltet sich kurz aus und dann Neustart. Könnte das am Netzteil, der Stromversorgung, liegen
    oder haben Andere das gleiche Problem?

    Mit Gruss malf_21

    Nachtrag: Wenn sich der Bildschirmschoner automatisch einschaltet, sich Backlight ausschaltet, gibt es kein Neustart.
    Das Problem besteht nur beim “Player ausschalten”-Knopf.

    • This reply was modified 1 year, 11 months ago by  malf_21.
    26. November 2015 at 18:59 #17042

    Hallo malf_21,

    das scheint ein Problem mit der Stromversorgung zu sein. Für das Display solltest du ein 2A Netzteil verwenden und bei zusätzlichen anderen Verbrauchern ggf. ein zusätzlichen USB-Hub mit separater Stromversorgung verwenden.

    Viele Grüße
    Stefan

    26. November 2015 at 19:00 #17044

    Danke für die Antwort. Aber ich benutze im Moment ein 2.4 Amp Netzteil… ? Probiere mal ein anderes Netzteil.

    Die Lösung: Nicht das Netzteil macht Probleme sondern das Kabel! Habe diverse Kabel getestet und bin mit dem Kürzesten glücklich geworden. Dazu noch ein passendes Video: https://www.youtube.com/watch?v=doMHmGatyYc

    • This reply was modified 1 year, 11 months ago by  malf_21.
    • This reply was modified 1 year, 11 months ago by  malf_21.
    28. November 2015 at 9:45 #17055

    Was nach einem zweitägigen Test unangenehm auffällt ist das der Raspberry am nächsten Morgen neu gestartet werden muss da das Display nicht reagiert, woran kann das liegen?

    30. November 2015 at 15:27 #17067

    Hallo. Wenn mein Netzwerk überlastet ist – download ;-), dann reagiert der Touchscreen auch nicht mehr. Villeicht liegts am Netzwerk. Mit Gruss malf_21

    30. November 2015 at 18:54 #17068

    Mein Display wacht jederzeit, egal ob per Touch oder IR-Fernbedienung, auf.

    3. December 2015 at 1:35 #17107

    Hallo, ich habe jivelite, max2play und den Kernel aktualisiert. Wenn ich als Bildschirmschoner blank screen wähle, bleibt die Beleuchtung trotzdem an. Der Konsolenbefehl gibt den Fehler “keine Berechtigung” zurück, als root User klappt es, nachdem ich ein root passwort eingerichtet hatte. In jivelite aber immer noch nicht.

    Habt ihr einen Tip, woran das liegen könnte?

    Grüße, fblu

    7. December 2015 at 10:07 #17134

    Hi, wollte nochmal fragen, ob irgendjemand einen Tip hat, wie ich jivelite dazu bekomme, nicht nur den Screen schwarz zu machen, sonder auch die Hintergrundbeleuchtung auszuschalten.

    Vielleicht irgendeine Berechtigung setzen? (da ich ja z.B. auch nur mit root-Zugriff in der Konsole selber die Beleuchtung ausschalten kann, siehe einen Beitrag weiter oben)

    Grüße

    9. December 2015 at 16:08 #17201

    Hallo fblu,

    wenn bei dir trotz des Kernelupdates und der Installation der aktuellsten Jivelite-Version die Backgroundbeleuchtung mit dem BlankScreenSaver von Jivelite anbleibt, dann kannst du mal versuchen auf der Konsole (über SSH einloggen) den Befehl “per Hand” zu testen:
    – Wichtig ist, dass die Datei “/sys/class/backlight/rpi_backlight/bl_power” existiert
    – Mit dem Befehl “echo 1 > /sys/class/backlight/rpi_backlight/bl_power” (in die Datei wird der Wert 1 eingetragen) sollte die Beleuchtung ausgeschalten werden

    Falls die Datei vorhanden ist, aber das Abschalten nicht funktioniert liegt es ggf. am Netzteil oder Kabel. Siehe auch der Post von malf_21.

    25. December 2015 at 11:16 #17479

    Fam.Weigand schrieb: Was nach einem zweitägigen Test unangenehm auffällt ist das der Raspberry am nächsten Morgen neu gestartet werden muss da das Display nicht reagiert, woran kann das liegen?

    Das ist bei mir jetzt auch einmal passiert. Das Display blieb aber trotz Neustart des Pi dunkel (mein Display hat den “Hauptstromanschluss” und versorgt den Pi über ein USB-Kabel). Ich musst erst das Display komplett stromlos machen und neu starten, dann gings wieder

    26. December 2015 at 9:26 #17484

    Hallo Manfred2k, bei mir ist es genau umgekehrt,
    der Raspi versorgt das Display.
    Nach den anfänglichen Schwierigkeiten habe ich MAX2Play komplett neu installiert und geupdatet,
    jetzt läuft alles wie es soll.

    20. February 2016 at 14:15 #18618

    Hallo Fam.Weigand,

    auch ich wollte den Bildschirm mit dem “echo > 1 ……” ausschalten, aber es klappte nicht, da mir der Zugriff auf die Datei “bl_power” verwehrt wurde. Ich habe dann als “su” die Datei beschreiben können. Mit “sudo echo > 1……” klappte es leider auch nicht.

    Mit “echo 1 > /sys/class/backlight/rpi_backlight/bl_power” schalte ich das Touchdisplay AUS und
    mit “echo 0 > /sys/class/backlight/rpi_backlight/bl_power” schalte ich es wieder EIN. (Hintergrundbeleuchtung)

    Es klappt jedoch nur als “su”.

    • This reply was modified 1 year, 8 months ago by  GeorgeHB.
Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.

Register here