Pulsating noise from pi/hifiberry when not playing

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Pulsating noise from pi/hifiberry when not playing

This topic contains 2 replies, has 2 voices, and was last updated by  stephi premium 2 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 20. October 2016 at 21:47 #23490

    Hi All Max2play enthousiasts!

    I am so pleased with max2play. Streaming 24 hours a day with my pi/hifiberry/max2play!…..well almost.
    And when it’s time to rest my ears, I leave my amplifier and Pi on and hear a pulsating noise coming from the speakers. This noise disappears when I start playing music again!

    Some sort of Idle noise ? raspberry goes to sleep? ….?

    Anybody a solution for this problem?

    Thanks!

    28. October 2016 at 11:29 #23590

    Hello stephi,

    Thanks for your request.

    Please try to deactivate the inbuild audio of the Raspberry Pi under Raspberry Settings. If you do thi you have to set “-o hw:0 -V Master” in the command line options. So the AMP should be deactivated if Squeezelite is stopped.

    Best Regards

    4. January 2017 at 14:15 #25484

    Thanks for your reply! Sorry for my late respons 😉

    “-o hw:0 -V Master” will by-pass the equalizer so that’s no option. also deactivating the inbuild PI audio didnt’owrk…As in : I couldnt do it 🙂

    BUT! I found the following:

    -C <timeout> “Close output device when idle after timeout seconds, default is to keep it open while player is ‘on’”

    So in the command line options filed I’ve put in:
    “-C 5”

    Now, when i stop playing, after 5 seconds the audio output stops and the noise is gone!

    Thanks!

    p.s. I do use the “-o hw:0 -V Master” option on my other PI, wich is connected to my livingroom stereo without equalizer. That works great and is preferable I think. But how to make it work on my other device with my ‘plugequal’as soundcard?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here