Problems Identified with Pi Zero/HiFiBerry DAC+ : Help Needed with Solution

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Problems Identified with Pi Zero/HiFiBerry DAC+ : Help Needed with Solution

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 3 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 20. April 2018 at 0:54 #35230

    Hello! As I indicated in my last post, I am unable to connect to Spotify Connect with a Pi Zero W and HiFiBerry DAC+ Zero.

    I placed the DAC+ Zero and on Pi 3 and went through the procedure to set up and connect to Spotify. Easy!

    When I looked under the file system, /Opt/spotifyconnect was present.

    It is not present when I use the Pi Zero W.

    Apparently, when Max2Play reads the type of Pi, for the Zero, it does not load the /Opt/spotifyconnect files.

    I would appreciate help in getting this solved for my Pi Zero? Thank you and best regards.

    Mike

    21. April 2018 at 0:35 #35238

    Hello! I hate to be a bother, but I am not making progress. Now, when I try to reboot, the system frequently stalls and says that the root account is locked. This despite the fact that I have completely reformatted my SD card several times and reinstalled the image before starting to reload the selections.

    When I was on the M2P desktop, I tried to place librespot (after downloading it with Firefox) in the spotifyconnect folder that I created; however, the system would not let me do that from the GUI. With this version of Firefox, I could not find the option command that would allow files to be downloaded to alternate file destinations.

    When I tried to copy the file from the command line, the system did not recognize the python commands that I used, so I am obviously doing something wrong. When I tried to use the file manager to find where python was loaded, I did not find it.

    In summary, the PiZero W does not work with spotifyconnect – Librespot is missing. Now, I am getting locked out of the system at irregular intervals upon reboot.

    Thank you for guidance. Best regards.

    Mike

    22. April 2018 at 22:42 #35258

    Hello! OK, I found the source of one error – I was not clicking on „Load WiFi Interface“ a couple of times during the process. When that happens, after reboot, the system locks me out.

    It looks like there is a new download for the Pi zero. In any case, when I down load SpotifyConnect, it shows up in the /opt file and Librespot is in the file now.

    Unfortunately, I still have the same error when I start SpotifyConnect – “ Trying to launch … NOT successful Click here to show detailed information.“ When I click on the link for detailed information, nothing comes up.

    Under DeBug infor, I still get „#### Librespot Output #### #### Librespot Command Line Options ####
    Illegal instruction.“

    So, Librespot now shows up. However, the system does not act on it.

    I tried to replace the file with the previous version of Librespot that a poster in the forum stated works, but I cannot get to the admin page.

    Thank you for your help. Best regards.

    Mike

    #### Librespot Command Line Options ####
    Illegal instruction

    #### Librespot Command Line Options ####
    Illegal instruction

    25. April 2018 at 11:05 #35327

    Hi Mike,

    Sorry about the late response. I was on holiday and am still working through the past week of requests.

    Thank you for the detailed report. I was able to recreate the issue on a Pi Zero Wireless, while 3B and 3B+ worked fine. So I added it to the list of known bugs and we will try to find a solution asap.

    If you are referring to the superuser in SSH, please log in as user pi with the pw „max2play“ then execute „su“ and use pw „max2play“.

    For now, you can use Spotty if you are okay with a Squeezebox Server running. Here’s the HowTo on setting it up.

    25. April 2018 at 15:15 #35331

    Hello! Thank you for your note and help with Pi Zero W and HifiBerry DAC+ zero.

    As far as logging on as administrator, I do not use Secure Shell – I log on to the desktop directly with a wireless keyboard and an HDMI monitor after turning on the Pi Zero W. The boot sequence takes me to the Max2Play desktop. From there, I log onto my network via http://max2play in order to set up everything.

    I do not see where to log in as administrator from the Max2Play desktop or the network. On the desktop, I tried to sign in to root under System tools with P/W of raspberry, pi, su, and max2play, but none worked. On the network, I went to the admin page, http://max2play/admin (as well as the actual address such as 168.192.1.1/admin), however, the page was blank except for the Max2Play headers at top, so there was no where to input the username and P/W. Best regards.

    Mike

    27. April 2018 at 11:50 #35359

    Hi Mike,

    You are right, however, sudo should still work.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here