Problem with Usb Drive

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 Problem with Usb Drive

This topic contains 17 replies, has 5 voices, and was last updated by  patrick31698 1 year, 1 month ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • 6. October 2015 at 20:30 #16085

    I have a Problem with mounting an NTFS USB HDD.
    The Hdd is attached to the U3 via powered USB hub(2,5 Ampere). The hub also serves as Power source for the U3.
    When the U3 is booted The HDD is mounted at media/usb0. scanning for music files hangs After approx 2 minutes.
    When i try to rescan, HDD is not mounted to any Media/usb….
    Let me know what Infos you need.

    Regards Patrick

    7. October 2015 at 7:38 #16087

    I don’t know where to start searching for the failure.
    It worked flawlessly for some days. Then i had to change the USB Hub due to problems with powering the HDD. I don’t know whether it was caused by the hub or the power adaptor.
    Even when scanning the music collection seems to be okay it is not. There are several Albums missing and the Albumart is not complete.
    It is a very strange issue as with every attempt of rescanning the max2play interface shows one more USB Drive which i can’t connect.
    (It’s hard to explain in english…)
    I also tried to fix the mount point by UUID, which also doesn’t work (Is it correct that the max size for the Pi is 2 GB ?) I am working woth an U3 hoping that the U3 can handle a 1 TB HDD.

    Would it be helpful to add the HDD to fstab manually?
    Does hdidle work with drives managed by fstab?

    Ah forgot to mention that I updated max2play and ubuntu via the interface / apt-get update apt-get upgrade

    Very frustrating 🙁

    Patrick

    • This reply was modified 1 year, 2 months ago by  patrick.
    • This reply was modified 1 year, 2 months ago by  patrick.
    7. October 2015 at 17:49 #16103

    Hi Patrick,

    thank you for contacting us.

    I recommend to restart with a default Max2Play image, create a new Squeezebox server and connect your hard drive afterwards.

    Regards

    Maximilian

    7. October 2015 at 18:22 #16106

    I am right now reflashing my eMMC Card.

    But i woulgd have been nice to know what went wrong.

    Problems occured without any known reason. I updated ubuntu after having the first problems.

    So you recommend not to update ubuntu?

    Another Question: is it possible to fix the mount point by UUID on an Odroid U3?

    7. October 2015 at 21:37 #16107

    Problem persists even with a New Installation.
    It seems that the Problem occurs After Hdd idle and can only be overcome by an restart.

    8. October 2015 at 17:02 #16209

    Hi patrick,
    Max2Play is designed and fitted for a specific version of Ubuntu, updating would mess with the system. Regarding size restrictions, we have already successfully integrated a 1TB HDD into the system. This should not be a problem for the U3. Please try it without any additional periphery connected to rule out this origin of error.
    Regarding the HDD idle time, I have already addressed this issue in another thread: https://www.max2play.com/forums/topic/hard-drive-goes-into-idle-mode-too-early/
    You can try out this solution and change the idle time to your liking.

    8. October 2015 at 19:43 #16237

    Hi, Heiner
    Thanks for helping me.

    So far i did not change anything outside the max2play interface.
    I dont have any other Hardware but the HDD together with the powered hub, As the Power from the U3 is not enough.
    I think the drive is not going into idle mode to early but it does not wake up correctly.

    I will send some Screenshots (is it possible here?) of the errors Tomorrow.

    Regards Patrick

    10. October 2015 at 22:51 #16266

    Me again,
    I removed the # at the last line of /etc/default/hdidle
    and changed the value from 180 to 6000.
    But the HD goes to idle mode even during scanning and causing a system crash.

    11. October 2015 at 11:36 #16267

    I would guess you don’t have good power to it. Try a power supply 1 to each. Hard drives take more power when they spin up then when they are on just spinning.

    11. October 2015 at 13:07 #16268

    One thing that really drives me crazy is that checking for new files always results in erasing all files from the data base.
    Often i don’t see my hard drive in ANY /media/USB0-7 folders after scanning.
    i think there is something going wrong with automount….
    And i can’t fix the /media/USB folder by UUID.

    I get this when i try to fix the mount point.
    May be there is some thing wrong in the web interface?

    Dateisystem – Mounten von Netzwerkpfaden (Samba/NFS)

    Falscher Pfad:
    HinzufĂŒgen nicht möglich! Bitte Anleitung beachten!
    Pfad Mountpoint Typ Optionen Aktion

    Neuen Mountpoint hinzufĂŒgen:

    //192.168.1.100/share
    /mnt/share
    cifs
    user=name,password=pass,sec=ntlm,iocharset=utf8

    Hilfe anzeigen
    Netzwerk GerÀte anzeigen

    DEBUG Info

    Externe Laufwerke an Max2Play – Pfade zu USB-Laufwerken

    Diese Liste zeigt die Verzeichnisse fĂŒr alle externen Speichersticks und Laufwerke. Diese GerĂ€te können ĂŒber das jeweilige Verzeichnis z.B. im Squeezeboxserver oder in Kodi/XBMC verwendet werden. Achtung: der Raspberry PI kann nur Partitionen bis 2GB verwalten. Sollte die Festplatte grĂ¶ĂŸer sein, so muss diese zuerst auf einem System in max. 2GB Partitionen aufgeteilt werden.

    in /media/usb0 (Device with UUID )
    Fixiere Pfad zum USB-Speicher (bleibt bei Neustart erhalten):

    • This reply was modified 1 year, 1 month ago by  patrick.
    11. October 2015 at 15:56 #16270

    deleted

    • This reply was modified 1 year, 1 month ago by  patrick.
    11. October 2015 at 16:20 #16272

    I think it might be a problem with the USB Hub.
    Red LED on the Hub starts to flicker after some time and then connction is lost. This also appears when i conncet it to my PC.
    Any suggestions on a powered USB Hub ?

    Nevertheless fixing the mountpoint even with a USB pen drive does not work…..

    Regards Patrick

    14. October 2015 at 15:09 #16361

    We do not have any experience with USB-Hub’s, we would recommend using a proper outlet for power supply.
    Regarding the German error message, please make sure you have English put as the device’s system language under “Settings/Reboot”. We are looking into this specific message, whether it got mixed up.

    14. October 2015 at 15:48 #16367

    Problem is not the german language. I am german.
    Problem is that i am not able to fix the mount point

    16. October 2015 at 14:43 #16410

    Okay, I thought this would be a secondary problem.
    So, you tried mounting a HDD with external supply and did not work either? To make sure you follow the same steps we do, please take a look at our tutorial video on the subject: https://youtu.be/3klQkxF6iNA?t=1m37s
    If you still cannot mount the drive, please try again with a freshly burnt and expanded image if you have not already.

    6. November 2015 at 13:47 #16787

    I have this USB Hub now

    http://www.amazon.de/schnelladen-funktion-inklusive-externes-Netzteil/dp/B00B22EY4S

    Everything works fine.

    6. November 2015 at 14:03 #16789

    I guess because that USB hub has a power supply with it. That’s why it works and the other not if it did not have it’s own power supply.

    -Raymond Day

    6. November 2015 at 14:06 #16790

    The other one also had a Power supply but i think it was out of Order in some way.
    So, I can recommend the i tec hub.

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

Register here