Problem with Samba

This topic contains 7 replies, has 2 voices, and was last updated by  MarioM Moderator 4 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 30. Mai 2020 at 14:23 #48880

    Hi all,

    I seem to be having a problem getting into my m2p files via „My Computer“ on my desktop PC (I have set up SAMBA using the m2p instructions).

    Strange as everything works as it should, I can sync M2P to play music with different players on the network, my Squeezebox Touch works fine with it. I can play tracks with my android phone with Samba Player and Squeezer. I just can’t acsess my files on the hardrive thats connected to the Pi with Max2play on it from the network via my PC or laptop.

    What I get is a prompt from windows, (a new window opens on screen) it says „Enter Network Password for max2play“, then asks for username and Password. I don’t have a clue as to which user name it wanted so I used the one from the samba set up. By this I mean when I set up samba I was given a user name „root“ and I put in a password, saved it. So tried this, NO.

    So I used my local wifi password details, No that did’nt work, I used my log on details when I log onto the computer, No, I used the raspberry Pi user and password „pi/raspberry“ no. Other than this, I’ve not set up any other passwords. I have reburned several images, hoping they will work, but its doing exactly the same as the above.
    AGGHHHHH, hoping someone might be able to shed some light on this for me please.
    Thanks all

    • This topic was modified 4 months, 3 weeks ago by  alex.
    2. Juni 2020 at 14:45 #48911

    Hi Alex,

    The password you need should be the one you set up for the Samba share access. When you connect the network drive to your Windows PC, make sure that you enter the following as a path: \\name or IP address of the Max2Play device\name of the samba share

    2. Juni 2020 at 22:50 #48934

    Hi MarioM
    Really good of you to get back to me.
    Would you please take a look at this below and see if I’m on track ?

    Sambashares, this is whats on the Filesystem Mount page on my Max2play

    Sambashares on Max2Play – setup network share paths

    Name
    max2playshare

    Path
    /media/usb0/storage/My Music/flac

    Comment
    Max2play USB

    Writeable
    yes

    Create Mode
    0777

    User for Samba-Access: root
    Password for Samba-Access: root

    I’ve upgraded to Pi4 and don’t seem to remember this issue with my other pi. In the past I just opened my file manager „My Computer“/network and there is was.
    However, in windows I can see my player on the network and I can see the shared folder, but when I click on it to open it, it (windows I think) asks for a username and password.

    Going back to your instructions, when you say „connect the network drive to your Windows PC“, I’m really not sure what you mean. I thought this is what samba does.
    I’d really appreciate if you could spell this bit out a little more please.

    And your instructions above, Do you mean in my browser, and if so should look like this
    http:\\192.168.1.000000000000000\max2playshare. I tried this and it did’nt work.

    But even if it did, would this, once done allow me access to the files via windows file manager as I need access to backup my music to the cloud. Thanks for your help.
    A

    • This reply was modified 4 months, 2 weeks ago by  alex.
    4. Juni 2020 at 15:43 #48941

    Hi Alex,

    In Windows Explorer there is a function to map a network drive. If you do this, you have to assign a letter for the drive such as „G:“ and specify the folder path. In this path you have to enter the IP address or the name of the Max2Play device, like: \\IP-address\share. You can find more detailed information here on the Microsoft help page: https://support.microsoft.com/en-us/help/4026635/windows-map-a-network-drive

    5. Juni 2020 at 11:02 #48947

    Hi MarioM
    Thanks for your help. I’ve tried that and flashed another image that I’m now using.

    What I get is a Windows pop up window called „Map Drive window“ that I can browse for my M2P. I can see it And there is a choice of drives letters I can assign to it.

    I put in the search box \\xxx.xxx.x.xx\media/usb0 and a window pops up called Map Network Drive, then its saying „attempting to connect to the IP address I have just entered and just sits there, I have to „cancel“ it to stop it doing what its doing.

    However, When I hit the „Browse button“ another window pops up called „Browse for folder.
    I can see Max2play in the list along with my Squeezebox Touch and the PC I am using.

    I choose Max2play… I then get a security window pop up (in windows) that says „Enter your Network password to connect to MAX2PLAY“

    So I enter the samba password I set up and it just rejects it.

    Very odd. Would you know if this means that Samba on M2P has been set up properly as I can see it on the network.
    If so, any idea what the password what could it be.

    I’ve tried raspberry, max2play and my PC logon password. Incidentally, this happened with the other images I have tried. However, since upgrading to a Pi4, I have also replaced my PC. So I’m using another PC in effect from when it used to work. That said, my laptop won’t connect either.
    Do you have any other suggestions. I have also flashed another image for my old Pi3 and thats doing exactly the same as this pi4.

    Any suggestions would be very much appreciated.
    Thanks

    9. Juni 2020 at 13:50 #48964

    Hi Alex,

    Please try to enter „\\xxx.xxx.x.xx\name of your share (not the path)“ in the Map Drive window and then connect to it. When asked for a user and password, use the data that you entered in Fileystem Mount under Sambashare Access. If that still doesn’t work, try activating the support for the SMB 1.0/CIFS file sharing in the Windows features.

    10. Juni 2020 at 12:24 #48979

    Hi MarioM

    Thanks again for your help and time, its very much appreciated.

    Follow your latest advice, I am delighted to say there has been some progress :-)…

    I did what you suggested and it did’nt work. But, also in your last message you gave me a link to the Samba support for windows, thinking you were trying to tell me it might be a windows issue, you were darn right…

    So, I borrowed a friends laptop, fired it up and followed your instructions again, and hey-ho, it worked!!!
    So my problem is some type of security issues with windows when connecting my pc to my LAN/Max2play.
    But you have resolved my issue, at least I know I can get to my files. If you do happen to know what might fix it, I would be very pleased if you could let me know (maybe I need to go to the link you sent me), but for now thanks again for your help…

    12. Juni 2020 at 14:08 #48991

    Hi Alex,

    If the problem is with the Windows PC, there can of course be many reasons why it does not connect to Max2Play. When it comes to security problems, the virus protection program comes to mind, which may interrupt connections. Can you test whether you can access other (maybe similar) devices with your PC? Apart from that, I can only recommend you to look in Microsoft forums to see if you can find a solution.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here