Problem with Airplay Shairport Raspberry Pi3

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Problem with Airplay Shairport Raspberry Pi3

This topic contains 5 replies, has 2 voices, and was last updated by  Mbydeen 1 year, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 20. Februar 2017 at 23:31 #27069

    Hello,

    I’ve been looking up the internet and trying to resolve this problem however I haven’t found the solution yet. Hope someone overhere have a similar problem can help me.

    I’m currently using the hifiberry Digi+ Transformer version, and using the RPi3. My set up the simple AIrplay option using shairport to stream music. However 4 out of 8 times when I turn off and my pi on again, the max2play showed on my ipad and it said it is streaming music but I got silience, no sound. I kept to either restart the pi or keep kill/restart the shairport plugin again, at least 2 or 3 times before I can actually hear the music. I have disabled, bluetooth, headphones out and the recommended setting in the Raspberry pi but the problem still persist.

    Just a note that when the music actually play, it really clear. It just that when I restart the pi, I have to kept restarting it untill it work again.

    I“m assuming I have to do something right since I do hear music sometimes if I do completely wrong then I don’t think I’ll hear the music stream at all.

    Thank you for all of your help and hope to hear from you guys soon.

    21. Februar 2017 at 12:42 #27080

    Dear phamd4,

    Please make sure that you have the latest version of Max2Play, which is 2.41, then can you send us the configuration that you are using in hifiberry Digi+ plugin and Audioplayer plugin.

    Regards,
    Mohammad Mbydeen

    23. Februar 2017 at 5:10 #27158

    Hello,

    Thank you for your reply. Here is the image of my setting.

    I also notice today that when I stram via Shairport it played for like 1 minutes then it went silence, max2play airplay still showed on my iPad but no sound. I have to kept kill the shairport and start it again 2 to 3 time before I got sound coming out again. As long as it played for more than 5 minutes, It will not drop to silence anymore.



    • This reply was modified 1 year, 7 months ago by  phamd4.
    23. Februar 2017 at 12:53 #27166

    Dear phamd4,

    Please uncheck the box for Enable I2S-MMAP (Mixerdevice for Soundcards)and enter the following into the shairport commandline: -t hardware -m hw:CARD=sndrpihifiberry -c Digital, hope this will solve your problem.

    Regards,
    Mohammad Mbydeen

    24. Februar 2017 at 3:09 #27185

    Hello,

    after turn off the I2S, and added the command line I got this error code which I can’t start the Shairport

    I have a Pico UPS running with the Pi3 I don’t know if that caused this problem.

    1. März 2017 at 15:12 #27377

    Hello phamd4

    I think that Pico UPS does not impact the shairport/Airplay, if you are using also Squeezelite audio player, please in the Shairport/Squeezelite automatic Audio-Switch put the IP of LMS server. and you can also burn fresh image and the configuration for the shaireport would be automatically set, I dont know why the commandline for shaireport was empty.

    Regards,
    Mohammad Mbydeen

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here