problem betwen MAx2Play and LMS

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI problem betwen MAx2Play and LMS

This topic contains 11 replies, has 3 voices, and was last updated by  Heiner Moderator 3 weeks, 3 days ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 20. August 2018 at 19:55 #37014

    Hello,
    for bigining sorry for my english, i’m french.
    I use a raspberry pi model B+
    I’m using max2play with LMS on a synology server. When I navigate in LMS I can’t find the MAX2PLAY player.
    But if I install LMS on the Raspberry through Max2play, it works.

    The only thing I noticed is that on Synology the LMS server is using port 9002 while on the Raspberry server stack is using port 9000.
    Should I change the port on the LMS server of synology? And how to do it?
    Thanks for your help.

    21. August 2018 at 12:42 #37055

    Hi krillin,

    Changing the port should not be necessary. Which version òf the LMS is installed? Did you try adding the IP of the diskstation manually in Squeezelite, yet?

    22. August 2018 at 11:29 #37101

    Hi Heiner,
    I use on Synology, Logitech Media Server Version : 7.7.6 – 1452060463
    I don’t understand when you say “adding the ip of the disk station manually in Squeezelite”
    In which tab should I go ?
    Thanks for your help.

    22. August 2018 at 14:11 #37120

    Sorry, in the Audioplayer menu under Squeezelite’s advanced options is the command line options field.

    Add your diskstation’s IP and its port in the following syntax:

    -s <server>[:<port>] Connect to specified server, otherwise uses autodiscovery to find server

    So, for example: „-s 192.168.1.1:9002“

    23. August 2018 at 16:25 #37216

    Hello,

    I just came across the issue as descibed above.
    I have a similar issue but I can’t find the Audioplayer menu under Squeezelite’s advanced options.

    can you tell me where to find this?

    thanks in advanced!

    Grtz.

    Bas

    23. August 2018 at 16:40 #37217

    Hi Bas,

    The Audioplayer plugin’s menu has the Squeezelite player in it. The Squeezelite player has a button „edit advanced options“. There, you can find the parameter „command line options“ and can save any new values to it.

    23. August 2018 at 17:05 #37218

    check, I found it!

    unfortunately the solution was not succesful.
    I run LMS in a docker container with ipaddress 192.168.1.101:9000
    when I run LMS it does not show the Max2play devices.

    any idea how I can fix this?

    thanks in advance!

    24. August 2018 at 10:32 #37257

    Hi Bas,

    Easiest solution would be running the LMS on the Raspberry Pi. But I assume that’s not an option for you?

    What’s the output when you add the command line options ans save?

    Also, please check and make sure that both Pi an LMS device are connected to the same network and do not have any restrictions on them.

    28. August 2018 at 14:28 #37599

    Hi Heiner,
    Thank you for your advice, I found the option but the field is already filled.
    He described it as „-C 5“ What does it mean and how do you combine 2 lines of command?

    I must install the DLNA audio client gmediarender to find it on a network or no? What is it used for ?
    Thanks for your help.
    Krillin

    29. August 2018 at 16:48 #37606

    Hi Krillin,

    You can just add other parameters when they are separated only by one space.

    Did the -s parameter work?

    Regarding -C, here’s the explanation from our wiki article:

    -C Close output device when idle after timeout seconds, default is to keep it open while player is ‚on‘

    31. August 2018 at 9:40 #37613

    Hi Heiner
    Sorry but the –s parameter doesn’t work

    I don’t have max2play that appears in LMs in Synology.
    I have uninstalled LMS and reinstalled it doesn’t change anything.
    I have unistalled and reinstalled Max2play. it doesn’t change anything too
    I don’t know what to do.
    Thank you for your help
    krillin

    31. August 2018 at 10:26 #37614

    Hi krillin,

    Your issue is probably connected to the home network. You can still check your router’s web interface and see if both NAS and Pi are properly recognized and listed in your connected devices list.

    You can also check your LMS settings for any possible restrictions and to see if the player shows up in the respective Settings menu.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here