[SOLVED] Printserver not working

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Printserver not working

This topic contains 13 replies, has 2 voices, and was last updated by  Mbydeen 1 year, 7 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • 12. Februar 2017 at 15:16 #26860

    Hi there,

    i’ve installed the printserver on my odroid u2/u3 max2play but i can’t see the printserver web interface?! The site http://max2play:631 won’t open, any ideas?

    Thanks!

    13. Februar 2017 at 13:41 #26874

    Dear wenkman,

    Please have a look at this webpage:

    https://www.max2play.com/en/wiki/using-the-plugin-printserver/

    You also could try to uninstall and install the plugin again.

    Best Regards,
    Mohammad Mbydeen

    13. Februar 2017 at 19:44 #26910

    Thank you for the help, but the printserver web interface http://max2play:631/ still doesn’t open. Is there a way to check if it really is running? Maybe some telnet / shell process ID I could have a look at?

    14. Februar 2017 at 12:37 #26916

    Dear wenkman,

    you can try to do a simple test to see if the port accepts connections. you can use the nc command and the”-vz” option:

    nc -vz IP_Address Port

    for more information you can have a look at:

    https://support.rackspace.com/how-to/testing-network-services-with-netcat/

    Best Regards,
    Mohammad Mbydeen

    14. Februar 2017 at 18:49 #26928

    nc: connectx to 192.168.2.125 port 631 (tcp) failed: Connection refused

    15. Februar 2017 at 12:35 #26931

    Dear wenkman,

    Please make sure that you disabled IPv6 on the raspberry settings page, because enabling IPv6 could cause broken links. and then you can check the CUPs service using this commands:

    nmap -v -sV localhost -p 631
    sudo netstat -tnlp | grep :631

    And please check the firewall settings if you are accessing the Print server from outside.

    for more information, please check the following webpage:

    http://serverfault.com/questions/725262/what-causes-the-connection-refused-message

    Best Regards,
    Mohammad Mbydeen

    18. Februar 2017 at 15:10 #27010

    Ok. Thanks so far. CUPS is listening on port 631 and I can get to it via wget from my max2play device (odroid), so the service seems to be Ok and running – but I cannot reach it from any other device in my network (Notebook, iPad, PC…) . So maybe it is some firewall issue? I only have a FritzBox router, I thought there was no port blocking or additional firewall there in my local network. Does anyone have any more ideas?

    19. Februar 2017 at 15:50 #27024

    nmap -v -sV localhost -p 631

    Starting Nmap 6.40 ( http://nmap.org ) at 2017-02-19 14:47 CET
    NSE: Loaded 23 scripts for scanning.
    Initiating Ping Scan at 14:47
    Scanning localhost (127.0.0.1) [2 ports]
    Completed Ping Scan at 14:47, 0.00s elapsed (1 total hosts)
    Initiating Connect Scan at 14:47
    Scanning localhost (127.0.0.1) [1 port]
    Discovered open port 631/tcp on 127.0.0.1
    Completed Connect Scan at 14:47, 0.00s elapsed (1 total ports)
    Initiating Service scan at 14:47
    Scanning 1 service on localhost (127.0.0.1)
    Completed Service scan at 14:47, 6.02s elapsed (1 service on 1 host)
    NSE: Script scanning 127.0.0.1.
    Nmap scan report for localhost (127.0.0.1)
    Host is up (0.000093s latency).
    rDNS record for 127.0.0.1: odroid
    PORT STATE SERVICE VERSION
    631/tcp open ipp CUPS 1.7

    Read data files from: /usr/bin/../share/nmap
    Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
    Nmap done: 1 IP address (1 host up) scanned in 6.45 seconds

    =================================================================================================
    sudo netstat -tnlp | grep :631

    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 9464/cupsd
    tcp6 0 0 ::1:631 :::* LISTEN 9464/cupsd

    19. Februar 2017 at 20:01 #27026

    … and „Logitech Media Server“ is reachable via „http://max2play:9000“ without any problems, printserver on „http://max2play:631“ not. Any more ideas?

    20. Februar 2017 at 13:16 #27037

    Hi wenkman,

    Please can you check iptables firewall. iptables is a user-space application program that allows a system administrator to configure the tables provided by the Linux kernel firewall. you can change the configuration to allow port 631 to accept data packets. Please check the following webpages:

    https://help.ubuntu.com/community/IptablesHowTo
    https://ubuntuforums.org/showthread.php?t=1849117

    Regards,
    Mohammad

    20. Februar 2017 at 20:11 #27061

    iptables is not installed on my maxplay/odroid. Is it even possible that there is the problem? shall I install it via apt-get?

    20. Februar 2017 at 20:58 #27063

    installed it. appended some rule. now it looks like this:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT tcp — anywhere anywhere tcp dpt:ipp
    ACCEPT tcp — anywhere anywhere tcp dpt:ipp

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    … still doesn’t work…

    20. Februar 2017 at 23:31 #27068

    got it.

    cupsctl –remote-admin

    21. Februar 2017 at 11:48 #27073

    Dear wenkman,

    On Max2Play the remote administration is enabled by default, but thank you to write the solution to enable the remote administration for CUPs.We are happy that your problem has been solved.

    Regards,
    Mohammad

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Register here