PowerFail, Corrupt SD, SD Protect not in HiFi Berry 2.46? & Stretch Incommicado

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions PowerFail, Corrupt SD, SD Protect not in HiFi Berry 2.46? & Stretch Incommicado

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 28. Juni 2018 at 22:27 #36398

    My only question is: the SD Protect add-on seems to be unavailable for max2play HiFi Berry 2.46? Is that intentional, is it a mistake, or is there some mystery way to install it?

    Because pulling the power plug without doing a shutdown Will corrupt the SD. Sooner or later, probably sooner. So the SD Protect add-on is wonderful assuming it works.

    The number of different versions have gotten a little confusing, not a big deal, I tried to install the new Stretch version, and it would not connect at all via an Ethernet cable connected to my router. The HiFi Berry version connected right away, and is doing it’s Squeezeplay job right now, but SD Protect is a requirement, not an option.

    Finally, I’ve noticed: „Connect by putting http://max2play/ in the URL field“. Since every browser that I’ve tried uses the URL field these days to double as Search, and that can result in a connection to the max2play.com website instead of the max2play software residing in the RPi. Sometimes it does work, and I guess that is when the RPi is connected to the router via an Ethernet cable(?). I think that Firefox has a parameter that can be flipped via „config:about“ to remove Search from the URL field, after all there’s another Search field that’s provided and specific to Search. After the RPi is connected to the network, the RPi’s IP address can be determined by logging into the router, and used with either Putty to get down and hack Linux, or by just putting the IP „dotted quad“ address into the famous URL/Search field and hitting Return. There is no uncertainty when the IP is used to connect. And it really is nice when the max2play image pops up! — and it’s not the website.

    29. Juni 2018 at 9:42 #36404

    Hi Mike,

    The SD card protection does not work with LMS. So if you have LMS installed, this is the reason why.

    You can also use the HTTP command for shutdown (displayed when you click it manually in the URL bar) to schedule or implement a correct shutdown without using the web interface.

    What is the exact error you get when you try to install the SD card protection?

    Regarding URL bar access to max2play: the slash at the end „max2play/“ should indicate that it is not a search request. At least this is the case with most browsers.

    30. Juni 2018 at 17:24 #36419

    Hi Heiner, and as always thanks for your quick response and support!

    1. Which versions of m2p for the RPi have SD Protect as an add-on? The only ones I have found are for ODROID.
    And, by the way, LMS in the HiFiBerry version is optional, so SD Protect should be available in that version, as well.

    Ok, so here’s what I really think: SD Power Protection is a Requirement. (period). Without it the Max2Play RPi is like a car that whenever it’s turned off can’t be started again until a tow truck is called to haul it to a garage where it can be fixed and started again. How acceptable would that be?

    If someone can’t fix LMS then do this: create a simple RPi voltage threshhold detector, a super-cheap little RPi plug in, either generate an interrupt or, better yet, a voltage out-of-tolerance flag so that, when the voltage is too low the M2P Executive can suspend normal operation until the voltage is back in tolerance. It’s that easy.

    2. http://max2play/ Here’s my theory: When a new m2p rpi is ethernet cabled into a system that has another m2p rpi there is a problem using http://max2play/ in a browser, the browser connection can’t be made because the address can’t be resolved even through the existing m2p rpi has had it’s name changed to, eg, „Big Blue“. „Big Blue“ of the existing device is different than the new one’s „max2play“ yet the browser doesn’t think they’re different.

    This is what I’ve observed, yesterday: Firefox goes to http://max2play.com (with Google Search enabled) in the URL field. Chrome keeps max2play/ in the URL field, and displays:
    „This site can’t be reached
    max2play’s server IP address could not be found.
    Did you mean http://max2play.com/?
    Search Google for max2play
    ERR_NAME_NOT_RESOLVED“

    „Big Blue“ is not responding correctly so that it’s address can be differentiated from the „max2play“ address? A little more work to fix.
    I don’t think it’s acceptable to turn off every m2p device on a network just to add a new one, I never have.

    Logging into the router to determine the IP addresses of every connected device including the new cable-connected m2p device, and using that in a browser URL field works always.

    That’s my 0.02Euro,
    Mike

    9. Juli 2018 at 14:28 #36496

    Hi Mike,

    Thanks for the detailed feedback and sorry about the late response, I was on holiday until yesterday.

    1. The Add-On works with all Pi images. The install link is: http://shop.max2play.com/media/downloadable/currentversion/sdcardprotection.tar

    We recommend running the Pi LMS continuously in your local network as the server unit. The Pi has no problem running 24/7 and the power usage is minimal (under 10€ a year with the 3B). However, if you want to securely shut down your Pi, you can schedule the shutdown command with any software you like through the Max2Play http request: http://max2play/plugins/max2play_settings/controller/Basic.php?action=shutdown

    2. You need to reboot the device after renaming it. Is that the issue? Afterwards, your router should reassign the name if the device. If this is not the case, please try to reboot once more. You can also activate the network lookup (free feature in Settings/Reboot) to easily switch between web interfaces of your different Max2Play devices 😉

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here