Power off amplifier

This topic contains 11 replies, has 3 voices, and was last updated by  Matthew Carrington premium 4 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 30. October 2017 at 21:51 #32218

    I am using the HiFiBerry DAC+ Bundle to play music from a separate Squeezebox server. I built it from the supplied components turned it on and then specified the Advanced Squeezebox menu option in the setup and it all worked straightaway.

    I do have a small problem with it, after I power off the amplifier that it is plugged into it no longer works. If I power off the bundle and power on the amplifier and then power on the bundle it all works fine. So currently I have to leave my amplifier powered on all the time.

    Has anyone else had a similar problem ?

    1. November 2017 at 17:05 #32233

    Hi Matthew,

    First of all, thanks for the kind words on your first setup. This experience is what we hope for all our customers.

    On your issues, it sounds like this might be related to power supply. So if you have any USB periphery, try disconnecting for a test to see if the problem persists and activate USB max current in the Raspberry Settings.

    Also, try running the power supply of the Pi on a single outlet.

    11. November 2017 at 13:33 #32415

    Thanks for the reply. Unfortunately, the suggestions you made haven’t solved the problem.

    The problem is not related to power as the music stops after 3 hours of listening even with the max2play plugged into a completely separate power supply and the amplifier on all the time. So I think I mislead you to start with.

    Is there a timeout of 3 hours somewhere in the configuration ?

    13. November 2017 at 13:45 #32452

    Hi Matthew,

    You can make sure your hw volume control is set up properly. The advanced options’ command line options should include “hw:0” or “hw:1”, depending on whether you deactivated the build-in audio or not. If its inactive, please make sure it says “hw:0” and vice versa.

    13. November 2017 at 20:41 #32464

    Well that’s torn it!

    It doesn’t work at all now.

    I did the following … Under Audioplayer, I clicked Edit Advanced Options and I added the “hw:0” to the command line options. That failed so I tried “hw:1”. That failed. So I removed it so that command line options were blank as they had been before the changes. I rebooted but still no sound at all.

    So I selected ‘Reset configs to Max2Play delivery configuration’ from Settings/Reboot and then rebooted. Still no sound!

    Any ideas ?

    14. November 2017 at 13:33 #32478

    Hi Matthew,

    Please select none in your HiFiBerry Plugin, reboot the system, select your DAC again, reboot again.

    The complete command line options for hardware volume control are -o hw:0 -V Digital when you have build-in audio deactivated in the Raspberry Settings.

    Optimizing Squeezelite’s Volume Control

    18. November 2017 at 12:45 #32522

    Yes, that’s got things working again. Thanks for that.

    I applied the change to the command line options and these worked: -o hw:1 -V Digital

    Unfortunately, it still times out after 3 hours.

    20. November 2017 at 20:39 #32552

    Yes, that worked well. Thanks. The options I used were ‘-o hw:1 -V Digital’

    I have music again. Unfortunately, it still times out after 3 hours.

    Any other ideas ?

    28. November 2017 at 12:02 #32660

    Hi Matthew,

    Sorry about the late response.

    Please try playing music from a local source (USB drive or NAS share) to make sure that internet connectivity is not the source of this dropout after 3 hours.

    12. December 2017 at 19:22 #32912

    Hi,

    Sorry, I’m not sure I understand that one.

    Perhaps if I explain my setup, I had a Squeezebox SB3 connected to my amplifier and a separate Squeezebox server running on a Raspberry Pi with a locally attached USB Disk Drive. All the music files are local to the Squeezebox server. The setup has been running successfully for years.

    The SB3 stopped working so I purchased the max2play HiFiBerry DAC+ Bundle to be a drop in replacement.

    I have run a test using a squeezelite client (Squeezeplay) on my Mac and it connects to the squeezebox server and plays music continuously with any problems. It continues for more than 3 hours without any problems.

    Matthew

    12. December 2017 at 22:04 #32919

    Hello Matthew,

    it seems that there are two isolated problems you describe:

    1) M2P stops playing after powering off the amplifier –> this is 99% an EMI problem. Maybe the RPi looses connection because of the surge current of your amp (if there is an toroidal transformer inside, you have strong inductive currents in the moment of powering off the unit). That can cause a complete crash of the RPi or dac if it is installed nearby the amp. Maybe it helps to place the RPi far away from the amp and use an RCA noise filter (ground isolator) to prevent reverting signal peaks from your amp to the RPi.

    2) M2P stops playing after some time –> i read about similar problems on other players (just google for it) without a dedicated solution. There are a lot of possibilities which can cause this problem. Maybe it helps to set some specific settings in LMS: LMS/Settings/Player…on the audio tab for the selected M2P player, you can choose the behavior of the player if the stream is interrupted, e.g. “stop at power off, restart on power on”. Maybe that helps.

    Regards,
    Stefan

    19. December 2017 at 21:08 #33059

    Stefan,

    Thanks for your attempt to help. Unfortunately, you didn’t read the thread or you would have noticed that 1) is not a problem.

    As for 2), well, just google it, is not a solution that’s very helpful.

    Whilst I was googling for a solution, I have come across a number of threads, on this forum, that suggest switching over to piCorePlayer. I tried that and it worked immediately and carries on working after 3 hours.

    So many thanks for the hardware but you probably need to review your software.

    Matthew

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here