[SOLVED] Plop noise on start/stop using "alsa-utils"

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Plop noise on start/stop using "alsa-utils"

This topic contains 4 replies, has 2 voices, and was last updated by  wilfo premium 2 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 30. April 2018 at 16:13 #35391

    Hi Everyone,
    I am using HifiBerry-AMP and IQAudio- AMP on RasPi Stretch. Both give ugly plops.
    For instance:
    mplayer sound.wave –> „Plop“ … playing sound.wav … „Plop“
    Searching for workarounds, i found that this behaviour results from „power save“
    mechanisms with „alsa“.
    Does anybody know, if there is a solution meanwhile. Maybe one could switch-off „power save“
    generally for above AMP’s ?
    Thanks in advance
    Wilfried

    3. Mai 2018 at 9:52 #35504

    Hi Wilfried,

    This is not an issue other users have reported thus far.

    Please try adding „-C 5“ in your audioplayers‘ command line options.

    3. Mai 2018 at 15:24 #35515

    Hi Heiner,
    sorry but which player uses „-C 5“ and what for?
    Thanks, Wilfried

    7. Mai 2018 at 11:25 #35539

    Hi Wilfried,

    The parameter is a time buffer for the connection and can usually get rid of the plop noise.

    We mostly recommend it for Squeezelite as this is the primary audioplayer of our system.

    7. Mai 2018 at 12:43 #35552

    Hi Heiner,
    O.K now it’s clear; -C controls the closing of the sounddevice and
    thats exactly what gives me those ‚plops‘.
    Thanks so far
    Wilfried

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here